aboutsummaryrefslogtreecommitdiff
path: root/games/rottdc
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-12 18:22:24 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-12 18:22:24 +0000
commit0e2a619b3493ea63667946992571f7ddbe548068 (patch)
tree1b03bff624e55a88732c4b41e2e3453bbd3cbe12 /games/rottdc
parent6f3d81280186f24eb94b92eb4be1cd2465e25d02 (diff)
Notes
Diffstat (limited to 'games/rottdc')
-rw-r--r--games/rottdc/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/games/rottdc/Makefile b/games/rottdc/Makefile
index 8d4dbc3b1002..b2187a57fdb0 100644
--- a/games/rottdc/Makefile
+++ b/games/rottdc/Makefile
@@ -10,30 +10,24 @@ MASTER_SITES= SF/sdl-dc/${PORTNAME}/1.0-2
MAINTAINER= ports@FreeBSD.org
COMMENT= Apogee's Rise Of The Triad source port
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
USE_SDL= sdl mixer
PATCH_WRKSRC= ${WRKSRC}/rott
# Crashes when compiling with -O2 or greater, so downgrade to -O1.
CFLAGS:= ${CFLAGS:C/-O[2-9]/-O1/}
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-extract:
@${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
do-install:
.for f in rott rott-sw
- ${INSTALL_PROGRAM} ${WRKSRC}/${f}/rott ${PREFIX}/bin/${f}
-.endfor
-.ifndef (NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.for i in cheats cmdline
- ${INSTALL_DATA} ${WRKSRC}/rott/${i}.txt ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f}/rott ${STAGEDIR}${PREFIX}/bin/${f}
.endfor
-.endif
-
-post-install:
- @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/rott && ${INSTALL_DATA} cheats.txt cmdline.txt \
+ ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>