aboutsummaryrefslogtreecommitdiff
path: root/games/rtb/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-09-22 05:47:15 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-09-22 05:47:15 +0000
commit1d2b76d00c571df83ffeba7411cc8e507dcdff01 (patch)
treeb75527b6920775d3c3ae02c4632e6f473158db3c /games/rtb/Makefile
parentdbb8a2f271f8064caac2e0b8f6d262c52222eb11 (diff)
downloadports-1d2b76d00c571df83ffeba7411cc8e507dcdff01.tar.gz
ports-1d2b76d00c571df83ffeba7411cc8e507dcdff01.zip
Notes
Diffstat (limited to 'games/rtb/Makefile')
-rw-r--r--games/rtb/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index e1e13d6f03e5..2ad1d9e9f9cb 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -22,6 +22,7 @@ USE_GNOME= gnometarget gtk20 lthack
USE_GETOPT_LONG= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=13
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
@@ -29,11 +30,9 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
LDFLAGS= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
+post-extract:
+ @${REINPLACE_CMD} -e 's/min/Min/; s/max/Max/' ${WRKSRC}/include/Various.h
+ @${REINPLACE_CMD} -E -e 's/\(int\*\)/int\*/' ${WRKSRC}/src/ArenaRealTime.cc
post-install:
.if !defined(NOPORTDOCS)
@@ -43,4 +42,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/RealTimeBattle.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>