aboutsummaryrefslogtreecommitdiff
path: root/games/rtb
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-19 18:36:43 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-19 18:36:43 +0000
commitadb0fd3a7eab8176478e2a3de9a23227759729f0 (patch)
treebb6458a9fa14449f18a92afbcc73e75e226175c4 /games/rtb
parent408dde95f5384412909bf5cb415aed5de7cbd557 (diff)
downloadports-adb0fd3a7eab8176478e2a3de9a23227759729f0.tar.gz
ports-adb0fd3a7eab8176478e2a3de9a23227759729f0.zip
Notes
Diffstat (limited to 'games/rtb')
-rw-r--r--games/rtb/Makefile55
-rw-r--r--games/rtb/files/patch-team-framework__io__unixclientcommunicator.cpp10
-rw-r--r--games/rtb/files/patch-team-framework__io__unixinstreambuf.cpp11
-rw-r--r--games/rtb/files/patch-team-framework__io__unixoutstreambuf.cpp11
-rw-r--r--games/rtb/files/patch-team-framework__io__unixremoteclientconnection.cpp10
-rw-r--r--games/rtb/files/patch-team-framework__io__unixrtbconnection.cpp11
-rw-r--r--games/rtb/files/patch-team-framework__io__unixservercommunicator.cpp10
-rw-r--r--games/rtb/files/patch-team-framework__io__unixserverconnection.cpp12
-rw-r--r--games/rtb/files/patch-team-framework__stdnamespace.h16
-rw-r--r--games/rtb/pkg-plist47
10 files changed, 156 insertions, 37 deletions
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index 362207159cea..49aad9ad89be 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -3,60 +3,45 @@
PORTNAME= RealTimeBattle
PORTVERSION= 1.0.8
-PORTREVISION= 9
+DISTVERSIONSUFFIX= -Ext
+PORTREVISION= 10
CATEGORIES= games
-MASTER_SITES= SF${PORTNAME:}
-DISTNAME= ${PORTNAME}-${PORTVERSION}-Ext
+MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME}-1.0.x/${PORTNAME}%20${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Robot programming game for UNIX
+LICENSE= GPLv2 # (or later)
+
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
-USES= perl5 gmake pkgconfig
+OPTIONS_DEFINE= DOCS
+
USE_BZIP2= yes
+USES= gettext gmake perl5 pkgconfig
USE_GNOME= gtk20
USE_PYTHON= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-rtb-dir=${PREFIX}/lib/${PORTNAME}
-CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
+DESKTOP_ENTRIES="${PORTNAME}" "" "" "${PORTNAME:L}" "" ""
+
post-patch:
-.for file in configure
- @${REINPLACE_CMD} -e '/test/s| == | = |g ; \
- s|INCLUDED_LIBINTL=yes|INCLUDED_LIBINTL=no|g ; \
- s|\\$${top_builddir}/intl/libintl.a|-lintl|g' ${WRKSRC}/${file}
+.for i in configure
+ @${REINPLACE_CMD} -e 's|INCLUDED_LIBINTL=yes|INCLUDED_LIBINTL=no|g ; \
+ s|\\$${top_builddir}/intl/libintl.a|-lintl|g ; \
+ /^DOCS_DIR/s|=.*|=$${prefix}/share/doc/${PORTNAME}| ; \
+ /test/s| == | = |g' ${WRKSRC}/${i}
.endfor
-.for file in Makefile.in
- @${REINPLACE_CMD} -e '/^SUBDIRS/s|Documentation||g' ${WRKSRC}/${file}
+.for i in Documentation/Makefile.in
+ @${REINPLACE_CMD} -e '/COPYING/d' ${WRKSRC}/${i}
.endfor
-.for file in team-framework/createrobot.sh \
+.for i in team-framework/createrobot.sh \
team-framework/createrobotconf.sh
- @${REINPLACE_CMD} -e 's| sed| gsed|g' ${WRKSRC}/${file}
-.endfor
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in AUTHORS ChangeLog EXTRAROBOTS.README NEWS README TODO \
- Documentation/RealTimeBattle-1.html \
- Documentation/RealTimeBattle-2.html \
- Documentation/RealTimeBattle-3.html \
- Documentation/RealTimeBattle-4.html \
- Documentation/RealTimeBattle-5.html \
- Documentation/RealTimeBattle-6.html \
- Documentation/RealTimeBattle.html \
- Documentation/next.gif Documentation/prev.gif Documentation/toc.gif \
- Documentation/next.png Documentation/prev.png Documentation/toc.png \
- Documentation/RealTimeBattle.dvi \
- Documentation/RealTimeBattle.sgml \
- Documentation/RealTimeBattle.txt \
- Documentation/RTB-Team-Framework-Tutorial.tar.gz
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ @${REINPLACE_CMD} -e 's| sed| gsed|g' ${WRKSRC}/${i}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/games/rtb/files/patch-team-framework__io__unixclientcommunicator.cpp b/games/rtb/files/patch-team-framework__io__unixclientcommunicator.cpp
new file mode 100644
index 000000000000..5d914e2a784d
--- /dev/null
+++ b/games/rtb/files/patch-team-framework__io__unixclientcommunicator.cpp
@@ -0,0 +1,10 @@
+--- team-framework/io/unixclientcommunicator.cpp.orig
++++ team-framework/io/unixclientcommunicator.cpp
+@@ -46,6 +46,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
++#include <unistd.h>
+
+ /**
+ * Namespace
diff --git a/games/rtb/files/patch-team-framework__io__unixinstreambuf.cpp b/games/rtb/files/patch-team-framework__io__unixinstreambuf.cpp
new file mode 100644
index 000000000000..86e04ee85e1a
--- /dev/null
+++ b/games/rtb/files/patch-team-framework__io__unixinstreambuf.cpp
@@ -0,0 +1,11 @@
+--- team-framework/io/unixinstreambuf.cpp.orig
++++ team-framework/io/unixinstreambuf.cpp
+@@ -33,6 +33,8 @@
+ #include "../exceptions/confignotloadedexception.h"
+ #include <sstream>
+ #include <errno.h>
++#include <sys/types.h>
++#include <unistd.h>
+
+ /**
+ * Namespace
diff --git a/games/rtb/files/patch-team-framework__io__unixoutstreambuf.cpp b/games/rtb/files/patch-team-framework__io__unixoutstreambuf.cpp
new file mode 100644
index 000000000000..81869123dc0b
--- /dev/null
+++ b/games/rtb/files/patch-team-framework__io__unixoutstreambuf.cpp
@@ -0,0 +1,11 @@
+--- team-framework/io/unixoutstreambuf.cpp.orig
++++ team-framework/io/unixoutstreambuf.cpp
+@@ -30,6 +30,8 @@
+ #include "unixoutstreambuf.h"
+ #include <sstream>
+ #include <errno.h>
++#include <sys/types.h>
++#include <unistd.h>
+ /**
+ * Namespace
+ */
diff --git a/games/rtb/files/patch-team-framework__io__unixremoteclientconnection.cpp b/games/rtb/files/patch-team-framework__io__unixremoteclientconnection.cpp
new file mode 100644
index 000000000000..e8f7a6f79b4e
--- /dev/null
+++ b/games/rtb/files/patch-team-framework__io__unixremoteclientconnection.cpp
@@ -0,0 +1,10 @@
+--- team-framework/io/unixremoteclientconnection.cpp.orig
++++ team-framework/io/unixremoteclientconnection.cpp
+@@ -36,6 +36,7 @@
+ #include <iostream>
+ #include <sstream>
+ #include <ios>
++#include <unistd.h>
+
+ /**
+ * Namespace
diff --git a/games/rtb/files/patch-team-framework__io__unixrtbconnection.cpp b/games/rtb/files/patch-team-framework__io__unixrtbconnection.cpp
new file mode 100644
index 000000000000..c521d88e0a5d
--- /dev/null
+++ b/games/rtb/files/patch-team-framework__io__unixrtbconnection.cpp
@@ -0,0 +1,11 @@
+--- team-framework/io/unixrtbconnection.cpp.orig
++++ team-framework/io/unixrtbconnection.cpp
+@@ -33,6 +33,8 @@
+ #include <iostream>
+ #include <sstream>
+ #include <ios>
++#include <sys/types.h>
++#include <unistd.h>
+
+ /**
+ * Namespace
diff --git a/games/rtb/files/patch-team-framework__io__unixservercommunicator.cpp b/games/rtb/files/patch-team-framework__io__unixservercommunicator.cpp
new file mode 100644
index 000000000000..af828940de87
--- /dev/null
+++ b/games/rtb/files/patch-team-framework__io__unixservercommunicator.cpp
@@ -0,0 +1,10 @@
+--- team-framework/io/unixservercommunicator.cpp.orig
++++ team-framework/io/unixservercommunicator.cpp
+@@ -50,6 +50,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
++#include <unistd.h>
+
+ /**
+ * Namespace
diff --git a/games/rtb/files/patch-team-framework__io__unixserverconnection.cpp b/games/rtb/files/patch-team-framework__io__unixserverconnection.cpp
new file mode 100644
index 000000000000..b8e9c43280e8
--- /dev/null
+++ b/games/rtb/files/patch-team-framework__io__unixserverconnection.cpp
@@ -0,0 +1,12 @@
+--- team-framework/io/unixserverconnection.cpp.orig
++++ team-framework/io/unixserverconnection.cpp
+@@ -41,6 +41,9 @@
+ //IPC
+ #include <fcntl.h>
+
++#include <sys/types.h>
++#include <unistd.h>
++
+ /**
+ * Namespace
+ */
diff --git a/games/rtb/files/patch-team-framework__stdnamespace.h b/games/rtb/files/patch-team-framework__stdnamespace.h
new file mode 100644
index 000000000000..e50764b9532b
--- /dev/null
+++ b/games/rtb/files/patch-team-framework__stdnamespace.h
@@ -0,0 +1,16 @@
+--- team-framework/stdnamespace.h.orig
++++ team-framework/stdnamespace.h
+@@ -25,9 +25,13 @@
+
+ **************************************************************************/
+
++#if !defined(_LIBCPP_VERSION)
+ #include <iosfwd> // This file contains the forward declaration in particular of std::string
+
+ namespace std
+ {
+ template <class _Tp> class auto_ptr; // Origin: The header file <memory>
+ }
++#else
++#include <memory>
++#endif
diff --git a/games/rtb/pkg-plist b/games/rtb/pkg-plist
index a7aab844f947..9f7731025cc5 100644
--- a/games/rtb/pkg-plist
+++ b/games/rtb/pkg-plist
@@ -1,5 +1,6 @@
bin/realtimebattle
include/RealTimeBattle/Messagetypes.h
+info/RealTimeBattle.info
lib/RealTimeBattle/Arenas/Circle.arena
lib/RealTimeBattle/Arenas/Circles.arena
lib/RealTimeBattle/Arenas/Cross.arena
@@ -121,9 +122,38 @@ lib/RealTimeBattle/rtb_logo.jpg
lib/RealTimeBattle/rtblogo1024.jpg
lib/RealTimeBattle/rtblogo1600.jpg
lib/RealTimeBattle/tournament.txt
+%%PORTDOCS%%%%DOCSDIR%%/ABOUT-NLS
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/EXTRAROBOTS.README
+%%PORTDOCS%%%%DOCSDIR%%/French/RealTimeBattle-1.html
+%%PORTDOCS%%%%DOCSDIR%%/French/RealTimeBattle-2.html
+%%PORTDOCS%%%%DOCSDIR%%/French/RealTimeBattle-3.html
+%%PORTDOCS%%%%DOCSDIR%%/French/RealTimeBattle-4.html
+%%PORTDOCS%%%%DOCSDIR%%/French/RealTimeBattle-5.html
+%%PORTDOCS%%%%DOCSDIR%%/French/RealTimeBattle-6.html
+%%PORTDOCS%%%%DOCSDIR%%/French/RealTimeBattle.html
+%%PORTDOCS%%%%DOCSDIR%%/French/next.gif
+%%PORTDOCS%%%%DOCSDIR%%/French/prev.gif
+%%PORTDOCS%%%%DOCSDIR%%/French/toc.gif
+%%PORTDOCS%%%%DOCSDIR%%/German/RealTimeBattle-1.html
+%%PORTDOCS%%%%DOCSDIR%%/German/RealTimeBattle-2.html
+%%PORTDOCS%%%%DOCSDIR%%/German/RealTimeBattle-3.html
+%%PORTDOCS%%%%DOCSDIR%%/German/RealTimeBattle-4.html
+%%PORTDOCS%%%%DOCSDIR%%/German/RealTimeBattle-5.html
+%%PORTDOCS%%%%DOCSDIR%%/German/RealTimeBattle-6.html
+%%PORTDOCS%%%%DOCSDIR%%/German/RealTimeBattle.dvi
+%%PORTDOCS%%%%DOCSDIR%%/German/RealTimeBattle.html
+%%PORTDOCS%%%%DOCSDIR%%/German/RealTimeBattle.info
+%%PORTDOCS%%%%DOCSDIR%%/German/RealTimeBattle.sgml
+%%PORTDOCS%%%%DOCSDIR%%/German/RealTimeBattle.txt
+%%PORTDOCS%%%%DOCSDIR%%/German/next.gif
+%%PORTDOCS%%%%DOCSDIR%%/German/next.png
+%%PORTDOCS%%%%DOCSDIR%%/German/prev.gif
+%%PORTDOCS%%%%DOCSDIR%%/German/prev.png
+%%PORTDOCS%%%%DOCSDIR%%/German/toc.gif
+%%PORTDOCS%%%%DOCSDIR%%/German/toc.png
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/RTB-Team-Framework-Tutorial.tar.gz
@@ -137,6 +167,16 @@ lib/RealTimeBattle/tournament.txt
%%PORTDOCS%%%%DOCSDIR%%/RealTimeBattle.html
%%PORTDOCS%%%%DOCSDIR%%/RealTimeBattle.sgml
%%PORTDOCS%%%%DOCSDIR%%/RealTimeBattle.txt
+%%PORTDOCS%%%%DOCSDIR%%/Spanish/next.gif
+%%PORTDOCS%%%%DOCSDIR%%/Spanish/prev.gif
+%%PORTDOCS%%%%DOCSDIR%%/Spanish/rtb-docs-1.0.5-es-1.html
+%%PORTDOCS%%%%DOCSDIR%%/Spanish/rtb-docs-1.0.5-es-2.html
+%%PORTDOCS%%%%DOCSDIR%%/Spanish/rtb-docs-1.0.5-es-3.html
+%%PORTDOCS%%%%DOCSDIR%%/Spanish/rtb-docs-1.0.5-es-4.html
+%%PORTDOCS%%%%DOCSDIR%%/Spanish/rtb-docs-1.0.5-es-5.html
+%%PORTDOCS%%%%DOCSDIR%%/Spanish/rtb-docs-1.0.5-es-6.html
+%%PORTDOCS%%%%DOCSDIR%%/Spanish/rtb-docs-1.0.5-es.html
+%%PORTDOCS%%%%DOCSDIR%%/Spanish/toc.gif
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/next.gif
%%PORTDOCS%%%%DOCSDIR%%/next.png
@@ -153,10 +193,13 @@ share/locale/ja/LC_MESSAGES/RealTimeBattle.mo
share/locale/pl/LC_MESSAGES/RealTimeBattle.mo
share/locale/pt/LC_MESSAGES/RealTimeBattle.mo
share/locale/sv/LC_MESSAGES/RealTimeBattle.mo
-@dirrmtry share/locale/en@boldquot/LC_MESSAGES
-@dirrmtry share/locale/en@boldquot
@dirrmtry share/locale/en@quot/LC_MESSAGES
@dirrmtry share/locale/en@quot
+@dirrmtry share/locale/en@boldquot/LC_MESSAGES
+@dirrmtry share/locale/en@boldquot
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/Spanish
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/German
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/French
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/RealTimeBattle/Robots/xt-bot
@dirrm lib/RealTimeBattle/Robots/thomas2