aboutsummaryrefslogtreecommitdiff
path: root/games/rtb
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-14 07:10:49 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-14 07:10:49 +0000
commit5ff6465d5f5c490a5d979a38f8a52aa32fc5137e (patch)
tree39d7bd3940bf391d390786fb1f2a8a7564880779 /games/rtb
parent92f44904f6f7d24cfa0ea7e6967b4a15a9d3600b (diff)
downloadports-5ff6465d5f5c490a5d979a38f8a52aa32fc5137e.tar.gz
ports-5ff6465d5f5c490a5d979a38f8a52aa32fc5137e.zip
Notes
Diffstat (limited to 'games/rtb')
-rw-r--r--games/rtb/Makefile29
-rw-r--r--games/rtb/distinfo3
-rw-r--r--games/rtb/files/patch-Makefile.in20
-rw-r--r--games/rtb/files/patch-ab16
-rw-r--r--games/rtb/files/patch-ac16
-rw-r--r--games/rtb/files/patch-include::fdstream.h18
-rw-r--r--games/rtb/files/patch-po::Makefile.in.in11
-rw-r--r--games/rtb/files/patch-src::Makefile.in15
-rw-r--r--games/rtb/files/patch-src::String.cc10
-rw-r--r--games/rtb/pkg-plist99
10 files changed, 133 insertions, 104 deletions
diff --git a/games/rtb/Makefile b/games/rtb/Makefile
index 568aeacd01aa..08c2f9a585bb 100644
--- a/games/rtb/Makefile
+++ b/games/rtb/Makefile
@@ -6,23 +6,34 @@
#
PORTNAME= RealTimeBattle
-PORTVERSION= 1.0.4
-PORTREVISION= 2
+PORTVERSION= 1.0.6
CATEGORIES= games
-MASTER_SITES= http://www.lysator.liu.se/realtimebattle/Download/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.lysator.liu.se/realtimebattle/Download/
+MASTER_SITE_SUBDIR= ${PORTNAME:L}
MAINTAINER= ports@FreeBSD.org
COMMENT= Robot programming game for UNIX
+USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= gtk12
+USE_GNOME= gnometarget gtk20 lthack
+USE_GETOPT_LONG= yes
+USE_GMAKE= yes
USE_LIBTOOL_VER=13
-CONFIGURE_ARGS= --enable-debug
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
-.include <bsd.port.pre.mk>
+CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
+LDFLAGS= -L${LOCALBASE}/lib
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/RealTimeBattle.txt ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/rtb/distinfo b/games/rtb/distinfo
index 39ac04e752cb..874a41373617 100644
--- a/games/rtb/distinfo
+++ b/games/rtb/distinfo
@@ -1 +1,2 @@
-MD5 (RealTimeBattle-1.0.4.tar.gz) = 493e7599d18c5cde3cb27c54400cf7a8
+MD5 (RealTimeBattle-1.0.6.tar.bz2) = 46ef5733dc6e65121155463bd62ea2f3
+SIZE (RealTimeBattle-1.0.6.tar.bz2) = 397439
diff --git a/games/rtb/files/patch-Makefile.in b/games/rtb/files/patch-Makefile.in
new file mode 100644
index 000000000000..2cd03c5dbea1
--- /dev/null
+++ b/games/rtb/files/patch-Makefile.in
@@ -0,0 +1,20 @@
+--- Makefile.in.orig Sun Nov 23 03:44:31 2003
++++ Makefile.in Sat Mar 13 02:50:55 2004
+@@ -120,7 +120,7 @@
+ USE_NLS = @USE_NLS@
+ VERSION = @VERSION@
+
+-SUBDIRS = intl po include src doc
++SUBDIRS = intl po include src
+
+ realtimebattledocdir = ${prefix}/doc/RealTimeBattle
+ realtimebattledoc_DATA = README COPYING AUTHORS ChangeLog INSTALL NEWS TODO ABOUT-NLS
+@@ -374,7 +374,7 @@
+ install-exec-am:
+ install-exec: install-exec-recursive
+
+-install-data-am: install-realtimebattledocDATA
++install-data-am:
+ install-data: install-data-recursive
+
+ install-am: all-am
diff --git a/games/rtb/files/patch-ab b/games/rtb/files/patch-ab
deleted file mode 100644
index deb2150a6893..000000000000
--- a/games/rtb/files/patch-ab
+++ /dev/null
@@ -1,16 +0,0 @@
---- Documentation/Makefile.in.orig
-+++ Documentation/Makefile.in
-
-287,288c287,288
-< RealTimeBattle.html RealTimeBattle.dvi RealTimeBattle.info RealTimeBattle.txt \
-< note-files note-files-html
----
-> RealTimeBattle.html RealTimeBattle.dvi RealTimeBattle.info \
-> note-files
-292c292
-< RealTimeBattle.html note-files-html
----
-> RealTimeBattle.html
-295,296d294
-<
-< note-files-html: BUGS.html FAQ.html ChangeLog.html TODO.html CVS-Help.html
diff --git a/games/rtb/files/patch-ac b/games/rtb/files/patch-ac
deleted file mode 100644
index 6560cbf8b7e4..000000000000
--- a/games/rtb/files/patch-ac
+++ /dev/null
@@ -1,16 +0,0 @@
---- Documentation/Makefile.am.orig
-+++ Documentation/Makefile.am
-
-41,42c41,42
-< RealTimeBattle.html RealTimeBattle.dvi RealTimeBattle.info RealTimeBattle.txt \
-< note-files note-files-html
----
-> RealTimeBattle.html RealTimeBattle.dvi RealTimeBattle.info \
-> note-files
-46c46
-< RealTimeBattle.html note-files-html
----
-> RealTimeBattle.html
-49,50d48
-<
-< note-files-html: BUGS.html FAQ.html ChangeLog.html TODO.html CVS-Help.html
diff --git a/games/rtb/files/patch-include::fdstream.h b/games/rtb/files/patch-include::fdstream.h
new file mode 100644
index 000000000000..bbcf4906a665
--- /dev/null
+++ b/games/rtb/files/patch-include::fdstream.h
@@ -0,0 +1,18 @@
+--- include/fdstream.h.orig Thu Sep 18 02:35:57 2003
++++ include/fdstream.h Sat Mar 13 02:07:54 2004
+@@ -28,9 +28,15 @@
+ #ifndef BOOST_FDSTREAM_HPP
+ #define BOOST_FDSTREAM_HPP
+
++#if defined __GNUC__ && __GNUC__ < 3
++#include <istream.h>
++#include <ostream.h>
++#include <streambuf.h>
++#else
+ #include <istream>
+ #include <ostream>
+ #include <streambuf>
++#endif
+ // for EOF:
+ #include <cstdio>
+ // for memmove():
diff --git a/games/rtb/files/patch-po::Makefile.in.in b/games/rtb/files/patch-po::Makefile.in.in
new file mode 100644
index 000000000000..e927d41c9a7c
--- /dev/null
+++ b/games/rtb/files/patch-po::Makefile.in.in
@@ -0,0 +1,11 @@
+--- po/Makefile.in.in.orig Sat Apr 26 00:02:45 2003
++++ po/Makefile.in.in Sun Mar 14 10:29:29 2004
+@@ -29,7 +29,7 @@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
++mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
+
+ CC = @CC@
+ GMSGFMT = @GMSGFMT@
diff --git a/games/rtb/files/patch-src::Makefile.in b/games/rtb/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..8d9d72c2c7e5
--- /dev/null
+++ b/games/rtb/files/patch-src::Makefile.in
@@ -0,0 +1,15 @@
+--- src/Makefile.in.orig Sun Nov 23 03:44:31 2003
++++ src/Makefile.in Sat Mar 13 02:46:55 2004
+@@ -123,10 +123,10 @@
+ INCLUDES = $(GTK_CFLAGS) -I../include
+
+
+-realtimebattle_CFLAGS = -Wall -O2
++realtimebattle_CFLAGS = -Wall
+
+
+-realtimebattle_CXXFLAGS = -Wall -O2
++realtimebattle_CXXFLAGS = -Wall
+
+
+ bin_PROGRAMS = realtimebattle
diff --git a/games/rtb/files/patch-src::String.cc b/games/rtb/files/patch-src::String.cc
new file mode 100644
index 000000000000..436f856667f3
--- /dev/null
+++ b/games/rtb/files/patch-src::String.cc
@@ -0,0 +1,10 @@
+--- src/String.cc.orig Thu Sep 18 02:51:37 2003
++++ src/String.cc Sat Mar 13 02:12:19 2004
+@@ -25,6 +25,7 @@
+ #include <iostream>
+ //#include <strstream>
+ #include <iomanip>
++#include <stdio.h>
+ #include <stdlib.h>
+ #include <ctype.h>
+
diff --git a/games/rtb/pkg-plist b/games/rtb/pkg-plist
index 32bb92500e23..b013976883e2 100644
--- a/games/rtb/pkg-plist
+++ b/games/rtb/pkg-plist
@@ -1,68 +1,43 @@
-bin/RealTimeBattle
-games/RealTimeBattle/Arenas/Circle.arena
-games/RealTimeBattle/Arenas/Circles.arena
-games/RealTimeBattle/Arenas/Cross.arena
-games/RealTimeBattle/Arenas/Diamond.arena
-games/RealTimeBattle/Arenas/Flower.arena
-games/RealTimeBattle/Arenas/Forest.arena
-games/RealTimeBattle/Arenas/Labyrinth.arena
-games/RealTimeBattle/Arenas/Nippon.arena
-games/RealTimeBattle/Arenas/Pool.arena
-games/RealTimeBattle/Arenas/Rooms.arena
-games/RealTimeBattle/Arenas/Square.arena
-games/RealTimeBattle/Arenas/Star.arena
-games/RealTimeBattle/Arenas/Triangle.arena
-games/RealTimeBattle/Robots/empty.robot
-games/RealTimeBattle/Robots/empty/empty.c
-games/RealTimeBattle/Robots/empty/Makefile.am
-games/RealTimeBattle/Robots/rotate_and_fire_signal.robot
-games/RealTimeBattle/Robots/rotate_and_fire_blocking.robot
-games/RealTimeBattle/Robots/rotate_and_fire_select.robot
-games/RealTimeBattle/Robots/rotate_and_fire/rotate_and_fire.cc
-games/RealTimeBattle/Robots/rotate_and_fire/rotate_and_fire.h
-games/RealTimeBattle/Robots/rotate_and_fire/rotate_and_fire_signal.cc
-games/RealTimeBattle/Robots/rotate_and_fire/rotate_and_fire_blocking.cc
-games/RealTimeBattle/Robots/rotate_and_fire/rotate_and_fire_select.cc
-games/RealTimeBattle/Robots/rotate_and_fire/Makefile.am
-games/RealTimeBattle/Robots/seek_and_destroy.robot
-games/RealTimeBattle/Robots/seek_and_destroy/seek_and_destroy.cc
-games/RealTimeBattle/Robots/seek_and_destroy/Makefile.am
-games/RealTimeBattle/Documentation/RealTimeBattle-1.html
-games/RealTimeBattle/Documentation/RealTimeBattle-2.html
-games/RealTimeBattle/Documentation/RealTimeBattle-3.html
-games/RealTimeBattle/Documentation/RealTimeBattle-4.html
-games/RealTimeBattle/Documentation/RealTimeBattle-5.html
-games/RealTimeBattle/Documentation/RealTimeBattle-6.html
-games/RealTimeBattle/Documentation/RealTimeBattle.html
-games/RealTimeBattle/Documentation/next.gif
-games/RealTimeBattle/Documentation/prev.gif
-games/RealTimeBattle/Documentation/toc.gif
-games/RealTimeBattle/Documentation/RealTimeBattle.dvi
-games/RealTimeBattle/Messagetypes.h
-games/RealTimeBattle/RealTimeBattle.xpm
-games/RealTimeBattle/tournament.txt
-games/RealTimeBattle/ABOUT-NLS
-games/RealTimeBattle/BUGS
-games/RealTimeBattle/FAQ
-games/RealTimeBattle/TODO
-games/RealTimeBattle/README
-games/RealTimeBattle/INSTALL
-games/RealTimeBattle/ChangeLog
-games/RealTimeBattle/CVS-Help
-include/Messagetypes.h
-@unexec install-info --delete %D/info/RealTimeBattle.info.gz %D/info/dir
-info/RealTimeBattle.info.gz
+bin/realtimebattle
+include/RealTimeBattle/ArenaBase.h
+include/RealTimeBattle/ArenaController.h
+include/RealTimeBattle/ArenaRealTime.h
+include/RealTimeBattle/ArenaReplay.h
+include/RealTimeBattle/ArenaWindow.h
+include/RealTimeBattle/ControlWindow.h
+include/RealTimeBattle/Dialog.h
+include/RealTimeBattle/Extras.h
+include/RealTimeBattle/GeometricalObjects.h
+include/RealTimeBattle/Gui.h
+include/RealTimeBattle/IntlDefs.h
+include/RealTimeBattle/List.h
+include/RealTimeBattle/MessageWindow.h
+include/RealTimeBattle/Messagetypes.h
+include/RealTimeBattle/MovingObject.h
+include/RealTimeBattle/Options.h
+include/RealTimeBattle/OptionsWindow.h
+include/RealTimeBattle/Robot.h
+include/RealTimeBattle/ScoreWindow.h
+include/RealTimeBattle/Shape.h
+include/RealTimeBattle/Shot.h
+include/RealTimeBattle/StartTournamentWindow.h
+include/RealTimeBattle/StatisticsWindow.h
+include/RealTimeBattle/String.h
+include/RealTimeBattle/Structs.h
+include/RealTimeBattle/Timer.h
+include/RealTimeBattle/Various.h
+include/RealTimeBattle/Vector2D.h
+include/RealTimeBattle/Wall.h
+include/RealTimeBattle/fdstream.h
share/locale/de/LC_MESSAGES/RealTimeBattle.mo
+share/locale/es/LC_MESSAGES/RealTimeBattle.mo
share/locale/gl/LC_MESSAGES/RealTimeBattle.mo
share/locale/ja/LC_MESSAGES/RealTimeBattle.mo
share/locale/pl/LC_MESSAGES/RealTimeBattle.mo
share/locale/pt/LC_MESSAGES/RealTimeBattle.mo
share/locale/sv/LC_MESSAGES/RealTimeBattle.mo
-@dirrm games/RealTimeBattle/Robots/empty
-@dirrm games/RealTimeBattle/Robots/rotate_and_fire
-@dirrm games/RealTimeBattle/Robots/seek_and_destroy
-@dirrm games/RealTimeBattle/Arenas
-@dirrm games/RealTimeBattle/Documentation
-@dirrm games/RealTimeBattle/Robots
-@dirrm games/RealTimeBattle
-@dirrm games
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/RealTimeBattle.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/RealTimeBattle