aboutsummaryrefslogtreecommitdiff
path: root/games/rtcw-paks
diff options
context:
space:
mode:
authorNik Clayton <nik@FreeBSD.org>2002-03-02 22:44:05 +0000
committerNik Clayton <nik@FreeBSD.org>2002-03-02 22:44:05 +0000
commitc4802b7cf8fcafe6cedbf2174f2eee32b33a9f6b (patch)
tree59c1253cb26dde03d10466318b56944332a2a2d5 /games/rtcw-paks
parent890c808240d2b41dce6f5a2c8fb13ca966644630 (diff)
downloadports-c4802b7cf8fcafe6cedbf2174f2eee32b33a9f6b.tar.gz
ports-c4802b7cf8fcafe6cedbf2174f2eee32b33a9f6b.zip
Notes
Diffstat (limited to 'games/rtcw-paks')
-rw-r--r--games/rtcw-paks/Makefile49
-rw-r--r--games/rtcw-paks/pkg-comment1
-rw-r--r--games/rtcw-paks/pkg-descr4
-rw-r--r--games/rtcw-paks/pkg-plist6
4 files changed, 60 insertions, 0 deletions
diff --git a/games/rtcw-paks/Makefile b/games/rtcw-paks/Makefile
new file mode 100644
index 000000000000..5d34b587df83
--- /dev/null
+++ b/games/rtcw-paks/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: Return to Castle Wolfenstein paks
+# Date created: Sat Jul 15 14:27:16 SAST 2000
+# Whom: nik@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= rtcw-paks
+PORTVERSION= 1.0
+CATEGORIES= games linux
+MASTER_SITES= #
+DISTFILES= mp_pak0.pk3 mp_pak1.pk3 mp_pak2.pk3 \
+ pak0.pk3 \
+ sp_pak1.pk3 sp_pak2.pk3
+DIST_SUBDIR= rtcw-paks
+IGNOREFILES= ${ALLFILES}
+
+MAINTAINER= nik@FreeBSD.org
+
+# Make this a BUILD_ rather than a RUN_DEPEND so that it can create the
+# directory hierarchy for us.
+BUILD_DEPENDS= ${PREFIX}/usr/games/rtcw/wolf.x86:${PORTSDIR}/games/rtcw
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX_PREFIX= yes
+EXTRACT_ONLY= # Don't extract anything
+STRIP=
+
+GAMEDIR= ${PREFIX}/usr/games/rtcw/
+
+.include <bsd.port.pre.mk>
+
+.for file in ${DISTFILES}
+.if !exists(${DISTDIR}/rtcw-paks/${file})
+IGNORE=You must manually copy all the .pk3 files from the main/ directory of an installed version of the game to the ${DISTDIR}/rtcw-paks directory and then run make again.
+.endif
+.endfor
+
+# Do nothing for the build. Don't set NO_BUILD because of the earlier
+# BUILD_DEPENDS
+do-build:
+
+do-install:
+ ${MKDIR} -p ${GAMEDIR}/main
+.for file in ${DISTFILES}
+ ${INSTALL_DATA} ${DISTDIR}/rtcw-paks/${file} ${GAMEDIR}/main
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/games/rtcw-paks/pkg-comment b/games/rtcw-paks/pkg-comment
new file mode 100644
index 000000000000..723f7449d268
--- /dev/null
+++ b/games/rtcw-paks/pkg-comment
@@ -0,0 +1 @@
+Return to Castle Wolfenstein for Linux .pk3 files
diff --git a/games/rtcw-paks/pkg-descr b/games/rtcw-paks/pkg-descr
new file mode 100644
index 000000000000..0e042a374f2d
--- /dev/null
+++ b/games/rtcw-paks/pkg-descr
@@ -0,0 +1,4 @@
+Return to Castle Wolfenstein for Linux, .pk3 files
+
+This port encapsulates the .pk3 files for RTCW that are used to complete
+the installation of the game (including the dedicated server).
diff --git a/games/rtcw-paks/pkg-plist b/games/rtcw-paks/pkg-plist
new file mode 100644
index 000000000000..a9c76a4bde87
--- /dev/null
+++ b/games/rtcw-paks/pkg-plist
@@ -0,0 +1,6 @@
+usr/games/rtcw/main/mp_pak0.pk3
+usr/games/rtcw/main/mp_pak1.pk3
+usr/games/rtcw/main/mp_pak2.pk3
+usr/games/rtcw/main/pak0.pk3
+usr/games/rtcw/main/sp_pak1.pk3
+usr/games/rtcw/main/sp_pak2.pk3