aboutsummaryrefslogtreecommitdiff
path: root/games/sampsvr
diff options
context:
space:
mode:
authorAlexander Logvinov <avl@FreeBSD.org>2009-10-22 11:28:10 +0000
committerAlexander Logvinov <avl@FreeBSD.org>2009-10-22 11:28:10 +0000
commitd830a5e2e91aad2f3a04845fb3265d338b2f932c (patch)
tree13f3a6e3cadcdec6bccba22d68d6d783ed0df24d /games/sampsvr
parenta460ef1b57ca21eb40d427c78619bfcd6d097d4a (diff)
downloadports-d830a5e2e91aad2f3a04845fb3265d338b2f932c.tar.gz
ports-d830a5e2e91aad2f3a04845fb3265d338b2f932c.zip
Notes
Diffstat (limited to 'games/sampsvr')
-rw-r--r--games/sampsvr/Makefile18
-rw-r--r--games/sampsvr/distinfo6
-rw-r--r--games/sampsvr/pkg-plist138
3 files changed, 104 insertions, 58 deletions
diff --git a/games/sampsvr/Makefile b/games/sampsvr/Makefile
index 3b4b706cbfca..d98e563ca923 100644
--- a/games/sampsvr/Makefile
+++ b/games/sampsvr/Makefile
@@ -5,24 +5,24 @@
# $FreeBSD$
PORTNAME= sampsvr
-PORTVERSION= 0.2.3
+PORTVERSION= 0.3a
CATEGORIES= games linux
MASTER_SITES= http://files.sa-mp.com/
-DISTNAME= samp02Xsvr
+DISTNAME= samp${PORTVERSION:S,.,,}svr
MAINTAINER= avl@FreeBSD.org
COMMENT= Rockstar's GTA: San Andreas multiplayer modification dedicated server
USE_LINUX= yes
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${DISTNAME:S,svr,,}
-USE_DOS2UNIX= *.txt *.pwn
+WRKSRC= ${WRKDIR}/${DISTNAME:S,asvr,,}
+USE_DOS2UNIX= *.txt *.pwn *.inc
USE_RC_SUBR= sampd
SAMPDIR= ${PREFIX}/libexec/${PORTNAME}
-PORTDOCS= README
-PLIST_SUB= SAMPDIR="${SAMPDIR:S,^${PREFIX}/,,}" SAMPBIN=${DISTNAME}
+PORTDOCS= LICENSE README
+PLIST_SUB= SAMPDIR="${SAMPDIR:S,^${PREFIX}/,,}"
SUB_FILES= pkg-message
-SUB_LIST= SAMPDIR="${SAMPDIR}" SAMPBIN=${DISTNAME}
+SUB_LIST= SAMPDIR="${SAMPDIR}" SAMPBIN=samp03svr
.if !defined(NOPORTDOCS)
SUB_LIST+= NOTEWORK="Read ${DOCSDIR}/README to configure SA-MP Server"
.else
@@ -33,7 +33,7 @@ SUB_LIST+= NOTEWORK=""
do-install:
${MKDIR} ${SAMPDIR}
-.for i in ${DISTNAME} announce
+.for i in announce samp-npc samp03svr
${BRANDELF} -t Linux ${WRKSRC}/${i}
${INSTALL_PROGRAM} ${WRKSRC}/${i} ${SAMPDIR}
.endfor
@@ -41,7 +41,7 @@ do-install:
cd ${WRKSRC} && \
${FIND} . -type d ! -empty -exec \
${MKDIR} "${DATADIR}/{}" \;
-.for i in filterscripts gamemodes scriptfiles
+.for i in filterscripts gamemodes include npcmodes scriptfiles
cd ${WRKSRC} && \
${FIND} ${i} -type f -exec \
${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
diff --git a/games/sampsvr/distinfo b/games/sampsvr/distinfo
index 9b14ea86dd59..27e88540aa15 100644
--- a/games/sampsvr/distinfo
+++ b/games/sampsvr/distinfo
@@ -1,3 +1,3 @@
-MD5 (samp02Xsvr.tar.gz) = b466193afd886aac9ec48f19c55d8947
-SHA256 (samp02Xsvr.tar.gz) = 185c51e58976546496a9fe818d9da29a9d4064514957085e6a80df75ffae7289
-SIZE (samp02Xsvr.tar.gz) = 632308
+MD5 (samp03asvr.tar.gz) = 912ad517c415714ae24afc3ec8187854
+SHA256 (samp03asvr.tar.gz) = 5bf91e1d2a75cf5a0092bd461f8c7e5fadfaf45957b7e85c7868e1637393cf0f
+SIZE (samp03asvr.tar.gz) = 1343888
diff --git a/games/sampsvr/pkg-plist b/games/sampsvr/pkg-plist
index 9710d80247ff..1d649a2d9146 100644
--- a/games/sampsvr/pkg-plist
+++ b/games/sampsvr/pkg-plist
@@ -1,67 +1,113 @@
@unexec if cmp -s %D/etc/sampsvr.cfg %D/etc/sampsvr.cfg.dist; then rm -f %D/etc/sampsvr.cfg; fi
etc/sampsvr.cfg.dist
@exec [ -f %B/sampsvr.cfg ] || cp %B/%f %B/sampsvr.cfg
-%%SAMPDIR%%/%%SAMPBIN%%
%%SAMPDIR%%/announce
+%%SAMPDIR%%/samp-npc
+%%SAMPDIR%%/samp03svr
%%SAMPDIR%%/server.cfg
%%SAMPDIR%%/filterscripts
+%%SAMPDIR%%/include
%%SAMPDIR%%/gamemodes
+%%SAMPDIR%%/npcmodes
%%SAMPDIR%%/scriptfiles
-%%DATADIR%%/filterscripts/actions.amx
-%%DATADIR%%/filterscripts/actions.pwn
%%DATADIR%%/filterscripts/adminspec.amx
%%DATADIR%%/filterscripts/adminspec.pwn
-%%DATADIR%%/filterscripts/olddance.pwn
-%%DATADIR%%/filterscripts/vactions.pwn
-%%DATADIR%%/filterscripts/vactions.amx
-%%DATADIR%%/gamemodes/area51.amx
-%%DATADIR%%/gamemodes/area51.pwn
+%%DATADIR%%/filterscripts/base.amx
+%%DATADIR%%/filterscripts/base.pwn
+%%DATADIR%%/filterscripts/baseaf.amx
+%%DATADIR%%/filterscripts/baseaf.pwn
+%%DATADIR%%/filterscripts/fsdebug.amx
+%%DATADIR%%/filterscripts/fsdebug.pwn
+%%DATADIR%%/filterscripts/gl_actions.amx
+%%DATADIR%%/filterscripts/gl_actions.pwn
+%%DATADIR%%/filterscripts/gl_chatbubble.amx
+%%DATADIR%%/filterscripts/gl_chatbubble.pwn
+%%DATADIR%%/filterscripts/gl_npcs.amx
+%%DATADIR%%/filterscripts/gl_npcs.pwn
+%%DATADIR%%/filterscripts/gl_property.amx
+%%DATADIR%%/filterscripts/gl_property.pwn
+%%DATADIR%%/filterscripts/gl_realtime.amx
+%%DATADIR%%/filterscripts/gl_realtime.pwn
+%%DATADIR%%/filterscripts/menutest.amx
+%%DATADIR%%/filterscripts/menutest.pwn
+%%DATADIR%%/filterscripts/npc_record.amx
+%%DATADIR%%/filterscripts/npc_record.pwn
+%%DATADIR%%/filterscripts/test_cmds.amx
+%%DATADIR%%/filterscripts/test_cmds.pwn
+%%DATADIR%%/gamemodes/bare.amx
+%%DATADIR%%/gamemodes/bare.pwn
%%DATADIR%%/gamemodes/barron.amx
%%DATADIR%%/gamemodes/barron.pwn
-%%DATADIR%%/gamemodes/cng.amx
-%%DATADIR%%/gamemodes/cng.pwn
-%%DATADIR%%/gamemodes/freighter.amx
-%%DATADIR%%/gamemodes/freighter.pwn
-%%DATADIR%%/gamemodes/ls-parachute.amx
-%%DATADIR%%/gamemodes/ls-parachute.pwn
+%%DATADIR%%/gamemodes/grandlarc.amx
+%%DATADIR%%/gamemodes/grandlarc.pwn
%%DATADIR%%/gamemodes/lvdm.amx
%%DATADIR%%/gamemodes/lvdm.pwn
-%%DATADIR%%/gamemodes/lyse.amx
-%%DATADIR%%/gamemodes/lyse.pwn
-%%DATADIR%%/gamemodes/manhunt-lv.amx
-%%DATADIR%%/gamemodes/manhunt-lv.pwn
-%%DATADIR%%/gamemodes/minigunmadness.amx
-%%DATADIR%%/gamemodes/minigunmadness.pwn
-%%DATADIR%%/gamemodes/monster.amx
-%%DATADIR%%/gamemodes/monster.pwn
%%DATADIR%%/gamemodes/rivershell.amx
%%DATADIR%%/gamemodes/rivershell.pwn
-%%DATADIR%%/gamemodes/rivershell2.amx
-%%DATADIR%%/gamemodes/sftdm.amx
-%%DATADIR%%/gamemodes/sftdm.pwn
-%%DATADIR%%/gamemodes/sniper.amx
-%%DATADIR%%/gamemodes/sniper.pwn
-%%DATADIR%%/gamemodes/timertest.pwn
%%DATADIR%%/gamemodes/timertest.amx
-%%DATADIR%%/scriptfiles/vehiclelists/README.txt
-%%DATADIR%%/scriptfiles/vehiclelists/bone.txt
-%%DATADIR%%/scriptfiles/vehiclelists/flint.txt
-%%DATADIR%%/scriptfiles/vehiclelists/ls_airport.txt
-%%DATADIR%%/scriptfiles/vehiclelists/ls_gen_inner.txt
-%%DATADIR%%/scriptfiles/vehiclelists/ls_gen_outer.txt
-%%DATADIR%%/scriptfiles/vehiclelists/ls_law.txt
-%%DATADIR%%/scriptfiles/vehiclelists/lv_airport.txt
-%%DATADIR%%/scriptfiles/vehiclelists/lv_gen.txt
-%%DATADIR%%/scriptfiles/vehiclelists/lv_law.txt
-%%DATADIR%%/scriptfiles/vehiclelists/red_county.txt
-%%DATADIR%%/scriptfiles/vehiclelists/sf_airport.txt
-%%DATADIR%%/scriptfiles/vehiclelists/sf_gen.txt
-%%DATADIR%%/scriptfiles/vehiclelists/sf_law.txt
-%%DATADIR%%/scriptfiles/vehiclelists/tierra.txt
-%%DATADIR%%/scriptfiles/vehiclelists/whetstone.txt
-@dirrmtry %%DATADIR%%/gamemodes
+%%DATADIR%%/gamemodes/timertest.pwn
+%%DATADIR%%/include/gl_common.inc
+%%DATADIR%%/include/gl_spawns.inc
+%%DATADIR%%/npcmodes/at400_ls.amx
+%%DATADIR%%/npcmodes/at400_ls.pwn
+%%DATADIR%%/npcmodes/at400_lv.amx
+%%DATADIR%%/npcmodes/at400_lv.pwn
+%%DATADIR%%/npcmodes/at400_sf.amx
+%%DATADIR%%/npcmodes/at400_sf.pwn
+%%DATADIR%%/npcmodes/mat_test.amx
+%%DATADIR%%/npcmodes/mat_test.pwn
+%%DATADIR%%/npcmodes/npcidle.amx
+%%DATADIR%%/npcmodes/npcidle.pwn
+%%DATADIR%%/npcmodes/npctest.amx
+%%DATADIR%%/npcmodes/npctest.pwn
+%%DATADIR%%/npcmodes/onfoot_test.amx
+%%DATADIR%%/npcmodes/onfoot_test.pwn
+%%DATADIR%%/npcmodes/recordings/1031test.rec
+%%DATADIR%%/npcmodes/recordings/at400_ls_to_lv_x1.rec
+%%DATADIR%%/npcmodes/recordings/at400_lv_to_sf_x1.rec
+%%DATADIR%%/npcmodes/recordings/at400_sf_to_ls_x1.rec
+%%DATADIR%%/npcmodes/recordings/train_ls_to_sf1.rec
+%%DATADIR%%/npcmodes/recordings/train_lv_to_ls1.rec
+%%DATADIR%%/npcmodes/recordings/train_sf_to_lv1.rec
+%%DATADIR%%/npcmodes/recordings/truth1.rec
+%%DATADIR%%/npcmodes/taxi_ls_test.amx
+%%DATADIR%%/npcmodes/taxi_ls_test.pwn
+%%DATADIR%%/npcmodes/train_ls.amx
+%%DATADIR%%/npcmodes/train_ls.pwn
+%%DATADIR%%/npcmodes/train_lv.amx
+%%DATADIR%%/npcmodes/train_lv.pwn
+%%DATADIR%%/npcmodes/train_sf.amx
+%%DATADIR%%/npcmodes/train_sf.pwn
+%%DATADIR%%/scriptfiles/properties/banks.txt
+%%DATADIR%%/scriptfiles/properties/businesses.txt
+%%DATADIR%%/scriptfiles/properties/houses.txt
+%%DATADIR%%/scriptfiles/properties/interiors.txt
+%%DATADIR%%/scriptfiles/properties/police.txt
+%%DATADIR%%/scriptfiles/vehicles/bone.txt
+%%DATADIR%%/scriptfiles/vehicles/flint.txt
+%%DATADIR%%/scriptfiles/vehicles/ls_airport.txt
+%%DATADIR%%/scriptfiles/vehicles/ls_gen_inner.txt
+%%DATADIR%%/scriptfiles/vehicles/ls_gen_outer.txt
+%%DATADIR%%/scriptfiles/vehicles/ls_law.txt
+%%DATADIR%%/scriptfiles/vehicles/lv_airport.txt
+%%DATADIR%%/scriptfiles/vehicles/lv_gen.txt
+%%DATADIR%%/scriptfiles/vehicles/lv_law.txt
+%%DATADIR%%/scriptfiles/vehicles/pilots.txt
+%%DATADIR%%/scriptfiles/vehicles/red_county.txt
+%%DATADIR%%/scriptfiles/vehicles/sf_airport.txt
+%%DATADIR%%/scriptfiles/vehicles/sf_gen.txt
+%%DATADIR%%/scriptfiles/vehicles/sf_law.txt
+%%DATADIR%%/scriptfiles/vehicles/sf_train.txt
+%%DATADIR%%/scriptfiles/vehicles/tierra.txt
+%%DATADIR%%/scriptfiles/vehicles/trains.txt
+%%DATADIR%%/scriptfiles/vehicles/whetstone.txt
@dirrmtry %%DATADIR%%/filterscripts
-@dirrmtry %%DATADIR%%/scriptfiles/vehiclelists
+@dirrmtry %%DATADIR%%/gamemodes
+@dirrmtry %%DATADIR%%/include
+@dirrmtry %%DATADIR%%/npcmodes/recordings
+@dirrmtry %%DATADIR%%/npcmodes
+@dirrmtry %%DATADIR%%/scriptfiles/properties
+@dirrmtry %%DATADIR%%/scriptfiles/vehicles
@dirrmtry %%DATADIR%%/scriptfiles
@dirrmtry %%DATADIR%%
@dirrmtry %%SAMPDIR%%