aboutsummaryrefslogtreecommitdiff
path: root/games/scare
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/scare
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
Notes
Diffstat (limited to 'games/scare')
-rw-r--r--games/scare/Makefile4
-rw-r--r--games/scare/files/xglk.patch4
2 files changed, 4 insertions, 4 deletions
diff --git a/games/scare/Makefile b/games/scare/Makefile
index 330e26579142..3c2adfaf6ddc 100644
--- a/games/scare/Makefile
+++ b/games/scare/Makefile
@@ -27,8 +27,8 @@ BINFILES= scare
.if defined(WITH_XGLK)
PKGNAMESUFFIX= -glk
-BUILD_DEPENDS+= ${X11BASE}/lib/libxglk.a:${PORTSDIR}/games/xglk
-RUN_DEPENDS+= ${X11BASE}/lib/libxglk.a:${PORTSDIR}/games/xglk
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libxglk.a:${PORTSDIR}/games/xglk
+RUN_DEPENDS+= ${LOCALBASE}/lib/libxglk.a:${PORTSDIR}/games/xglk
ALL_TARGET= all glkscare
diff --git a/games/scare/files/xglk.patch b/games/scare/files/xglk.patch
index ef555fe6d738..519ee481a5ff 100644
--- a/games/scare/files/xglk.patch
+++ b/games/scare/files/xglk.patch
@@ -5,7 +5,7 @@
# for Glk, comment out the include line.
GLKPATH = $(GLKDIR)/$(GLK)
-sinclude $(GLKPATH)/Make.$(GLK)
-+.include "$(X11BASE)/share/xglk/Make.$(GLK)"
++.include "$(LOCALBASE)/share/xglk/Make.$(GLK)"
GLKLIBS = -L$(GLKPATH) $(GLKLIB) $(LINKLIBS)
# Always use the Bourne shell.
@@ -14,7 +14,7 @@
os_glk.o: os_glk.c $(HEADERS)
$(CC) $(GLKARCH) $(CFLAGS) -Wno-write-strings \
- -I $(GLKDIR)/$(GLK) -c -o $@ $<
-+ -DLINUX_GRAPHICS -I${X11BASE}/include/xglk -c -o $@ $<
++ -DLINUX_GRAPHICS -I${LOCALBASE}/include/xglk -c -o $@ $<
# Option to build an IFP plugin version of SCARE.
scare_plugin.c: scare.hdr