aboutsummaryrefslogtreecommitdiff
path: root/games/scare
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-03-24 16:25:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-03-24 16:25:23 +0000
commit5ae2a002992c732e8b9a889ecfca3b96b2ddda4c (patch)
treedee73d2b13f4a12585f7a0d05a7c3e2c92286590 /games/scare
parent1378a6713f82c34f89d4a7d046ee37f886afef6b (diff)
downloadports-5ae2a002992c732e8b9a889ecfca3b96b2ddda4c.tar.gz
ports-5ae2a002992c732e8b9a889ecfca3b96b2ddda4c.zip
Notes
Diffstat (limited to 'games/scare')
-rw-r--r--games/scare/Makefile59
-rw-r--r--games/scare/distinfo4
-rw-r--r--games/scare/files/no-xglk.patch17
-rw-r--r--games/scare/files/patch-Makefile46
-rw-r--r--games/scare/files/xglk.patch22
-rw-r--r--games/scare/pkg-descr2
6 files changed, 44 insertions, 106 deletions
diff --git a/games/scare/Makefile b/games/scare/Makefile
index e2c933070549..0c6c81f2bbab 100644
--- a/games/scare/Makefile
+++ b/games/scare/Makefile
@@ -6,44 +6,65 @@
#
PORTNAME= scare
-PORTVERSION= 1.3.7
+PORTVERSION= 1.3.10
CATEGORIES= games
-MASTER_SITES= ftp://ftp.ifarchive.org/if-archive/programming/adrift/
+MASTER_SITES= http://ifarchive.flavorplex.com/%SUBDIR%/ \
+ http://ifarchive.heanet.ie/%SUBDIR%/ \
+ http://ifarchive.jmac.org/%SUBDIR%/ \
+ http://ifarchive.plover.net/%SUBDIR%/ \
+ http://ifarchive.wurb.com/%SUBDIR%/ \
+ http://www.ifarchive.org/%SUBDIR%/ \
+ ftp://ftp.ifarchive.org/%SUBDIR%/
+MASTER_SITE_SUBDIR= if-archive/programming/adrift
MAINTAINER= ports@FreeBSD.org
COMMENT= ADRIFT-compatible interactive games interpreter
+LICENSE= GPLv2
+
OPTIONS= XGLK "Use the xglk graphics library" off
USE_ZIP= yes
+MAKE_JOBS_SAFE=yes
-.include <bsd.port.pre.mk>
-
-BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+PLIST_FILES= bin/scare
-BINFILES= scare
+.include <bsd.port.options.mk>
.if defined(WITH_XGLK)
-PKGNAMESUFFIX= -glk
-
BUILD_DEPENDS+= ${LOCALBASE}/lib/libxglk.a:${PORTSDIR}/games/xglk
RUN_DEPENDS+= ${LOCALBASE}/lib/libxglk.a:${PORTSDIR}/games/xglk
+ALL_TARGET= scare glkscare
+PLIST_FILES+= bin/glkscare
+.endif
-ALL_TARGET= all glkscare
-
-EXTRA_PATCHES= ${FILESDIR}/xglk.patch
-
-BINFILES+= glkscare
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^CC/s|= |?= | ; \
+ /^CFLAGS/s|= -O2|+= | ; \
+ /^CFLAGS/s|-fPIC|| ; \
+ /^LDLIBS/s|=.*|= -lz| ; \
+ /-D__unix/s|^#|| ; \
+ s|^sinclude.*|.include "$$(GLKPATH)/Make.$$(GLK)"| ; \
+ s| $$(ZOBJECTS)||' ${WRKSRC}/source/Makefile
+
+do-configure:
+ @${MKDIR} ${WRKDIR}/xglk
+.if defined(WITH_XGLK)
+ @${LN} -sf ${LOCALBASE}/include/xglk/*.h ${WRKDIR}/xglk
+ @${LN} -sf ${LOCALBASE}/share/xglk/Make.xglk ${WRKDIR}/xglk
.else
-EXTRA_PATCHES= ${FILESDIR}/no-xglk.patch
+ @${TOUCH} ${WRKDIR}/xglk/Make.xglk
.endif
-PLIST_FILES= ${BINFILES:S,^,bin/,}
-
do-install:
- ${INSTALL_PROGRAM} ${BINFILES:S,^,${WRKSRC}/source/,} ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/source/scare ${PREFIX}/bin
+.if defined(WITH_XGLK)
+ ${INSTALL_PROGRAM} ${WRKSRC}/source/glkscare ${PREFIX}/bin
+.endif
test: build
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} check
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/scare/distinfo b/games/scare/distinfo
index 5afc168f6690..7afd18513eb7 100644
--- a/games/scare/distinfo
+++ b/games/scare/distinfo
@@ -1,2 +1,2 @@
-SHA256 (scare-1.3.7.zip) = bb4d2ff59304d6674f6e7909bd0e171cb69c151ed859c729f6888aa58a17d4e6
-SIZE (scare-1.3.7.zip) = 1313534
+SHA256 (scare-1.3.10.zip) = c11410e8474de23d5c8256fd5f303ecac8882e9c4a0e02ece2ea7fb21561a5be
+SIZE (scare-1.3.10.zip) = 1338680
diff --git a/games/scare/files/no-xglk.patch b/games/scare/files/no-xglk.patch
deleted file mode 100644
index 6fcd14964746..000000000000
--- a/games/scare/files/no-xglk.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Properly disable the use of the xglk library if the port's XGLK option
-has been turned off.
-
---- source/Makefile.orig
-+++ source/Makefile
-@@ -73,8 +73,9 @@
- # If your make can't handle sinclude or -include, and you're not building
- # for Glk, comment out the include line.
- GLKPATH = $(GLKDIR)/$(GLK)
--sinclude $(GLKPATH)/Make.$(GLK)
--GLKLIBS = -L$(GLKPATH) $(GLKLIB) $(LINKLIBS)
-+#sinclude $(GLKPATH)/Make.$(GLK)
-+#GLKLIBS = -L$(GLKPATH) $(GLKLIB) $(LINKLIBS)
-+GLKLIBS =
-
- # Always use the Bourne shell.
- SHELL = /bin/sh
diff --git a/games/scare/files/patch-Makefile b/games/scare/files/patch-Makefile
deleted file mode 100644
index e0175c2dbc80..000000000000
--- a/games/scare/files/patch-Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-Only set the Makefile variables conditionally so that they may be
-overridden by the FreeBSD port.
-
---- source/Makefile.orig
-+++ source/Makefile
-@@ -26,18 +26,19 @@
- #
-
- # GCC compiler and linker flags.
--CC = gcc
--DEBUG =
--CEXTRA =
--CFLAGS = -O2 -D__NO_STRING_INLINES -fPIC -ansi -D_STRICT_ANSI_ -Wall -W \
-+CC ?= gcc
-+DEBUG ?=
-+CEXTRA ?=
-+CFLAGS ?= -O2 -D__NO_STRING_INLINES -fPIC -ansi -D_STRICT_ANSI_ -Wall -W \
- -pedantic -Wshadow -Wpointer-arith -Wstrict-prototypes \
- -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls \
- -Wwrite-strings -Wundef -Wbad-function-cast -Waggregate-return \
- -Wnested-externs \
-- $(DEBUG) $(CEXTRA)
--LDLIBS =
--LDEXTRA =
--LDFLAGS = $(DEBUG) $(LDEXTRA)
-+ $(DEBUG)
-+CFLAGS += $(CEXTRA)
-+LDLIBS ?=
-+LDEXTRA ?=
-+LDFLAGS ?= $(DEBUG) $(LDEXTRA)
-
- # Generic compiler and linker flags.
- #CC = cc
-@@ -79,9 +80,9 @@
- SHELL = /bin/sh
-
- # Miscellaneous tools, overridable by the command line.
--UNZIP = unzip
--RM = rm
--TEST = test
-+UNZIP ?= unzip
-+RM ?= rm
-+TEST ?= test
-
- # SCARE objects and headers.
- OBJECTS = sctafpar.o sctaffil.o scprops.o scvars.o scexpr.o scprintf.o \
diff --git a/games/scare/files/xglk.patch b/games/scare/files/xglk.patch
deleted file mode 100644
index 809c40007423..000000000000
--- a/games/scare/files/xglk.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Properly enable the xglk build if the XGLK port option has been turned on.
-
---- source/Makefile.orig
-+++ source/Makefile
-@@ -73,7 +73,7 @@
- # If your make can't handle sinclude or -include, and you're not building
- # for Glk, comment out the include line.
- GLKPATH = $(GLKDIR)/$(GLK)
--sinclude $(GLKPATH)/Make.$(GLK)
-+.include "$(LOCALBASE)/share/xglk/Make.$(GLK)"
- GLKLIBS = -L$(GLKPATH) $(GLKLIB) $(LINKLIBS)
-
- # Always use the Bourne shell.
-@@ -134,7 +134,7 @@
-
- os_glk.o: os_glk.c $(HEADERS)
- $(CC) $(GLKARCH) $(CFLAGS) -Wno-write-strings \
-- -I $(GLKDIR)/$(GLK) -c -o $@ $<
-+ -DLINUX_GRAPHICS -I${LOCALBASE}/include/xglk -c -o $@ $<
-
- # Option to build an IFP plugin version of SCARE.
- scare_plugin.c: scare.hdr
diff --git a/games/scare/pkg-descr b/games/scare/pkg-descr
index 9b92f98b2c36..1464e40a412f 100644
--- a/games/scare/pkg-descr
+++ b/games/scare/pkg-descr
@@ -1 +1,3 @@
An ADRIFT-compatible interactive games interpreter.
+
+WWW: http://sites.google.com/site/scarehome/