aboutsummaryrefslogtreecommitdiff
path: root/games/schiff
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-12-08 19:04:54 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-12-08 19:04:54 +0000
commit204acb24b86a531921d870d171d0d455902c4c3d (patch)
tree03ee37b23e712667fab5339defe493314d564cc5 /games/schiff
parent6ad04afc409a856c97a021b0172cf4c185d7e1aa (diff)
downloadports-204acb24b86a531921d870d171d0d455902c4c3d.tar.gz
ports-204acb24b86a531921d870d171d0d455902c4c3d.zip
Notes
Diffstat (limited to 'games/schiff')
-rw-r--r--games/schiff/Makefile45
-rw-r--r--games/schiff/distinfo4
-rw-r--r--games/schiff/files/schiff.in7
-rw-r--r--games/schiff/pkg-descr6
4 files changed, 62 insertions, 0 deletions
diff --git a/games/schiff/Makefile b/games/schiff/Makefile
new file mode 100644
index 000000000000..9f0190659762
--- /dev/null
+++ b/games/schiff/Makefile
@@ -0,0 +1,45 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= schiff
+PORTVERSION= 16
+CATEGORIES= games python
+MASTER_SITES= SF/pygamebook/${PORTNAME:S/s/S/}/${PORTNAME}${PORTVERSION}.py/ \
+ SF/nemysisfreebsdp/games/:icons
+DISTFILES= ${PORTNAME}${DISTVERSION}.py \
+ ${PORTNAME}.png:icons
+DIST_SUBDIR= python
+EXTRACT_ONLY=
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Steer your ship(s) with the keyboard
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYGAME}
+
+USE_PYTHON= 2.7
+NO_BUILD= yes
+
+SUB_FILES= ${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/pixmaps/${PORTNAME}.png \
+ %%DATADIR%%/${PORTNAME}.py
+PLIST_DIRS= %%DATADIR%%
+
+DESKTOP_ENTRIES="Schiff" "" ${PORTNAME} \
+ "${PORTNAME}" "Game;LogicGame;" ""
+
+do-install:
+ @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' \
+ ${WRKDIR}/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${_DISTDIR}/schiff${PORTVERSION}.py \
+ ${STAGEDIR}${DATADIR}/${PORTNAME}.py
+
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
+
+.include <bsd.port.mk>
diff --git a/games/schiff/distinfo b/games/schiff/distinfo
new file mode 100644
index 000000000000..d90b305cd45a
--- /dev/null
+++ b/games/schiff/distinfo
@@ -0,0 +1,4 @@
+SHA256 (python/schiff16.py) = 85a350632ad28883a2752a817046381b1d00ec4b8c13026d0f30fa6504e17e00
+SIZE (python/schiff16.py) = 56221
+SHA256 (python/schiff.png) = 8ad9550368f8ba47978f39da2431c92f9dcba19dd9ad6273df3a09323d425d98
+SIZE (python/schiff.png) = 3437
diff --git a/games/schiff/files/schiff.in b/games/schiff/files/schiff.in
new file mode 100644
index 000000000000..416529857916
--- /dev/null
+++ b/games/schiff/files/schiff.in
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd "%%DATADIR%%"
+exec %%PYTHON_CMD%% ./schiff.py "${@}"
diff --git a/games/schiff/pkg-descr b/games/schiff/pkg-descr
new file mode 100644
index 000000000000..f45e03c77612
--- /dev/null
+++ b/games/schiff/pkg-descr
@@ -0,0 +1,6 @@
+Schiff is the German word for ship.
+Steer your ship(s) with the keyboard to rotate or move forward / backward.
+Try to avoid enemy bullets and the floating yellow rectangles.
+Become last ship floating to win the game.
+
+WWW: http://thepythongamebook.com/en:resources:games:schiff