aboutsummaryrefslogtreecommitdiff
path: root/games/scid/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-03-12 15:47:11 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-03-12 15:47:11 +0000
commit2b6d2524bdaa96ad24030e8462776e3d42acfde2 (patch)
tree7d47cde920b8cf42065a944a1a08bad5c7a0844b /games/scid/Makefile
parent237e610a595f024b0e7f23c885b9166a86ffef14 (diff)
Notes
Diffstat (limited to 'games/scid/Makefile')
-rw-r--r--games/scid/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/games/scid/Makefile b/games/scid/Makefile
index f8c5bd62cd64..1cd8c579c69a 100644
--- a/games/scid/Makefile
+++ b/games/scid/Makefile
@@ -2,24 +2,24 @@
# $FreeBSD$
PORTNAME= scid
-PORTVERSION= 4.3
+PORTVERSION= 4.4
CATEGORIES= games databases
-MASTER_SITES= SF/${PORTNAME}/Scid/Scid%204.3/
+MASTER_SITES= SF/${PORTNAME}/Scid/Scid%204.4/
MAINTAINER= bsd@volki.at
-COMMENT= A free chess database application
+COMMENT= Free chess database application
HAS_CONFIGURE= yes
-USES= gmake tk:84,85
+USES= gmake tk:84,85,86
USE_BZIP2= yes
USE_PYTHON= yes
-USE_GMAKE= yes
TCL_LIBRARY= -L${LOCALBASE}/lib -ltcl${TCL_SHLIB_VER}
CONFIGURE_ARGS= \
BINDIR="${PREFIX}/bin" \
SHAREDIR="${PREFIX}/share/scid" \
+ THREADS="-pthread" \
TCL_VERSION="${TCL_VER}" \
TCL_INCLUDE="-I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR} -I${LOCALBASE}/include" \
TCL_LIBRARY="${TCL_LIBRARY}" \
@@ -29,7 +29,11 @@ CONFIGURE_ARGS= \
ALL_TARGET= all strip
-WRKSRC= ${WRKDIR}/${PORTNAME}
+post-configure:
+ @${REINPLACE_CMD} -e 's|g++|${CXX}|g; s|gcc|${CC}|g' \
+ -e '/engines/ s|SHAREDIR|DESTDIR\)$$\(&|g' \
+ ${WRKSRC}/Makefile \
+ ${WRKSRC}/engines/phalanx-scid/makefile \
+ ${WRKSRC}/engines/togaII1.2.1a/src/Makefile
-NO_STAGE= yes
.include <bsd.port.mk>