aboutsummaryrefslogtreecommitdiff
path: root/games/scourge
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-09-15 16:20:12 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-09-15 16:20:12 +0000
commit677de4ea6433173eef7a4ad295550681e01e8768 (patch)
tree2a6a812b3b02c455c12dfba828d2c12feee246d6 /games/scourge
parent79f8669ec0edb65d9dc0ea630308c8e391032929 (diff)
downloadports-677de4ea6433173eef7a4ad295550681e01e8768.tar.gz
ports-677de4ea6433173eef7a4ad295550681e01e8768.zip
Notes
Diffstat (limited to 'games/scourge')
-rw-r--r--games/scourge/Makefile34
-rw-r--r--games/scourge/distinfo6
-rw-r--r--games/scourge/files/pkg-message.in19
3 files changed, 52 insertions, 7 deletions
diff --git a/games/scourge/Makefile b/games/scourge/Makefile
index b5fe044f55e8..551c15399bed 100644
--- a/games/scourge/Makefile
+++ b/games/scourge/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= scourge
-PORTVERSION= 0.14
+PORTVERSION= 0.15
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME:S/$/-src/}-${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= acm@FreeBSD.org
@@ -21,7 +22,6 @@ RUN_DEPENDS= ${DATADIR}/world/gui.txt:${PORTSDIR}/games/scourge-data
USE_GL= yes
USE_SDL= sdl mixer net
USE_GMAKE= yes
-USE_GCC= 3.3+
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_LIBS}
LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib
@@ -30,18 +30,44 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-data-dir=${DATADIR}
+SUB_FILES= pkg-message
PLIST_FILES= bin/${PORTNAME}
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+WXCONFIG= wxgtk2${_WX_UC}-${_WX_VER}-config
-OPTIONS= DEBUG "Produce an executable with debugging symbols" off
+OPTIONS= DEBUG "Produce an executable with debugging symbols" off \
+ EDITOR "Install scourge editor" on
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= Some dependencies do not compile on 4.x
+.endif
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
+.if !defined(WITHOUT_EDITOR)
+USE_WX= 2.6+
+WX_COMPS= wx contrib
+WX_UNICODE= yes
+PLIST_FILES+= bin/${PORTNAME}-editor
+HAVE_EDITOR= true
+.else
+CONFIGURE_ARGS+= --disable-editor
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|wx-config|${WXCONFIG} |g' ${WRKSRC}/configure
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin/
+.if defined(HAVE_EDITOR)
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/tools/tools ${PREFIX}/bin/${PORTNAME}-editor
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/games/scourge/distinfo b/games/scourge/distinfo
index 8e07f4d67dc5..c55c1a0e6e29 100644
--- a/games/scourge/distinfo
+++ b/games/scourge/distinfo
@@ -1,3 +1,3 @@
-MD5 (scourge/scourge-0.14.tar.gz) = b5433d7015d4108dc01065d92d46fa59
-SHA256 (scourge/scourge-0.14.tar.gz) = c6b283c0e986c83c0d0cc377511b6446b12e9e45109951a9894170e85e322cdc
-SIZE (scourge/scourge-0.14.tar.gz) = 1740238
+MD5 (scourge/scourge-src-0.15.tar.gz) = e5e00d1ff25c9da124f45e910db4f230
+SHA256 (scourge/scourge-src-0.15.tar.gz) = e0d29a7357e8a9042d0cc510fb6e8010ce296fb4c037e0355e2aa01a504f6847
+SIZE (scourge/scourge-src-0.15.tar.gz) = 1051072
diff --git a/games/scourge/files/pkg-message.in b/games/scourge/files/pkg-message.in
new file mode 100644
index 000000000000..6b14e3e820ed
--- /dev/null
+++ b/games/scourge/files/pkg-message.in
@@ -0,0 +1,19 @@
+###############################################################################
+
+S.C.O.U.R.G.E was installed
+
+1) You can run the scourge, using:
+
+ # scourge
+
+2) Show the help:
+
+ # scourge -help
+
+3) If you decided to install the editor program, use:
+
+ # scourge-editor
+
+4) Enjoy it ;)
+
+###############################################################################