aboutsummaryrefslogtreecommitdiff
path: root/games/scummvm-tools/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-02 12:12:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-02 12:12:01 +0000
commit9022a33aba9c09c8c8214fb562742e4c44ebcf0c (patch)
tree30ccd5be3cae2d4781b4cfa4c9105a7fb210f05c /games/scummvm-tools/Makefile
parentf9483446abda743b5d6f20c282b60404d15b2ac7 (diff)
downloadports-9022a33aba9c09c8c8214fb562742e4c44ebcf0c.tar.gz
ports-9022a33aba9c09c8c8214fb562742e4c44ebcf0c.zip
Notes
Diffstat (limited to 'games/scummvm-tools/Makefile')
-rw-r--r--games/scummvm-tools/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/games/scummvm-tools/Makefile b/games/scummvm-tools/Makefile
index 28deac0c14ee..9af744c4a3c6 100644
--- a/games/scummvm-tools/Makefile
+++ b/games/scummvm-tools/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= scummvm-tools
-PORTVERSION= 0.9.0
-PORTREVISION= 1
+PORTVERSION= 0.10.0
CATEGORIES= games emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= scummvm
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= lars.engels@0x20.net
COMMENT= Tools for use with the SCUMMVM game emulator
RUN_DEPENDS= scummvm:${PORTSDIR}/games/scummvm
@@ -24,10 +23,14 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USE_GMAKE= yes
-WRKSRC= ${WRKDIR}/tools-${PORTVERSION}
+WRKSRC= ${WRKDIR}/scummvm-tools-${PORTVERSION}
do-install:
-.for i in compress_queen compress_saga compress_scumm_bun compress_scumm_sou compress_simon compress_sword1 compress_sword2 extract_kyra extract_loom_tg16 extract_mm_c64 extract_mm_nes extract_scumm_mac extract_simon1_amiga extract_zak_c64 dekyra descumm desword2
+.for i in compress_agos compress_kyra compress_queen compress_saga compress_scumm_bun \
+ compress_scumm_san compress_scumm_sou compress_sword1 compress_sword2 \
+ compress_touche dekyra descumm desword2 encode_dxa extract_agos \
+ extract_kyra extract_loom_tg16 extract_mm_apple extract_mm_c64 \
+ extract_mm_nes extract_scumm_mac extract_zak_c64
@${INSTALL_PROGRAM} ${WRKSRC}/$i ${PREFIX}/bin
.endfor
@@ -37,6 +40,6 @@ do-install:
.endif
post-patch:
- @${REINPLACE_CMD} -e 's@:= -g -O@+= ${CFLAGS}@' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's@:= -g -O@+= ${CFLAGS}@' -e "s@%%PREFIX%%@${PREFIX}@" ${WRKSRC}/Makefile
.include <bsd.port.mk>