aboutsummaryrefslogtreecommitdiff
path: root/games/scummvm-tools/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-21 16:33:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-21 16:33:25 +0000
commit3cf025aca0120b54a3221a67fdcc4f0f768a5afc (patch)
tree6f0c98149d47e143d4514ef6a0faf7d5b5623e06 /games/scummvm-tools/Makefile
parentc11033e057d05545674d6ff776de97eb426dd698 (diff)
Notes
Diffstat (limited to 'games/scummvm-tools/Makefile')
-rw-r--r--games/scummvm-tools/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/games/scummvm-tools/Makefile b/games/scummvm-tools/Makefile
index 7ae93ee266c7..80e23113b2ec 100644
--- a/games/scummvm-tools/Makefile
+++ b/games/scummvm-tools/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= scummvm-tools
-PORTVERSION= 0.7.0
+PORTVERSION= 0.8.0
CATEGORIES= games emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= scummvm
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd.alex@trull.org
COMMENT= Tools for use with the SCUMMVM game emulator
RUN_DEPENDS= scummvm:${PORTSDIR}/games/scummvm
@@ -23,15 +23,16 @@ BUILD_DEPENDS= lame:${PORTSDIR}/audio/lame \
USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/tools-${PORTVERSION}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BUILD_DEPENDS+= gcc32:${PORTSDIR}/lang/gcc32
+USE_GCC= 3.3+
.endif
do-install:
-.for i in descumm extract md5table mm_nes_extract queenrebuild rescumm
+.for i in compress_queen compress_saga compress_san compress_scumm_bun compress_scumm_sou compress_simon compress_sword1 compress_sword2 extract_kyra extract_loom_tg16 extract_mm_c64 extract_mm_nes extract_scumm_mac extract_simon1_amiga extract_zak_c64 dekyra descumm desword2
@${INSTALL_PROGRAM} ${WRKSRC}/$i ${PREFIX}/bin
.endfor
@@ -43,7 +44,7 @@ do-install:
post-patch:
@${REINPLACE_CMD} -e 's@:= -g -O@+= ${CFLAGS}@' ${WRKSRC}/Makefile
.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's/gcc/gcc32/g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's/gcc/${CC}/g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's/g\+\+/g\+\+32/g' ${WRKSRC}/Makefile
.endif