aboutsummaryrefslogtreecommitdiff
path: root/games/scummvm-tools
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-21 16:33:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-21 16:33:25 +0000
commit3cf025aca0120b54a3221a67fdcc4f0f768a5afc (patch)
tree6f0c98149d47e143d4514ef6a0faf7d5b5623e06 /games/scummvm-tools
parentc11033e057d05545674d6ff776de97eb426dd698 (diff)
downloadports-3cf025aca0120b54a3221a67fdcc4f0f768a5afc.tar.gz
ports-3cf025aca0120b54a3221a67fdcc4f0f768a5afc.zip
Notes
Diffstat (limited to 'games/scummvm-tools')
-rw-r--r--games/scummvm-tools/Makefile11
-rw-r--r--games/scummvm-tools/distinfo5
-rw-r--r--games/scummvm-tools/files/patch-simon1descr.c19
-rw-r--r--games/scummvm-tools/pkg-plist22
4 files changed, 26 insertions, 31 deletions
diff --git a/games/scummvm-tools/Makefile b/games/scummvm-tools/Makefile
index 7ae93ee266c7..80e23113b2ec 100644
--- a/games/scummvm-tools/Makefile
+++ b/games/scummvm-tools/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= scummvm-tools
-PORTVERSION= 0.7.0
+PORTVERSION= 0.8.0
CATEGORIES= games emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= scummvm
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd.alex@trull.org
COMMENT= Tools for use with the SCUMMVM game emulator
RUN_DEPENDS= scummvm:${PORTSDIR}/games/scummvm
@@ -23,15 +23,16 @@ BUILD_DEPENDS= lame:${PORTSDIR}/audio/lame \
USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/tools-${PORTVERSION}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BUILD_DEPENDS+= gcc32:${PORTSDIR}/lang/gcc32
+USE_GCC= 3.3+
.endif
do-install:
-.for i in descumm extract md5table mm_nes_extract queenrebuild rescumm
+.for i in compress_queen compress_saga compress_san compress_scumm_bun compress_scumm_sou compress_simon compress_sword1 compress_sword2 extract_kyra extract_loom_tg16 extract_mm_c64 extract_mm_nes extract_scumm_mac extract_simon1_amiga extract_zak_c64 dekyra descumm desword2
@${INSTALL_PROGRAM} ${WRKSRC}/$i ${PREFIX}/bin
.endfor
@@ -43,7 +44,7 @@ do-install:
post-patch:
@${REINPLACE_CMD} -e 's@:= -g -O@+= ${CFLAGS}@' ${WRKSRC}/Makefile
.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's/gcc/gcc32/g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's/gcc/${CC}/g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's/g\+\+/g\+\+32/g' ${WRKSRC}/Makefile
.endif
diff --git a/games/scummvm-tools/distinfo b/games/scummvm-tools/distinfo
index e375e0688413..91e070fe5a6f 100644
--- a/games/scummvm-tools/distinfo
+++ b/games/scummvm-tools/distinfo
@@ -1,2 +1,3 @@
-MD5 (scummvm-tools-0.7.0.tar.bz2) = eeebbd4e309a8564dd911d5c26fed2f0
-SIZE (scummvm-tools-0.7.0.tar.bz2) = 98664
+MD5 (scummvm-tools-0.8.0.tar.bz2) = cc7e13ea10acf692c10e90b9507074ed
+SHA256 (scummvm-tools-0.8.0.tar.bz2) = b60936416e201eda18c627c85bc29ba742e1b6c98d79bc9935ed4827a2e47fa0
+SIZE (scummvm-tools-0.8.0.tar.bz2) = 92983
diff --git a/games/scummvm-tools/files/patch-simon1descr.c b/games/scummvm-tools/files/patch-simon1descr.c
deleted file mode 100644
index 47e16abf6c16..000000000000
--- a/games/scummvm-tools/files/patch-simon1descr.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- simon1decr.c.orig Mon Apr 12 00:10:19 2004
-+++ simon1decr.c Tue Jan 4 15:36:39 2005
-@@ -26,14 +26,9 @@
-
- #define EndGetM32(a) ((((a)[0])<<24)|(((a)[1])<<16)|(((a)[2])<<8)|((a)[3]))
-
--#define SD_GETBIT(var) do { \
-- if (!bits--) { s -= 4; if (s < src) return 0; bb=EndGetM32(s); bits=31; } \
-- (var) = bb & 1; bb >>= 1; \
--} while (0)
-+#define SD_GETBIT(var) do { if (!bits--) { s -= 4; if (s < src) return 0; bb=EndGetM32(s); bits=31; } (var) = bb & 1; bb >>= 1; } while (0)
-
--#define SD_GETBITS(var, nbits) do { \
-- bc=(nbits); (var)=0; while (bc--) {(var)<<=1; SD_GETBIT(bit); (var)|=bit; } \
--} while (0)
-+#define SD_GETBITS(var, nbits) do { bc=(nbits); (var)=0; while (bc--) {(var)<<=1; SD_GETBIT(bit); (var)|=bit; } } while (0)
-
- #define SD_TYPE_LITERAL (0)
- #define SD_TYPE_MATCH (1)
diff --git a/games/scummvm-tools/pkg-plist b/games/scummvm-tools/pkg-plist
index 53024e3c287e..d92159e52474 100644
--- a/games/scummvm-tools/pkg-plist
+++ b/games/scummvm-tools/pkg-plist
@@ -1,8 +1,20 @@
+bin/compress_queen
+bin/compress_saga
+bin/compress_san
+bin/compress_scumm_bun
+bin/compress_scumm_sou
+bin/compress_simon
+bin/compress_sword1
+bin/compress_sword2
+bin/extract_kyra
+bin/extract_loom_tg16
+bin/extract_mm_c64
+bin/extract_mm_nes
+bin/extract_scumm_mac
+bin/extract_simon1_amiga
+bin/extract_zak_c64
+bin/dekyra
bin/descumm
-bin/extract
-bin/md5table
-bin/mm_nes_extract
-bin/queenrebuild
-bin/rescumm
+bin/desword2
%%PORTDOCS%%share/doc/scummvm-tools/README
%%PORTDOCS%%@dirrm share/doc/scummvm-tools