aboutsummaryrefslogtreecommitdiff
path: root/games/scummvm
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2010-06-16 20:25:17 +0000
committerLars Engels <lme@FreeBSD.org>2010-06-16 20:25:17 +0000
commitd02b3d8146fdab4df534fb209cc716fb86c9caf4 (patch)
treea6a4485849ebfa542c93730b3480ebaa7e170b5f /games/scummvm
parente31e75ce1e8cb1db13f49d78e460b617312233f6 (diff)
downloadports-d02b3d8146fdab4df534fb209cc716fb86c9caf4.tar.gz
ports-d02b3d8146fdab4df534fb209cc716fb86c9caf4.zip
Notes
Diffstat (limited to 'games/scummvm')
-rw-r--r--games/scummvm/Makefile62
-rw-r--r--games/scummvm/distinfo6
2 files changed, 41 insertions, 27 deletions
diff --git a/games/scummvm/Makefile b/games/scummvm/Makefile
index 53e2b12f683f..0602a884af0b 100644
--- a/games/scummvm/Makefile
+++ b/games/scummvm/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= scummvm
-DISTVERSION= 1.0.0
-PORTREVISION= 3
+DISTVERSION= 1.1.1
CATEGORIES= games emulators
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${DISTVERSION}
MAINTAINER= lme@FreeBSD.org
-COMMENT= Graphical Adventure Game Virtual Machine
+COMMENT= Interpreter for several adventure games
USE_BZIP2= yes
USE_GMAKE= yes
@@ -22,28 +21,50 @@ USE_SDL= sdl
MAKE_JOBS_SAFE= yes
-CONFIGURE_ARGS=--with-sdl-prefix=${LOCALBASE} \
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --with-sdl-prefix=${LOCALBASE} \
--disable-alsa \
--with-zlib-prefix=/usr \
--disable-debug \
--disable-tremor
CONFIGURE_ENV= CXX="${CXX}"
+ LDFLAGS="${PTHREAD_LIBS}"
OPTIONS= VORBIS "Enable Ogg Vorbis support" off \
- MAD "Enable mad (MP3) support" on \
+ MP3 "Enable MP3 support" on \
MPEG2 "Enable MPEG2 support (implies VORBIS)" on \
FLAC "Enable FLAC support" off \
FLUIDSYNTH "Enable FluidSynth MIDI synthesizer" off \
- DPLUGINS "Enable support for dynamic plugins" off
+ MT32EMU "Enable MT-32 emulator" on \
+ X86_ASM "Enable assembly code (i386 only)" on
MAN6= scummvm.6
-PORTDOCS= NEWS README TODO
-PLIST_FILES= bin/scummvm %%DATADIR%%/scummmodern.zip
+PORTDOCS= AUTHORS NEWS README TODO COPYRIGHT
+ENGINEDATA= drascula.dat \
+ kyra.dat \
+ lure.dat \
+ queen.tbl \
+ sky.cpt \
+ teenagent.dat
+
+PLIST_FILES= bin/scummvm %%DATADIR%%/scummmodern.zip \
+ %%DATADIR%%/scummvm.svg \
+ %%DATADIR%%/scummmodern.zip \
+ $(ENGINEDATA:S/^/%%DATADIR%%\/$$/)
PLIST_DIRS= %%DATADIR%%
.include <bsd.port.pre.mk>
+.if ${ARCH} == "i386"
+.if defined(WITH_X86_ASM)
+BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
+CONFIGURE_ARGS+=--with-nasm-prefix=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--disable-nasm
+.endif
+.endif
+
.if defined(WITH_MPEG2)
WITH_VORBIS= yes
.endif
@@ -57,19 +78,13 @@ CONFIGURE_ARGS+=--with-ogg-prefix=${LOCALBASE} \
CONFIGURE_ARGS+=--disable-vorbis
.endif
-.if !defined(WITHOUT_MAD)
+.if defined(WITH_MP3)
LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
CONFIGURE_ARGS+=--with-mad-prefix=${LOCALBASE}
.else
CONFIGURE_ARGS+=--disable-mad
.endif
-.if defined(WITH_MPEG2)
-WITH_VORBIS= yes
-LIB_DEPENDS+= mpeg2.0:${PORTSDIR}/multimedia/libmpeg2
-CONFIGURE_ARGS+=--with-mpeg2-prefix=${LOCALBASE} --enable-mpeg2
-.endif
-
.if defined(WITH_FLAC)
LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
CONFIGURE_ARGS+=--with-flac-prefix=${LOCALBASE}
@@ -84,24 +99,23 @@ CONFIGURE_ARGS+=--with-fluidsynth-prefix=${LOCALBASE}
CONFIGURE_ARGS+=--disable-fluidsynth
.endif
-.if defined(WITH_DPLUGINS)
-CONFIGURE_ARGS+= --enable-plugins
+.if defined(WITHOUT_MT32EMU)
+CONFIGURE_ARGS+=--disable-mt32emu
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's/-O//' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's/-lfluidsynth/& ${PTHREAD_LIBS}/' ${WRKSRC}/configure
-
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/scummvm ${PREFIX}/bin
@${INSTALL_MAN} ${WRKSRC}/dists/scummvm.6 ${PREFIX}/man/man6
@${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/icons/scummvm.svg ${DATADIR}
@${INSTALL_DATA} ${WRKSRC}/gui/themes/scummmodern.zip ${DATADIR}
-
+.for i in ${ENGINEDATA}
+ @${INSTALL_DATA} ${WRKSRC}/dists/engine-data/${i} ${DATADIR}
+.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for doc in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
diff --git a/games/scummvm/distinfo b/games/scummvm/distinfo
index 675edc05e5fa..2fe4182846e5 100644
--- a/games/scummvm/distinfo
+++ b/games/scummvm/distinfo
@@ -1,3 +1,3 @@
-MD5 (scummvm-1.0.0.tar.bz2) = 11b911937e0fc73c94a7bdc374ab617c
-SHA256 (scummvm-1.0.0.tar.bz2) = 920932b9d0cfca019f35c2451d93d94ca3b9f981f0b82c418bfbc864fb8c00ec
-SIZE (scummvm-1.0.0.tar.bz2) = 7955357
+MD5 (scummvm-1.1.1.tar.bz2) = ed9098a78022d07fa1482f14325e3ab8
+SHA256 (scummvm-1.1.1.tar.bz2) = 9cc865c5690bfc1df4970d35984455031467381180a71d84b08dcc9f51e39d4a
+SIZE (scummvm-1.1.1.tar.bz2) = 8668735