aboutsummaryrefslogtreecommitdiff
path: root/games/sdlsand
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-08 00:04:32 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-08 00:04:32 +0000
commit94095c84758bf94d27c1d0efff7e39124e710eca (patch)
treea896538e10107b329ef22eef17cdeaaa099ec42b /games/sdlsand
parent4aaf5e970a7fd0eb62dbc2de0bb343e940ea391f (diff)
downloadports-94095c84758bf94d27c1d0efff7e39124e710eca.tar.gz
ports-94095c84758bf94d27c1d0efff7e39124e710eca.zip
Notes
Diffstat (limited to 'games/sdlsand')
-rw-r--r--games/sdlsand/Makefile38
-rw-r--r--games/sdlsand/distinfo3
-rw-r--r--games/sdlsand/pkg-descr7
3 files changed, 48 insertions, 0 deletions
diff --git a/games/sdlsand/Makefile b/games/sdlsand/Makefile
new file mode 100644
index 000000000000..d017be8bee62
--- /dev/null
+++ b/games/sdlsand/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: sdlsand
+# Date created: 22 Apr 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdlsand
+PORTVERSION= 20060207
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= sldsand-src-${PORTVERSION}
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Simulation of falling sand and other materials
+
+USE_ZIP= yes
+USE_SDL= sdl
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/SDL\ Sand/SDL\ Sand
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= readme.txt
+
+do-build:
+ cd ${WRKSRC} && ${CXX} -o ${PORTNAME} ${CXXFLAGS} \
+ `${SDL_CONFIG} --cflags --libs` main.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/sdlsand/distinfo b/games/sdlsand/distinfo
new file mode 100644
index 000000000000..99649553a92d
--- /dev/null
+++ b/games/sdlsand/distinfo
@@ -0,0 +1,3 @@
+MD5 (sldsand-src-20060207.zip) = c2611a17ad7665bcbfb28352dc95434e
+SHA256 (sldsand-src-20060207.zip) = cab31d00789115fbd13a57b29a5a4e6752e3f70b718d168389785cdda8d649d5
+SIZE (sldsand-src-20060207.zip) = 552046
diff --git a/games/sdlsand/pkg-descr b/games/sdlsand/pkg-descr
new file mode 100644
index 000000000000..29c637483cae
--- /dev/null
+++ b/games/sdlsand/pkg-descr
@@ -0,0 +1,7 @@
+The SDL Sand game (The Falling SDL-Sand Game) is a C++ implementation of the
+original 'World of Sand' (and later 'Hell of Sand') game implemented in JAVA.
+SDL Sand uses the SDL (Simple DirectMedia Library - http://www.libsdl.org/)
+library for screen output. Therefore the implementation can possibly run on
+every platform supported by SDL.
+
+WWW: http://sourceforge.net/projects/sdlsand/