aboutsummaryrefslogtreecommitdiff
path: root/games/seahaven
diff options
context:
space:
mode:
authorWarner Losh <imp@FreeBSD.org>2011-07-17 21:51:22 +0000
committerWarner Losh <imp@FreeBSD.org>2011-07-17 21:51:22 +0000
commit8b78f1c4f381c0b982587d185010fbb36c93716f (patch)
treebc71ef6411f290020aab39a32de448f771c15d09 /games/seahaven
parentda56229899fc3ec037c6bc3384c0fcb5c5ad8d78 (diff)
downloadports-8b78f1c4f381c0b982587d185010fbb36c93716f.tar.gz
ports-8b78f1c4f381c0b982587d185010fbb36c93716f.zip
Notes
Diffstat (limited to 'games/seahaven')
-rw-r--r--games/seahaven/Makefile4
-rw-r--r--games/seahaven/distinfo4
-rw-r--r--games/seahaven/files/patch-Makefile11
-rw-r--r--games/seahaven/files/patch-auto.C132
-rw-r--r--games/seahaven/files/patch-configure19
-rw-r--r--games/seahaven/files/patch-configure.in13
6 files changed, 37 insertions, 146 deletions
diff --git a/games/seahaven/Makefile b/games/seahaven/Makefile
index ecaf53685334..e55d457459c7 100644
--- a/games/seahaven/Makefile
+++ b/games/seahaven/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= seahaven
-PORTVERSION= 1.50
+PORTVERSION= 1.60
CATEGORIES= games
MASTER_SITES= http://seahaven.sourceforge.net/
EXTRACT_SUFX= .tgz
@@ -15,7 +15,7 @@ MAINTAINER= imp@FreeBSD.org
COMMENT= The classic, lightweight version of Seahaven Towers
GNU_CONFIGURE= yes
-USE_XORG= x11 xext
+USE_XORG= x11 xext xft
MAN6?= seahaven.6
PLIST_FILES= bin/seahaven
diff --git a/games/seahaven/distinfo b/games/seahaven/distinfo
index 2dd7b4a192bc..8d456120a3f8 100644
--- a/games/seahaven/distinfo
+++ b/games/seahaven/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seahaven-1.50.tgz) = 34065225f85f6d8eb597741423162fe7334140d575a710375af61119ddc31f27
-SIZE (seahaven-1.50.tgz) = 55991
+SHA256 (seahaven-1.60.tgz) = 096b0a5cce64bca53f03f0c2b3850acf3997d6ce130c711f4fab1221dcb2fd87
+SIZE (seahaven-1.60.tgz) = 76609
diff --git a/games/seahaven/files/patch-Makefile b/games/seahaven/files/patch-Makefile
new file mode 100644
index 000000000000..37dd8be2a9e7
--- /dev/null
+++ b/games/seahaven/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.bak 2011-07-17 15:46:30.000000000 -0600
++++ Makefile 2011-07-17 15:46:43.000000000 -0600
+@@ -45,7 +45,7 @@
+
+ install: $(PROGRAM)
+ $(INSTALL) -s $(PROGRAM) $(bindir)/$(PROGRAM)
+- $(INSTALL) -D $(PROGRAM).$(MANPAGE) $(mandir)/man$(MANPAGE)/$(PROGRAM).$(MANPAGE)
++ $(INSTALL) $(PROGRAM).$(MANPAGE) $(mandir)/man$(MANPAGE)/$(PROGRAM).$(MANPAGE)
+
+ uninstall:
+ -@ rm -f $(bindir)/$(PROGRAM)
diff --git a/games/seahaven/files/patch-auto.C b/games/seahaven/files/patch-auto.C
deleted file mode 100644
index a6e4bbdd3c8b..000000000000
--- a/games/seahaven/files/patch-auto.C
+++ /dev/null
@@ -1,132 +0,0 @@
---- auto.C.orig Sat Dec 6 11:12:47 2003
-+++ auto.C Sun Jan 14 15:16:37 2007
-@@ -1,5 +1,6 @@
- #include <string.h>
- #include <stdlib.h>
-+#include <err.h>
-
- #include <sys/types.h>
- #include <sys/time.h>
-@@ -48,11 +49,6 @@
-
- const int NumRanks = RankLast+1;
-
--void Error(char *s1 = "", char *s2 = "", char *s3 = "") {
-- cerr << "\n" << s1 << s2 << s3 << "\n";
-- exit(-1);
--}
--
- class Tableaux;
-
- inline unsigned short Fold(long l) {
-@@ -146,7 +142,7 @@
- }
-
- int HashList::Add(const Hash& h) {
-- if (!this) Error("Add to NULL HashList.");
-+ if (!this) errx(1, "Add to NULL HashList.");
- if (HashVal().EmptyP()) hash = h;
- else next = new HashList(h, next);
- return depth++;
-@@ -198,8 +194,8 @@
- void MoveTo(CardRange&);
- };
-
--void Dest::MoveTo(Card&) { Error("Dest::MoveTo(Card&)"); }
--void Dest::MoveTo(CardRange&) { Error("Dest::MoveTo(CardRange&)"); }
-+void Dest::MoveTo(Card&) { errx(1, "Dest::MoveTo(Card&)"); }
-+void Dest::MoveTo(CardRange&) { errx(1, "Dest::MoveTo(CardRange&)"); }
-
- typedef void (Dest::* MoveCardToMemberFunction)(Card&);
- typedef void (Dest::* MoveCardRangeToMemberFunction)(CardRange&);
-@@ -211,9 +207,9 @@
- public:
- Card(Suit suit, Rank rank) {
- if ((suit < SuitFirst) || (suit > SuitLast))
-- Error("Bad suit in Card constructor.");
-+ errx(1, "Bad suit %d in Card constructor.", (int)suit);
- if ((rank < RankFirst) || (rank > RankLast))
-- Error("Bad rank in Card constructor.");
-+ errx(1, "Bad rank %d in Card constructor.", (int)rank);
- thisSuit = suit; thisRank = rank; empty = 0;
- }
- Card(char *st);
-@@ -251,10 +247,10 @@
- Card::Card(char* st) {
- char *c;
- c = strchr(suitName, st[1]);
-- if (! c) Error("Bad suit ", st, " in Card string constructor.");
-+ if (! c) errx(1, "Bad suit %c in Card string constructor.", st[1]);
- thisSuit = Suit(c-suitName);
- c = strchr(rankName, st[0]);
-- if (! c) Error("Bad rank ", st, " in Card string constructor.");
-+ if (! c) errx(1, "Bad rank %c in Card string constructor.", st[0]);
- thisRank = Rank(c - rankName);
- empty = 0;
- }
-@@ -272,7 +268,7 @@
- void Init(Card c, CountType count) { thisCard = c; thisCount = count; }
- public:
- CardRange(Suit s, Rank rank1, Rank rank2) {
-- if (rank2 < rank1) Error("rank2 < rank1 in CardRange constructor.");
-+ if (rank2 < rank1) errx(1, "rank2 < rank1 in CardRange constructor.");
- Init(Card(s, rank1), rank2-rank1+1);
- }
- CardRange(Suit s, Rank rank, CountType count = 1) {
-@@ -287,7 +283,7 @@
- Card next() const { return thisCard.next(thisCount); }
- CountType Count() const { return thisCount; }
- void Prepend(const CardRange& cr) {
-- if (!cr.nextP(First())) Error("CardRange::Prepend, not next.");
-+ if (!cr.nextP(First())) errx(1, "CardRange::Prepend, not next.");
- thisCount += cr.Count();
- thisCard = cr.First();
- }
-@@ -413,7 +409,7 @@
- };
-
- void Spaces::MoveTo(CardRange& from) { MoveToSpace(from); }
--void Spaces::MoveTo(Card&) { Error("Spaces::MoveTo(Card&)"); }
-+void Spaces::MoveTo(Card&) { errx(1, "Spaces::MoveTo(Card&)"); }
-
- const int NumPiles = 10;
-
-@@ -481,7 +477,7 @@
- Dest& dest;
- public:
- Move(Dest& d) : dest(d) { }
-- virtual void DoIt() { Error("Move::DoIt()"); };
-+ virtual void DoIt() { errx(1, "Move::DoIt()"); };
- };
-
- class MoveCard : public Move {
-@@ -566,7 +562,7 @@
- }
-
- if ((l1==0)&&(l2==0)&&(l3==0))
-- Error("Tableaux hashes to NULL.");
-+ errx(1, "Tableaux hashes to NULL.");
- }
-
- bool Tableaux::WonP() {
-@@ -850,8 +846,9 @@
- for (Suit s = SuitFirst; s <= SuitLast; s = Suit(s+1))
- for (Rank r = RankFirst; r <= RankLast; r = Rank(r+1))
- if (deck[s][r] != 1) {
-- cerr << "\n" << Card(s, r) << " count is " << deck[s][r];
-- Error();
-+ cerr << "\n" << Card(s, r) << " count is " << deck[s][r]
-+ << endl;
-+ exit(-1);
- }
-
- CanonicalForm();
-@@ -918,7 +915,7 @@
- sprintf(savefile, "%s/.seahavensave", getenv("HOME"));
-
- ifstream in(savefile, ios::in);
-- if (!in) Error("Can't open", savefile);
-+ if (!in) errx(1, "Can't open %s", savefile);
-
- Tableaux t(in);
-
diff --git a/games/seahaven/files/patch-configure b/games/seahaven/files/patch-configure
index 20a7a8606a99..97a39604d74c 100644
--- a/games/seahaven/files/patch-configure
+++ b/games/seahaven/files/patch-configure
@@ -1,14 +1,13 @@
---- configure Sat Aug 17 12:15:42 2002
-+++ configure.orig Sat Aug 17 12:15:20 2002
-@@ -1805,9 +1805,9 @@
- if test -n "$GXX"; then
- # GNU C compiler
+--- configure.bak 2011-07-17 15:43:48.000000000 -0600
++++ configure 2011-07-17 15:44:10.000000000 -0600
+@@ -3920,8 +3920,8 @@
# -Wno-return-type is necessary for Xlib header files on many systems:
-- CFLAGS="-Wall -Wno-return-type -O2 $X_CFLAGS"
-+ CFLAGS="$CFLAGS $X_CFLAGS"
+ CFLAGS="-Wall -Wno-return-type -O2 $X_CFLAGS"
CFLAGS_D="-Wall -Wno-return-type -g -DDEBUG $X_CFLAGS"
-- CXXFLAGS="-Wall -Wno-return-type -O2 $X_CFLAGS"
-+ CXXFLAGS="$CXXFLAGS $X_CFLAGS"
- CXXFLAGS_D="-Wall -Wno-return-type -g -DDEBUG $X_CFLAGS"
+- CXXFLAGS="-Wall -Wno-return-type -O2 $X_CFLAGS -DUSE_XFT -I/usr/include/freetype2"
+- CXXFLAGS_D="-Wall -Wno-return-type -g -DDEBUG $X_CFLAGS -DUSE_XFT -I/usr/include/freetype2"
++ CXXFLAGS="-Wall -Wno-return-type -O2 $X_CFLAGS -DUSE_XFT -I/usr/local/include/freetype2"
++ CXXFLAGS_D="-Wall -Wno-return-type -g -DDEBUG $X_CFLAGS -DUSE_XFT -I/usr/local/include/freetype2"
+ LIBS="$LIBS -lXft"
else
if test "`(uname) 2>/dev/null`" = IRIX; then
diff --git a/games/seahaven/files/patch-configure.in b/games/seahaven/files/patch-configure.in
new file mode 100644
index 000000000000..9e952775f01d
--- /dev/null
+++ b/games/seahaven/files/patch-configure.in
@@ -0,0 +1,13 @@
+--- configure.in.bak 2011-07-17 15:38:31.000000000 -0600
++++ configure.in 2011-07-17 15:39:11.000000000 -0600
+@@ -20,8 +20,8 @@
+ # -Wno-return-type is necessary for Xlib header files on many systems:
+ CFLAGS="-Wall -Wno-return-type -O2 $X_CFLAGS"
+ CFLAGS_D="-Wall -Wno-return-type -g -DDEBUG $X_CFLAGS"
+- CXXFLAGS="-Wall -Wno-return-type -O2 $X_CFLAGS -DUSE_XFT -I/usr/include/freetype2"
+- CXXFLAGS_D="-Wall -Wno-return-type -g -DDEBUG $X_CFLAGS -DUSE_XFT -I/usr/include/freetype2"
++ CXXFLAGS="-Wall -Wno-return-type -O2 $X_CFLAGS -DUSE_XFT -I/usr/local/include/freetype2"
++ CXXFLAGS_D="-Wall -Wno-return-type -g -DDEBUG $X_CFLAGS -DUSE_XFT -I/usr/local/include/freetype2"
+ LIBS="$LIBS -lXft"
+ else
+ if test "`(uname) 2>/dev/null`" = IRIX; then