aboutsummaryrefslogtreecommitdiff
path: root/games/secretmaryochronicles/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-18 12:33:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-18 12:33:01 +0000
commit4f08a6c409ae3d092939b856fa38369c94f5551f (patch)
tree189977e573fd969097ea8a2299c8df5d1dc991ff /games/secretmaryochronicles/Makefile
parent0d0acb77cee558f1f70b7004f0d5c016d51714f2 (diff)
downloadports-4f08a6c409ae3d092939b856fa38369c94f5551f.tar.gz
ports-4f08a6c409ae3d092939b856fa38369c94f5551f.zip
Notes
Diffstat (limited to 'games/secretmaryochronicles/Makefile')
-rw-r--r--games/secretmaryochronicles/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/games/secretmaryochronicles/Makefile b/games/secretmaryochronicles/Makefile
new file mode 100644
index 000000000000..9337476b0234
--- /dev/null
+++ b/games/secretmaryochronicles/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: secretmaryochronicles
+# Date created: 31 Jan 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= secretmaryochronicles
+PORTVERSION= 1.4.1
+CATEGORIES= games
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= smclone
+DISTFILES= smc-${PORTVERSION}
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Secret Maryo Chronicles two-dimensional platform game
+
+LIB_DEPENDS= CEGUIBase.1:${PORTSDIR}/graphics/cegui \
+ boost_filesystem.4:${PORTSDIR}/devel/boost \
+ png.5:${PORTSDIR}/graphics/png
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= sdl image mixer ttf
+USE_GL= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+
+WRKSRC= ${WRKDIR}/${DISTFILES}
+
+DATADIR= ${PREFIX}/share/smc
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= controls.html style.css
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>