aboutsummaryrefslogtreecommitdiff
path: root/games/shaaft
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-12-24 13:51:30 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-12-24 13:51:30 +0000
commit15924ebac89ca61fc48abc4fde550f475e6d54bf (patch)
tree71fee553a31614b4fd566f7891a9cb591199555a /games/shaaft
parenta5e9cebcf64073153f6256fe9b2a27cc51508e14 (diff)
Notes
Diffstat (limited to 'games/shaaft')
-rw-r--r--games/shaaft/Makefile2
-rw-r--r--games/shaaft/files/patch-PNG.cpp21
2 files changed, 12 insertions, 11 deletions
diff --git a/games/shaaft/Makefile b/games/shaaft/Makefile
index fb5c9f2ac6ae..d467992fca44 100644
--- a/games/shaaft/Makefile
+++ b/games/shaaft/Makefile
@@ -11,7 +11,7 @@ DISTNAME= Shaaft-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenGL 3D falling block game similar to Blockout
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
CONFLICTS= criticalmass-*
diff --git a/games/shaaft/files/patch-PNG.cpp b/games/shaaft/files/patch-PNG.cpp
index 04a62f44fc70..92417be1dfe0 100644
--- a/games/shaaft/files/patch-PNG.cpp
+++ b/games/shaaft/files/patch-PNG.cpp
@@ -1,14 +1,15 @@
---- utilssdl/PNG.cpp.orig 2003-03-03 03:32:18.000000000 +0100
-+++ utilssdl/PNG.cpp 2012-05-09 12:16:57.000000000 +0200
-@@ -13,6 +13,7 @@
- // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
- //
- #include <PNG.hpp>
-+#include <pngpriv.h>
+--- utilssdl/PNG.cpp.orig 2003-03-03 02:32:18 UTC
++++ utilssdl/PNG.cpp
+@@ -45,7 +45,7 @@ void PNG::writeData( png_structp png, pn
+ {
+ png_uint_32 check;
- //Save SDL surface as png
- bool PNG::Save( SDL_Surface *img, const string &filename)
-@@ -72,7 +73,7 @@
+- check = fwrite( data, 1, length, (FILE *)(png->io_ptr));
++ check = fwrite( data, 1, length, (FILE *)(png_get_io_ptr(png)));
+ if( check != length)
+ {
+ png_error( png, "Write Error");
+@@ -72,7 +72,7 @@ bool PNG::init( FILE *fp, int width, int
return false;
}