aboutsummaryrefslogtreecommitdiff
path: root/games/shaaft
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-17 18:39:48 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-17 18:39:48 +0000
commitc27a014515c4c423b908c8c1f5c6bed1a67ce14a (patch)
treed4834143dc691ff44ce143994e7674cbedc990a3 /games/shaaft
parentf68ff4109986b750a2934da5d40179834a336507 (diff)
downloadports-c27a014515c4c423b908c8c1f5c6bed1a67ce14a.tar.gz
ports-c27a014515c4c423b908c8c1f5c6bed1a67ce14a.zip
Notes
Diffstat (limited to 'games/shaaft')
-rw-r--r--games/shaaft/Makefile22
-rw-r--r--games/shaaft/files/patch-configure58
-rw-r--r--games/shaaft/files/patch-game::main.cpp20
-rw-r--r--games/shaaft/files/patch-utilsgl::GLBitmapCollection.cpp11
-rw-r--r--games/shaaft/files/patch-utilsgl::GLTexture.hpp11
-rw-r--r--games/shaaft/files/patch-utilssdl::PNG.hpp11
6 files changed, 17 insertions, 116 deletions
diff --git a/games/shaaft/Makefile b/games/shaaft/Makefile
index 56e3cc240f85..5cb1e8d20d56 100644
--- a/games/shaaft/Makefile
+++ b/games/shaaft/Makefile
@@ -7,22 +7,34 @@
PORTNAME= shaaft
PORTVERSION= 0.5.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= sourceforge/criticalmass
+MASTER_SITE_SUBDIR= criticalmass
DISTNAME= Shaaft-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Shaaft is an OpenGL 3D falling block game similar to Blockout
+COMMENT= An OpenGL 3D falling block game similar to Blockout
+
+CONFLICTS= criticalmass-*
USE_BZIP2= yes
USE_SDL= mixer image sdl
+USE_GL= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
-
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-optimize
MAN6= ${PORTNAME}.6
+post-patch:
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG:T}|g ; \
+ s|^CXXFLAGS|#CXXFLAGS|g ; \
+ s|-lSDL | |g ; \
+ s|-lpng12|-lpng|g' ${WRKSRC}/configure
+ @${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|SDL/SDL|SDL|g'
+
.include <bsd.port.mk>
diff --git a/games/shaaft/files/patch-configure b/games/shaaft/files/patch-configure
deleted file mode 100644
index f5c82073dca7..000000000000
--- a/games/shaaft/files/patch-configure
+++ /dev/null
@@ -1,58 +0,0 @@
---- configure.orig Fri Jan 2 00:19:59 2004
-+++ configure Fri Jan 2 18:15:32 2004
-@@ -1424,7 +1424,7 @@
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-lSDL `sdl-config --libs` $LIBS"
-+LIBS="-lSDL-1.1 `sdl11-config --libs` $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 1430 "configure"
- #include "confdefs.h"
-@@ -1448,9 +1448,9 @@
- fi
- if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
- echo "$ac_t""yes" 1>&6
-- LIBS="$LIBS `sdl-config --libs`" ; \
-- CFLAGS="$CFLAGS `sdl-config --cflags`" ; \
-- CXXFLAGS="$CXXFLAGS `sdl-config --cflags`" ; \
-+ LIBS="$LIBS `sdl11-config --libs`" ; \
-+ CFLAGS="$CFLAGS `sdl11-config --cflags`" ; \
-+ CXXFLAGS="$CXXFLAGS `sdl11-config --cflags`" ; \
- HAVE_SDL=1
- else
- echo "$ac_t""no" 1>&6
-@@ -1588,14 +1588,14 @@
- LIBS="-L/usr/local/lib -L/usr/X11R6/lib $LIBS"
- CFLAGS="$CFLAGS -I/usr/X11R6/include" ; \
- CXXFLAGS="$CXXFLAGS -I/usr/X11R6/include"
-- echo $ac_n "checking for main in -lpng12""... $ac_c" 1>&6
--echo "configure:1593: checking for main in -lpng12" >&5
-+ echo $ac_n "checking for main in -lpng""... $ac_c" 1>&6
-+echo "configure:1593: checking for main in -lpng" >&5
- ac_lib_var=`echo png12'_'main | sed 'y%./+-%__p_%'`
- if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-lpng12 $LIBS"
-+LIBS="-lpng $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 1601 "configure"
- #include "confdefs.h"
-@@ -1619,13 +1619,13 @@
- fi
- if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
- echo "$ac_t""yes" 1>&6
-- ac_tr_lib=HAVE_LIB`echo png12 | sed -e 's/[^a-zA-Z0-9_]/_/g' \
-+ ac_tr_lib=HAVE_LIB`echo png | sed -e 's/[^a-zA-Z0-9_]/_/g' \
- -e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
- cat >> confdefs.h <<EOF
- #define $ac_tr_lib 1
- EOF
-
-- LIBS="-lpng12 $LIBS"
-+ LIBS="-lpng $LIBS"
-
- else
- echo "$ac_t""no" 1>&6
diff --git a/games/shaaft/files/patch-game::main.cpp b/games/shaaft/files/patch-game::main.cpp
deleted file mode 100644
index 89f87d0fcd19..000000000000
--- a/games/shaaft/files/patch-game::main.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- game/main.cpp.orig Fri Jan 2 18:26:21 2004
-+++ game/main.cpp Fri Jan 2 18:26:37 2004
-@@ -12,7 +12,7 @@
- // ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
- // FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details
- //
--#include "SDL.h" //needed for SDL_main
-+#include <SDL11/SDL.h> //needed for SDL_main
-
- #include <Trace.hpp>
- #include <Constants.hpp>
-@@ -46,7 +46,7 @@
- }
-
- #include <png.h>
--#include <SDL/SDL_mixer.h>
-+#include <SDL11/SDL_mixer.h>
- void showVersions( void)
- {
- const SDL_version *vsdl = SDL_Linked_Version();
diff --git a/games/shaaft/files/patch-utilsgl::GLBitmapCollection.cpp b/games/shaaft/files/patch-utilsgl::GLBitmapCollection.cpp
deleted file mode 100644
index 0b5bbb2bff71..000000000000
--- a/games/shaaft/files/patch-utilsgl::GLBitmapCollection.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- utilsgl/GLBitmapCollection.cpp.orig Fri Jan 2 18:19:34 2004
-+++ utilsgl/GLBitmapCollection.cpp Fri Jan 2 18:19:49 2004
-@@ -16,7 +16,7 @@
- //
- #include <iostream>
-
--#include <SDL/SDL_image.h>
-+#include <SDL11/SDL_image.h>
- #include <zrwops.hpp>
-
- #include <Trace.hpp>
diff --git a/games/shaaft/files/patch-utilsgl::GLTexture.hpp b/games/shaaft/files/patch-utilsgl::GLTexture.hpp
deleted file mode 100644
index 40cc7f58b834..000000000000
--- a/games/shaaft/files/patch-utilsgl::GLTexture.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- utilsgl/GLTexture.hpp.orig Fri Jan 2 18:21:50 2004
-+++ utilsgl/GLTexture.hpp Fri Jan 2 18:22:19 2004
-@@ -16,7 +16,7 @@
- #define _GLTexture_hpp_
-
- #include <gl++.hpp>
--#include <SDL/SDL_image.h>
-+#include <SDL11/SDL_image.h>
-
- class GLTexture
- {
diff --git a/games/shaaft/files/patch-utilssdl::PNG.hpp b/games/shaaft/files/patch-utilssdl::PNG.hpp
deleted file mode 100644
index 7130b50f7228..000000000000
--- a/games/shaaft/files/patch-utilssdl::PNG.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- utilssdl/PNG.hpp.orig Fri Jan 2 18:17:09 2004
-+++ utilssdl/PNG.hpp Fri Jan 2 18:17:33 2004
-@@ -14,7 +14,7 @@
- //
- #include <string>
- #include <png.h>
--#include "SDL/SDL.h"
-+#include <SDL11/SDL.h>
-
- using std::string;
-