aboutsummaryrefslogtreecommitdiff
path: root/games/simsu
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-08-27 17:39:52 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-08-27 17:39:52 +0000
commit3a4ed6b1f10d5e4fcd84d08979c492f581ba849c (patch)
treee3d72b294831e1f5060b4e20d5cee974227ce74f /games/simsu
parent6fbefd1963cdca7cb09f959a54fbadc5ccb39035 (diff)
downloadports-3a4ed6b1f10d5e4fcd84d08979c492f581ba849c.tar.gz
ports-3a4ed6b1f10d5e4fcd84d08979c492f581ba849c.zip
- port requires data
- adopt optionsNG for DOCS - move from cp to install_data for icons - drop INSTALL doc from PORTDOCS PR: 170742 Submitted by: maintainer, nemysis@gmx.ch
Notes
Notes: svn path=/head/; revision=303236
Diffstat (limited to 'games/simsu')
-rw-r--r--games/simsu/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/games/simsu/Makefile b/games/simsu/Makefile
index 3d2fdcb6eecb..8bcf1dc7660e 100644
--- a/games/simsu/Makefile
+++ b/games/simsu/Makefile
@@ -7,6 +7,7 @@
PORTNAME= simsu
PORTVERSION= 1.2.2
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://gottcode.org/${PORTNAME}/
EXTRACT_SUFX= -src.tar.bz2
@@ -32,29 +33,31 @@ USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
PORTDATA= *
-PORTDOCS= CREDITS ChangeLog INSTALL
+PORTDOCS= CREDITS ChangeLog
+
+.include <bsd.port.options.mk>
do-install:
# Executable
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+# Data
+ ${MKDIR} ${DATADIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} "symmetry translations" ${DATADIR})
+
# Icons
- ${CP} -R ${WRKSRC}/icons/hicolor ${PREFIX}/share/icons/
+ ${MKDIR} ${PREFIX}/share/icons/hicolor
+.for d in incons
+ @(cd ${WRKSRC}/${d} && ${COPYTREE_SHARE} hicolor ${PREFIX}/share/icons/)
+.endfor
# Pixmaps and Desktop
${INSTALL_DATA} ${WRKSRC}/icons/${PORTNAME}_32.xpm ${PREFIX}/share/pixmaps/
${MKDIR} ${PREFIX}/share/applications
${INSTALL_DATA} ${WRKSRC}/icons/${PORTNAME}.desktop ${PREFIX}/share/applications/
-post-install:
-# Data
-.if !defined (NOPORTDATA)
- ${MKDIR} ${DATADIR}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} "symmetry translations" ${DATADIR})
-.endif
-
-# Documentations
-.if !defined(NOPORTDOCS)
+# Documentation
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}