aboutsummaryrefslogtreecommitdiff
path: root/games/sjeng/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-02-23 00:35:36 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-02-23 00:35:36 +0000
commita564380f1470f544aa7a9be976e61c7592795400 (patch)
tree7e75ca4a8e66cd88479704885bb05332ba06566f /games/sjeng/Makefile
parent9aed32b19dfc53a0ca149d0953724fae0290d6e4 (diff)
downloadports-a564380f1470f544aa7a9be976e61c7592795400.tar.gz
ports-a564380f1470f544aa7a9be976e61c7592795400.zip
Notes
Diffstat (limited to 'games/sjeng/Makefile')
-rw-r--r--games/sjeng/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/games/sjeng/Makefile b/games/sjeng/Makefile
new file mode 100644
index 000000000000..f9e61467528b
--- /dev/null
+++ b/games/sjeng/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: sjeng
+# Date created: 18 Feb 2006
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sjeng
+PORTVERSION= 11.2
+CATEGORIES= games
+MASTER_SITES= http://sjeng.org/ftp/
+DISTNAME= Sjeng-Free-${PORTVERSION}
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Chess engine supporting chess variations
+
+LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgdbm"
+
+PLIST_FILES= bin/sjeng
+
+.include <bsd.port.mk>