aboutsummaryrefslogtreecommitdiff
path: root/games/slashem-tty/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2014-06-29 07:12:44 +0000
committerGreg Lewis <glewis@FreeBSD.org>2014-06-29 07:12:44 +0000
commitb80fe53ce92741d45a6ce371446725be02cbc352 (patch)
tree922761ffffae019eac0decfa3dd3b44c3caa8a96 /games/slashem-tty/Makefile
parentaf58c750658bbfe88e817cec49e71d6d1083f1d7 (diff)
downloadports-b80fe53ce92741d45a6ce371446725be02cbc352.tar.gz
ports-b80fe53ce92741d45a6ce371446725be02cbc352.zip
Notes
Diffstat (limited to 'games/slashem-tty/Makefile')
-rw-r--r--games/slashem-tty/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/games/slashem-tty/Makefile b/games/slashem-tty/Makefile
index 7f90b825cb3c..0981af871c7c 100644
--- a/games/slashem-tty/Makefile
+++ b/games/slashem-tty/Makefile
@@ -14,30 +14,30 @@ COMMENT= Dungeon explorin', slashin', hackin' game
USES= gmake
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SUB_FILES+= pkg-deinstall
-MAN6= dgn_comp.6 dlb.6 lev_comp.6 recover.6 slashem.6
MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([A-Z])./\1/g}
MAKE_ENV+= DATADIR="${DATADIR}"
-NO_STAGE= yes
+.include <bsd.port.pre.mk>
+
post-patch:
${REINPLACE_CMD} -e \
"s@%%DATADIR%%@${DATADIR}@g" ${WRKSRC}/include/config.h
-pre-configure:
+do-configure:
@cd ${WRKSRC}/sys/unix; ${SH} setup.sh
post-install:
@cd ${WRKSRC}/doc; ${CHMOD} 644 *.6
@(cd ${WRKSRC}/doc; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} manpages)
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/Guidebook.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/slamfaq.txt ${DOCSDIR}
- ${INSTALL_DATA} ${FILESDIR}/sample.slashemrc ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/Guidebook.txt ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/slamfaq.txt ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/sample.slashemrc ${STAGEDIR}${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>