aboutsummaryrefslogtreecommitdiff
path: root/games/sokoban
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-01-31 13:00:16 +0000
committerJohn Marino <marino@FreeBSD.org>2016-01-31 13:00:16 +0000
commiteb9e732d83333c76b092a74731d84cd646ad2834 (patch)
tree8159270ac71bb25b2ccebc4c2ff506401f428588 /games/sokoban
parent13c09243871f9c13663c6ad7cc9c903f04514585 (diff)
downloadports-eb9e732d83333c76b092a74731d84cd646ad2834.tar.gz
ports-eb9e732d83333c76b092a74731d84cd646ad2834.zip
Notes
Diffstat (limited to 'games/sokoban')
-rw-r--r--games/sokoban/Makefile7
-rw-r--r--games/sokoban/files/patch-Makefile6
-rw-r--r--games/sokoban/files/patch-play.c6
3 files changed, 10 insertions, 9 deletions
diff --git a/games/sokoban/Makefile b/games/sokoban/Makefile
index d6974081aa50..1148435a96c1 100644
--- a/games/sokoban/Makefile
+++ b/games/sokoban/Makefile
@@ -11,16 +11,17 @@ DISTNAME= ${PORTNAME}-src
MAINTAINER= lifanov@mail.lifanov.com
COMMENT= Logical game: problems with packets in cave
+USES= ncurses
WRKSRC= ${WRKDIR}/sokoban
ALL_TARGET=
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/sokoban ${STAGEDIR}${PREFIX}/bin/sokoban
+ ${INSTALL_PROGRAM} ${WRKSRC}/sokoban ${STAGEDIR}${PREFIX}/bin/sokoban
@${MKDIR} ${STAGEDIR}${DATADIR}/screens
- @${INSTALL_DATA} ${WRKSRC}/screens/* ${STAGEDIR}${DATADIR}/screens
+ ${INSTALL_DATA} ${WRKSRC}/screens/* ${STAGEDIR}${DATADIR}/screens
post-install:
@${MKDIR} ${STAGEDIR}/var/games/sokoban
- @truncate -s 512 ${STAGEDIR}/var/games/sokoban/scores.sample
+ truncate -s 512 ${STAGEDIR}/var/games/sokoban/scores.sample
.include <bsd.port.mk>
diff --git a/games/sokoban/files/patch-Makefile b/games/sokoban/files/patch-Makefile
index b221e139a154..7fd0b3c2e008 100644
--- a/games/sokoban/files/patch-Makefile
+++ b/games/sokoban/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./Makefile.orig 1992-05-09 19:23:46.000000000 -0400
-+++ ./Makefile 2014-03-11 22:14:36.359748029 -0400
+--- Makefile.orig 1992-05-09 23:23:46 UTC
++++ Makefile
@@ -1,8 +1,12 @@
-CCOPT= -O3
+CCOPT= ${CFLAGS}
@@ -11,7 +11,7 @@
sokoban: $(OBJECTS)
- cc $(CCOPT) -static -o sokoban $(OBJECTS) -lcurses -ltermcap
-+ cc $(CCOPT) -o sokoban $(OBJECTS) -lcurses -ltermcap
++ cc $(CCOPT) -o sokoban $(OBJECTS) $(LDFLAGS) -lncurses
sok.o: sok.c sokoban.h
cc $(CCOPT) -c sok.c
diff --git a/games/sokoban/files/patch-play.c b/games/sokoban/files/patch-play.c
index eb658bd170ed..578694b8efde 100644
--- a/games/sokoban/files/patch-play.c
+++ b/games/sokoban/files/patch-play.c
@@ -1,6 +1,6 @@
---- ./play.c.orig 1992-05-16 02:53:27.000000000 -0400
-+++ ./play.c 2014-03-11 22:14:36.546748659 -0400
-@@ -37,7 +37,7 @@
+--- play.c.orig 1992-05-16 06:53:27 UTC
++++ play.c
+@@ -37,7 +37,7 @@ static POS tmp_ppos;
short play() {