aboutsummaryrefslogtreecommitdiff
path: root/games/solarconquest/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-31 13:30:16 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-31 13:30:16 +0000
commit9715677bb7f0fbb8342ec5d19fb4b4deb670aae7 (patch)
tree2a434a570c1d171a81d4f598c79d3a2572b8cd78 /games/solarconquest/Makefile
parent16ef18761fcebeb5b9aa52482c8ef5d603aaab53 (diff)
Notes
Diffstat (limited to 'games/solarconquest/Makefile')
-rw-r--r--games/solarconquest/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/games/solarconquest/Makefile b/games/solarconquest/Makefile
new file mode 100644
index 000000000000..1c783b66076a
--- /dev/null
+++ b/games/solarconquest/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: solarconquest
+# Date created: 06 Apr 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= solarconquest
+PORTVERSION= 0.2
+CATEGORIES= games
+MASTER_SITES= http://games.sajthelper.com/
+DISTNAME= SolarConquest
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= Space 2D action game with plenty of shooting
+
+USE_SDL= sdl mixer image
+USE_GL= yes
+USE_DOS2UNIX= makefile source/MenuScreen.h source/main.cpp
+
+MAKEFILE= makefile
+MAKE_ENV= CXX="${CXX}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|images/|${DATADIR}/images/|' \
+ ${WRKSRC}/source/main.cpp
+ @${REINPLACE_CMD} -e 's|shapes/|${DATADIR}/shapes/|' \
+ ${WRKSRC}/source/main.cpp
+ @${REINPLACE_CMD} -e 's|settings.dat|.solarconquest.rc|' \
+ ${WRKSRC}/source/Common.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/solar ${PREFIX}/bin/${PORTNAME}
+ ${MKDIR} ${DATADIR}/shapes
+ ${INSTALL_DATA} ${WRKSRC}/shapes/* ${DATADIR}/shapes
+ ${MKDIR} ${DATADIR}/images/fonts
+ ${INSTALL_DATA} ${WRKSRC}/images/*.png ${DATADIR}/images
+ ${INSTALL_DATA} ${WRKSRC}/images/fonts/* ${DATADIR}/images/fonts
+
+.include <bsd.port.mk>