aboutsummaryrefslogtreecommitdiff
path: root/games/solarconquest
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-17 00:18:27 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-17 00:18:27 +0000
commit4595d44540b3f34c36a6a6d81319f47cc8016793 (patch)
tree9e56bd3d5326e76e825265648abcda6fd9f903e1 /games/solarconquest
parent5baa5eb700462b494fb1ee0f26a01e4951b03da1 (diff)
Notes
Diffstat (limited to 'games/solarconquest')
-rw-r--r--games/solarconquest/Makefile16
-rw-r--r--games/solarconquest/pkg-plist23
2 files changed, 9 insertions, 30 deletions
diff --git a/games/solarconquest/Makefile b/games/solarconquest/Makefile
index 897fca097ec8..585dee2b0646 100644
--- a/games/solarconquest/Makefile
+++ b/games/solarconquest/Makefile
@@ -19,7 +19,9 @@ USE_DOS2UNIX= makefile source/MenuScreen.h source/main.cpp
MAKEFILE= makefile
-NO_STAGE= yes
+PLIST_FILES= bin/${PORTNAME}
+PORTDATA= *
+
post-patch:
@${REINPLACE_CMD} -e 's|images/|${DATADIR}/images/|' \
${WRKSRC}/source/main.cpp
@@ -29,11 +31,11 @@ post-patch:
${WRKSRC}/source/Common.h
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/solar ${PREFIX}/bin/${PORTNAME}
- ${MKDIR} ${DATADIR}/shapes
- ${INSTALL_DATA} ${WRKSRC}/shapes/* ${DATADIR}/shapes
- ${MKDIR} ${DATADIR}/images/fonts
- ${INSTALL_DATA} ${WRKSRC}/images/*.png ${DATADIR}/images
- ${INSTALL_DATA} ${WRKSRC}/images/fonts/* ${DATADIR}/images/fonts
+ ${INSTALL_PROGRAM} ${WRKSRC}/solar ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${MKDIR} ${STAGEDIR}${DATADIR}/shapes
+ ${INSTALL_DATA} ${WRKSRC}/shapes/* ${STAGEDIR}${DATADIR}/shapes
+ ${MKDIR} ${STAGEDIR}${DATADIR}/images/fonts
+ ${INSTALL_DATA} ${WRKSRC}/images/*.png ${STAGEDIR}${DATADIR}/images
+ ${INSTALL_DATA} ${WRKSRC}/images/fonts/* ${STAGEDIR}${DATADIR}/images/fonts
.include <bsd.port.mk>
diff --git a/games/solarconquest/pkg-plist b/games/solarconquest/pkg-plist
deleted file mode 100644
index 60d704852e1c..000000000000
--- a/games/solarconquest/pkg-plist
+++ /dev/null
@@ -1,23 +0,0 @@
-bin/solarconquest
-%%DATADIR%%/images/explosion.png
-%%DATADIR%%/images/explosion_detailed.png
-%%DATADIR%%/images/fonts/glowfont_template.bmp
-%%DATADIR%%/images/fonts/smallfont.bmp
-%%DATADIR%%/shapes/advancedbomber.txt
-%%DATADIR%%/shapes/advancedbomber_source.txt
-%%DATADIR%%/shapes/advancedfighter.txt
-%%DATADIR%%/shapes/advancedfighter_source.txt
-%%DATADIR%%/shapes/aircraftcarrier.txt
-%%DATADIR%%/shapes/aircraftcarrier_source.txt
-%%DATADIR%%/shapes/destroyer.txt
-%%DATADIR%%/shapes/destroyer_source.txt
-%%DATADIR%%/shapes/laserturret.txt
-%%DATADIR%%/shapes/laserturret_source.txt
-%%DATADIR%%/shapes/spacestation.txt
-%%DATADIR%%/shapes/spacestation_source.txt
-%%DATADIR%%/shapes/turretstation.txt
-%%DATADIR%%/shapes/turretstation_source.txt
-@dirrm %%DATADIR%%/images/fonts
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%/shapes
-@dirrm %%DATADIR%%