aboutsummaryrefslogtreecommitdiff
path: root/games/solarus-quest-editor
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-12-25 11:59:36 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-12-25 11:59:36 +0000
commit8325f6c0ec9c0458179738a57504a97148fe2a92 (patch)
tree4fbfebd430e700ca29412952dbadb29e1a033de6 /games/solarus-quest-editor
parent16c8b4c7661cd0ecba12ef608f1a990054d5fba4 (diff)
downloadports-8325f6c0ec9c0458179738a57504a97148fe2a92.tar.gz
ports-8325f6c0ec9c0458179738a57504a97148fe2a92.zip
Notes
Diffstat (limited to 'games/solarus-quest-editor')
-rw-r--r--games/solarus-quest-editor/Makefile17
-rw-r--r--games/solarus-quest-editor/distinfo6
-rw-r--r--games/solarus-quest-editor/files/patch-include_widgets_plain__text__edit.h11
-rw-r--r--games/solarus-quest-editor/files/patch-qt51136
4 files changed, 13 insertions, 57 deletions
diff --git a/games/solarus-quest-editor/Makefile b/games/solarus-quest-editor/Makefile
index 0473316ef81d..07a7f073878d 100644
--- a/games/solarus-quest-editor/Makefile
+++ b/games/solarus-quest-editor/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= solarus-quest-editor
-PORTVERSION= 1.5.3
-PORTREVISION= 3
+PORTVERSION= 1.6.0
DISTVERSIONPREFIX= v
CATEGORIES= games
@@ -18,15 +17,19 @@ LIB_DEPENDS= libphysfs.so:devel/physfs \
liblua-5.1.so:lang/lua51 \
libvorbis.so:audio/libvorbis \
libogg.so:audio/libogg \
- libsolarus.so:games/solarus
+ libsolarus.so:games/solarus \
-USE_GITHUB= yes
-GH_ACCOUNT= christopho
+BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:math/glm
+
+USES= cmake compiler:c++11-lib openal qt:5
+
+USE_GITLAB= yes
+GL_ACCOUNT= solarus-games
+GL_COMMIT= 47ebde229b805ebe076ab6ef7f8e947a06a17451
CMAKE_ARGS+= -DSOLARUS_USE_LUAJIT=OFF
USE_SDL= sdl2 ttf2 image2
-USE_QT= buildtools core gui linguist qmake widgets
-USES= cmake compiler:c++11-lib openal qt:5
+USE_QT= buildtools concurrent core gui linguist qmake widgets
DESKTOP_ENTRIES= "Solarus Quest Editor" "${COMMENT}" "${PORTNAME}" "${PORTNAME}" \
"Game;" false
diff --git a/games/solarus-quest-editor/distinfo b/games/solarus-quest-editor/distinfo
index 33961b1b697e..d23e09a40313 100644
--- a/games/solarus-quest-editor/distinfo
+++ b/games/solarus-quest-editor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1492117065
-SHA256 (christopho-solarus-quest-editor-v1.5.3_GH0.tar.gz) = 2274388d2f91641c46fd141e7fdfb461b1ae84a83b497f2cea54180102e8c60a
-SIZE (christopho-solarus-quest-editor-v1.5.3_GH0.tar.gz) = 67711657
+TIMESTAMP = 1545689078
+SHA256 (solarus-games-solarus-quest-editor-47ebde229b805ebe076ab6ef7f8e947a06a17451_GL0.tar.gz) = 2b70da748b564ee593e093e937bfa4392706c71c049a3e135916c8d175094171
+SIZE (solarus-games-solarus-quest-editor-47ebde229b805ebe076ab6ef7f8e947a06a17451_GL0.tar.gz) = 68711893
diff --git a/games/solarus-quest-editor/files/patch-include_widgets_plain__text__edit.h b/games/solarus-quest-editor/files/patch-include_widgets_plain__text__edit.h
deleted file mode 100644
index da0edafcea19..000000000000
--- a/games/solarus-quest-editor/files/patch-include_widgets_plain__text__edit.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/widgets/plain_text_edit.h.orig 2016-07-30 20:59:16 UTC
-+++ include/widgets/plain_text_edit.h
-@@ -75,7 +75,7 @@ protected:
- if (show_margin) {
- const QRect rect = event->rect();
- const QFont font = currentCharFormat().font();
-- int x = std::round(QFontMetrics(font).maxWidth() * margin)
-+ int x = ::round(QFontMetrics(font).maxWidth() * margin)
- + contentOffset().x()
- + document()->documentMargin();
-
diff --git a/games/solarus-quest-editor/files/patch-qt511 b/games/solarus-quest-editor/files/patch-qt511
deleted file mode 100644
index 99555bdc2c7f..000000000000
--- a/games/solarus-quest-editor/files/patch-qt511
+++ /dev/null
@@ -1,36 +0,0 @@
-Fix build with Qt 5.11
-Fixed upstream:
-https://gitlab.com/solarus-games/solarus-quest-editor/commit/8f308463030c18cd4f7c8a6052028fff3b7ca35a
-https://gitlab.com/solarus-games/solarus-quest-editor/commit/f285beab62594f73e57190c49848c848487214cf
-
---- include/widgets/map_view.h.orig 2017-04-03 11:37:49 UTC
-+++ include/widgets/map_view.h
-@@ -21,6 +21,8 @@
- #include <QGraphicsView>
- #include <QPointer>
-
-+class QActionGroup;
-+
- namespace SolarusEditor {
-
- class MapModel;
---- src/widgets/map_view.cpp.orig 2017-04-03 11:37:49 UTC
-+++ src/widgets/map_view.cpp
-@@ -29,6 +29,7 @@
- #include "tileset_model.h"
- #include "view_settings.h"
- #include <QAction>
-+#include <QActionGroup>
- #include <QApplication>
- #include <QClipboard>
- #include <QDebug>
---- src/widgets/text_editor.cpp.orig 2017-04-03 11:37:49 UTC
-+++ src/widgets/text_editor.cpp
-@@ -26,6 +26,7 @@
- #include <QList>
- #include <QPlainTextEdit>
- #include <QScrollBar>
-+#include <QAction>
- #include <QTextStream>
-
- namespace SolarusEditor {