aboutsummaryrefslogtreecommitdiff
path: root/games/solarwolf
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-06-25 14:57:21 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-06-25 14:57:21 +0000
commitedda0f3bb9517d1794a4ce86af3381c727e998c9 (patch)
treebca13d81f2b9d841a94b7552740124c330e6f6c9 /games/solarwolf
parentf8374cc7fcf07ec1b1de2a00f039cf3f153240ed (diff)
downloadports-edda0f3bb9517d1794a4ce86af3381c727e998c9.tar.gz
ports-edda0f3bb9517d1794a4ce86af3381c727e998c9.zip
Use "exec" statement in the helper script to avoid leaving useless sh instance
hanging around.
Notes
Notes: svn path=/head/; revision=44420
Diffstat (limited to 'games/solarwolf')
-rw-r--r--games/solarwolf/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/solarwolf/Makefile b/games/solarwolf/Makefile
index a7213636a225..9216ea84f41e 100644
--- a/games/solarwolf/Makefile
+++ b/games/solarwolf/Makefile
@@ -24,7 +24,7 @@ do-install:
(cd ${WRKSRC}; tar cf - .) | \
(cd ${PREFIX}/share/solarwolf; tar --unlink -xf -)
@printf "#!/bin/sh\ncd ${PREFIX}/share/solarwolf && \
- ${PYTHON_CMD} ${PREFIX}/share/solarwolf/solarwolf.py\n" > ${WRKDIR}/solarwolf.sh
+ exec ${PYTHON_CMD} ${PREFIX}/share/solarwolf/solarwolf.py\n" > ${WRKDIR}/solarwolf.sh
@${INSTALL_SCRIPT} ${WRKDIR}/solarwolf.sh ${PREFIX}/bin/solarwolf
.include <bsd.port.mk>