aboutsummaryrefslogtreecommitdiff
path: root/games/species
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-01-30 04:27:43 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-01-30 04:27:43 +0000
commit9ac5382ccbc413b496bcd9c2aeff256755986f94 (patch)
tree1a0123bc0adb5139d925ca7fe9ce4c8ec677b1ea /games/species
parent849f4a2e3c2546397ce3d49348d2f6bd35c99382 (diff)
downloadports-9ac5382ccbc413b496bcd9c2aeff256755986f94.tar.gz
ports-9ac5382ccbc413b496bcd9c2aeff256755986f94.zip
Notes
Diffstat (limited to 'games/species')
-rw-r--r--games/species/Makefile44
-rw-r--r--games/species/distinfo3
-rw-r--r--games/species/files/patch-Makefile30
-rw-r--r--games/species/pkg-descr9
-rw-r--r--games/species/pkg-plist120
5 files changed, 206 insertions, 0 deletions
diff --git a/games/species/Makefile b/games/species/Makefile
new file mode 100644
index 000000000000..fd7a776ef77d
--- /dev/null
+++ b/games/species/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: species
+# Date created: 2008-01-15
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= species
+PORTVERSION= 1.2d
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= alepulver
+DISTNAME= redcoder
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Corewars evolver - generates warriors using genetic algorithms
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+OPTIONS= VISITOOL "Buil GUI tool for displaying evolution" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_VISITOOL)
+USE_WX= 2.4
+ALL_TARGET= all visitool
+PLIST_SUB+= VISITOOL=""
+.else
+PLIST_SUB+= VISITOOL="@comment "
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} koen.* species.ini *.rc ${DATADIR}
+ cd ${WRKSRC} && ${CP} -r bench evolver_hill wilfiz ${DATADIR}
+.if defined(WITH_VISITOOL)
+ ${INSTALL_PROGRAM} ${WRKSRC}/visitool \
+ ${PREFIX}/bin/${PORTNAME}-visitool
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/species/distinfo b/games/species/distinfo
new file mode 100644
index 000000000000..89a9e6c3ec9f
--- /dev/null
+++ b/games/species/distinfo
@@ -0,0 +1,3 @@
+MD5 (redcoder.tar.bz2) = a3a083413ba8d614f0615e4f4fa2797f
+SHA256 (redcoder.tar.bz2) = d1cbae5ff55e5e9f7ed31b1eea0644ee1a008db5c0c0cf090fcaca30be7528a1
+SIZE (redcoder.tar.bz2) = 153446
diff --git a/games/species/files/patch-Makefile b/games/species/files/patch-Makefile
new file mode 100644
index 000000000000..8bb63db5c344
--- /dev/null
+++ b/games/species/files/patch-Makefile
@@ -0,0 +1,30 @@
+--- ./Makefile.orig Sun Feb 22 03:54:24 2004
++++ ./Makefile Wed Jan 16 18:29:09 2008
+@@ -1,8 +1,8 @@
+ # makefile for species
+
+-CC = gcc
+-CPP = g++
+-LD = g++
++CC ?= gcc
++CPP = $(CXX)
++LD = $(CXX)
+
+ OPT = -O4
+ DBG =
+@@ -11,12 +11,12 @@
+ #OPT += -mcpu=i686 -march=i686
+ #DBG += -W -Wall -pedantic -ansi
+
+-CFLAGS = ${OPT} ${DBG}
++CFLAGS += ${OPT} ${DBG} ${WXCFLAGS} -include math.h
+ CPPFLAGS = ${OPT} ${DBG}
+
+ #set WXDIR if it isn't a global variable on your system, and you will be making visitool (species itself doesn't need wxWindows)
+-WXCFLAGS = -I${WXDIR}/lib/wx/include/msw-2.4 -I${WXDIR}/include -I${WXDIR}/src/regex -I${WXDIR}/src/zlib -I${WXDIR}/src/png -I${WXDIR}/src/jpeg -I${WXDIR}/src/tiff -D_WIN32_IE=0x400 -D__WXMSW__ -mthreads -DWXUSINGDLL=1 -fno-pcc-struct-return -O4 -MMD -mthreads -Wall
+-WXLD = -L${WXDIR}/lib -lwxmsw240 -Wl,--subsystem,windows -mwindows -mthreads
++WXCFLAGS = `${WX_CONFIG} --cflags`
++WXLD = `${WX_CONFIG} --libs`
+
+ #exhaust files
+ EXHAUST = sim.o asm.o pspace.o
diff --git a/games/species/pkg-descr b/games/species/pkg-descr
new file mode 100644
index 000000000000..1c00ee5d8051
--- /dev/null
+++ b/games/species/pkg-descr
@@ -0,0 +1,9 @@
+Species is a corewars evolver. It is a program to generates corewars warriors
+using genetic algorithms. This is the program which generated the best evolved
+warrior in the recent Multi-Manics corewars competition. Contemporaries
+include YACE, RedRace, Red Maker and CCAI.
+
+Species is definitely the most over-engineered, complicated and buggy Corewars
+Evolver on the freeware market today!
+
+WWW: http://redcoder.sourceforge.net/?p=species
diff --git a/games/species/pkg-plist b/games/species/pkg-plist
new file mode 100644
index 000000000000..14740d399613
--- /dev/null
+++ b/games/species/pkg-plist
@@ -0,0 +1,120 @@
+bin/species
+%%VISITOOL%%bin/species-visitool
+%%DATADIR%%/bench/Armadillo.red
+%%DATADIR%%/bench/Armadillo.red.rc
+%%DATADIR%%/bench/B-scanner 1.red
+%%DATADIR%%/bench/B-scanner 1.red.rc
+%%DATADIR%%/bench/B-scanner 2.red
+%%DATADIR%%/bench/B-scanner 2.red.rc
+%%DATADIR%%/bench/CMP-scanner 1.red
+%%DATADIR%%/bench/CMP-scanner 1.red.rc
+%%DATADIR%%/bench/CMP-scanner 2.red
+%%DATADIR%%/bench/Cannonade Stone.red
+%%DATADIR%%/bench/Cannonade Stone.red.rc
+%%DATADIR%%/bench/Keystone Stone.red
+%%DATADIR%%/bench/Keystone Stone.red.rc
+%%DATADIR%%/bench/Night Crawler Stone.red
+%%DATADIR%%/bench/Night Crawler Stone.red.rc
+%%DATADIR%%/bench/Winter Werewolf.red
+%%DATADIR%%/bench/Winter Werewolf.red.rc
+%%DATADIR%%/bench/crimp2.red
+%%DATADIR%%/bench/crimp2.red.rc
+%%DATADIR%%/bench/dwarf.red
+%%DATADIR%%/bench/dwarf.red.rc
+%%DATADIR%%/bench/mice.red
+%%DATADIR%%/bench/mice.red.rc
+%%DATADIR%%/bench/notepaper.red
+%%DATADIR%%/bench/notepaper.red.rc
+%%DATADIR%%/bench/paper 2.red
+%%DATADIR%%/bench/paper 2.red.rc
+%%DATADIR%%/bench/paper 3.red
+%%DATADIR%%/bench/paper 3.red.rc
+%%DATADIR%%/bench/paper1.red
+%%DATADIR%%/bench/paper1.red.rc
+%%DATADIR%%/bench/pittrap.red
+%%DATADIR%%/bench/pittrap.red.rc
+%%DATADIR%%/bench/red2rc.bat
+%%DATADIR%%/bench/stone.red
+%%DATADIR%%/bench/stone.red.rc
+%%DATADIR%%/bench/sucker5.red
+%%DATADIR%%/bench/sucker5.red.rc
+%%DATADIR%%/bench/twilight.red
+%%DATADIR%%/bench/twilight.red.rc
+%%DATADIR%%/bench/vampire 1.red
+%%DATADIR%%/bench/vampire 1.red.rc
+%%DATADIR%%/bench/vampire 2.red
+%%DATADIR%%/bench/vampire 2.red.rc
+%%DATADIR%%/evolver_hill/Evolved--1.rc
+%%DATADIR%%/evolver_hill/Evolved--1.red
+%%DATADIR%%/evolver_hill/Evolved--10.rc
+%%DATADIR%%/evolver_hill/Evolved--10.red
+%%DATADIR%%/evolver_hill/Evolved--11.rc
+%%DATADIR%%/evolver_hill/Evolved--11.red
+%%DATADIR%%/evolver_hill/Evolved--12.rc
+%%DATADIR%%/evolver_hill/Evolved--12.red
+%%DATADIR%%/evolver_hill/Evolved--13.rc
+%%DATADIR%%/evolver_hill/Evolved--13.red
+%%DATADIR%%/evolver_hill/Evolved--14.rc
+%%DATADIR%%/evolver_hill/Evolved--14.red
+%%DATADIR%%/evolver_hill/Evolved--15.rc
+%%DATADIR%%/evolver_hill/Evolved--15.red
+%%DATADIR%%/evolver_hill/Evolved--16.rc
+%%DATADIR%%/evolver_hill/Evolved--16.red
+%%DATADIR%%/evolver_hill/Evolved--16.red~
+%%DATADIR%%/evolver_hill/Evolved--17.rc
+%%DATADIR%%/evolver_hill/Evolved--17.red
+%%DATADIR%%/evolver_hill/Evolved--18.rc
+%%DATADIR%%/evolver_hill/Evolved--18.red
+%%DATADIR%%/evolver_hill/Evolved--19.rc
+%%DATADIR%%/evolver_hill/Evolved--19.red
+%%DATADIR%%/evolver_hill/Evolved--2.rc
+%%DATADIR%%/evolver_hill/Evolved--2.red
+%%DATADIR%%/evolver_hill/Evolved--20.rc
+%%DATADIR%%/evolver_hill/Evolved--20.red
+%%DATADIR%%/evolver_hill/Evolved--3.rc
+%%DATADIR%%/evolver_hill/Evolved--3.red
+%%DATADIR%%/evolver_hill/Evolved--4.rc
+%%DATADIR%%/evolver_hill/Evolved--4.red
+%%DATADIR%%/evolver_hill/Evolved--5.rc
+%%DATADIR%%/evolver_hill/Evolved--5.red
+%%DATADIR%%/evolver_hill/Evolved--6.rc
+%%DATADIR%%/evolver_hill/Evolved--6.red
+%%DATADIR%%/evolver_hill/Evolved--7.rc
+%%DATADIR%%/evolver_hill/Evolved--7.red
+%%DATADIR%%/evolver_hill/Evolved--8.rc
+%%DATADIR%%/evolver_hill/Evolved--8.red
+%%DATADIR%%/evolver_hill/Evolved--9.rc
+%%DATADIR%%/evolver_hill/Evolved--9.red
+%%DATADIR%%/evolver_hill/red2rc.bat
+%%DATADIR%%/koen.markov2
+%%DATADIR%%/koen.operands
+%%DATADIR%%/runtest_dummy.rc
+%%DATADIR%%/species.ini
+%%DATADIR%%/wilfiz/behemot.rc
+%%DATADIR%%/wilfiz/behemot.red
+%%DATADIR%%/wilfiz/crazyshot2.rc
+%%DATADIR%%/wilfiz/crazyshot2.red
+%%DATADIR%%/wilfiz/hazylazy.rc
+%%DATADIR%%/wilfiz/hazylazy.red
+%%DATADIR%%/wilfiz/npaper2.rc
+%%DATADIR%%/wilfiz/npaper2.red
+%%DATADIR%%/wilfiz/reepicheep.rc
+%%DATADIR%%/wilfiz/reepicheep.red
+%%DATADIR%%/wilfiz/revengepaper.rc
+%%DATADIR%%/wilfiz/revengepaper.red
+%%DATADIR%%/wilfiz/rotfcopy.rc
+%%DATADIR%%/wilfiz/rotfcopy.red
+%%DATADIR%%/wilfiz/silvertalon12.rc
+%%DATADIR%%/wilfiz/silvertalon12.red
+%%DATADIR%%/wilfiz/sonofvain.rc
+%%DATADIR%%/wilfiz/sonofvain.red
+%%DATADIR%%/wilfiz/uninvited.rc
+%%DATADIR%%/wilfiz/uninvited.red
+%%DATADIR%%/wilfiz/vanquisher2.rc
+%%DATADIR%%/wilfiz/vanquisher2.red
+%%DATADIR%%/wilfiz/willow.rc
+%%DATADIR%%/wilfiz/willow.red
+@dirrm %%DATADIR%%/wilfiz
+@dirrm %%DATADIR%%/evolver_hill
+@dirrm %%DATADIR%%/bench
+@dirrm %%DATADIR%%