aboutsummaryrefslogtreecommitdiff
path: root/games/spellathon/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-10-31 21:42:03 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-10-31 21:42:03 +0000
commitfd8feccb65d6270fd18bdf049de22ff7c89da20d (patch)
treee339981a2f038c6c9e5c13b9fded76d643c18d18 /games/spellathon/Makefile
parent8dd184229c63c85021a227532565202258c17ba2 (diff)
Notes
Diffstat (limited to 'games/spellathon/Makefile')
-rw-r--r--games/spellathon/Makefile44
1 files changed, 35 insertions, 9 deletions
diff --git a/games/spellathon/Makefile b/games/spellathon/Makefile
index 463ccf6de154..7f7278e23f4a 100644
--- a/games/spellathon/Makefile
+++ b/games/spellathon/Makefile
@@ -2,24 +2,50 @@
# $FreeBSD$
PORTNAME= spellathon
-PORTVERSION= 5.79
-PORTREVISION= 1
+PORTVERSION= 6.0
CATEGORIES= games
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/Spellathon%20${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Word game to test your English vocabulary skills
-USE_QT4= gui moc_build qmake_build rcc_build uic_build
+LICENSE= BSD
+
+LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ png15:${PORTSDIR}/graphics/png \
+ freetype:${PORTSDIR}/print/freetype2 \
+ expat:${PORTSDIR}/textproc/expat2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
+
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_GNOME= glib20
+USE_QT4= corelib gui moc_build qmake_build rcc_build uic_build
+USE_XORG= ice sm x11 xau xdmcp xext xrender
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+DESKTOP_ENTRIES="Spellathon" "${COMMENT}" "" "${PORTNAME}" "" "true"
post-patch:
- @${REINPLACE_CMD} 's|qmake|qmake-qt4|' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} 's|dict/words.txt|${DATADIR}/words.txt|' \
- ${WRKSRC}/src/logic/defines.h
+ @${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|$${CC}|$${CXX}|g ; \
+ s|$${CFLAGS}|$${CXXFLAGS}|g ; \
+ s|qmake-qt4|${TRUE}|'
+ @${REINPLACE_CMD} \
+ 's|dict/words.txt|${DATADIR}/words.txt|' ${WRKSRC}/src/logic/defines.h
+
+do-configure:
+ @(cd ${WRKSRC}/src/gui && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS})
do-install:
- ${INSTALL} ${WRKSRC}/spellathon ${PREFIX}/bin
- ${INSTALL} ${WRKSRC}/spellathon-cl ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/spellathon ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/spellathon-cl ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libspellathon.so.0.0 ${PREFIX}/lib
+ ${LN} -sf libspellathon.so.0.0 ${PREFIX}/lib/libspellathon.so
+ ${LN} -sf libspellathon.so.0.0 ${PREFIX}/lib/libspellathon.so.0
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/dict/words.txt ${DATADIR}