aboutsummaryrefslogtreecommitdiff
path: root/games/spicetrade
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-11 02:24:26 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-11 02:24:26 +0000
commit7bb493fa225175d2345b2dfde432f2d7759fa7fd (patch)
treee983afc63ef31a9d6fed31227aeeba8312032f45 /games/spicetrade
parent844df1072e3cdf323de7e1f5eacbee536d12750b (diff)
downloadports-7bb493fa225175d2345b2dfde432f2d7759fa7fd.tar.gz
ports-7bb493fa225175d2345b2dfde432f2d7759fa7fd.zip
Notes
Diffstat (limited to 'games/spicetrade')
-rw-r--r--games/spicetrade/Makefile35
-rw-r--r--games/spicetrade/distinfo2
-rw-r--r--games/spicetrade/files/spicetrade.in2
-rw-r--r--games/spicetrade/pkg-descr7
4 files changed, 46 insertions, 0 deletions
diff --git a/games/spicetrade/Makefile b/games/spicetrade/Makefile
new file mode 100644
index 000000000000..d8851864b855
--- /dev/null
+++ b/games/spicetrade/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: spicetrade
+# Date created: 2005-09-09
+# Whom: Daniel Roethlisberger <daniel@roe.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spicetrade
+PORTVERSION= 1.2
+CATEGORIES= games java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= Spicetrade-${PORTVERSION}
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY=
+
+MAINTAINER= daniel@roe.ch
+COMMENT= Colourful 14th century Arab spice trading game
+
+USE_JAVA= 1.4+
+USE_X_PREFIX= yes
+NO_BUILD= yes
+
+SUB_FILES= ${PORTNAME}
+SUB_LIST= JARFILE="${DATADIR}/${DISTFILES}"
+
+PLIST_FILES= bin/spicetrade %%DATADIR%%/${DISTFILES}
+PLIST_DIRS= %%DATADIR%%
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DISTFILES} ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/spicetrade/distinfo b/games/spicetrade/distinfo
new file mode 100644
index 000000000000..26b82facb448
--- /dev/null
+++ b/games/spicetrade/distinfo
@@ -0,0 +1,2 @@
+MD5 (Spicetrade-1.2.jar) = b87495f0502b1a6baf2ae4e167918720
+SIZE (Spicetrade-1.2.jar) = 194859911
diff --git a/games/spicetrade/files/spicetrade.in b/games/spicetrade/files/spicetrade.in
new file mode 100644
index 000000000000..fcc36a1548de
--- /dev/null
+++ b/games/spicetrade/files/spicetrade.in
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec java -jar %%JARFILE%% "$@"
diff --git a/games/spicetrade/pkg-descr b/games/spicetrade/pkg-descr
new file mode 100644
index 000000000000..56884979bcbe
--- /dev/null
+++ b/games/spicetrade/pkg-descr
@@ -0,0 +1,7 @@
+Spicetrade is a unique, innovative and colourful 14th century Arab spice
+trading game with some roleplay elements. You start out as a poor young
+lad in Baghdad, and try your luck in the spice trade, with only a house
+and some land, but with great plans in mind: travel to Europe and create
+your own spice empire!
+
+WWW: http://www.spicetrade.org/