aboutsummaryrefslogtreecommitdiff
path: root/games/spring/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-12-21 12:55:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-12-21 12:55:29 +0000
commit265b94cbd985d8325ce685e3a20284d15baf17ad (patch)
treef9a3cbdb106f45b2fd287bd389b797ae0901b796 /games/spring/Makefile
parent4132656f3136b83de66cb151558288c4007fcb46 (diff)
downloadports-265b94cbd985d8325ce685e3a20284d15baf17ad.tar.gz
ports-265b94cbd985d8325ce685e3a20284d15baf17ad.zip
Notes
Diffstat (limited to 'games/spring/Makefile')
-rw-r--r--games/spring/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/games/spring/Makefile b/games/spring/Makefile
index 28840d67ab4e..a4a00c8ad083 100644
--- a/games/spring/Makefile
+++ b/games/spring/Makefile
@@ -21,8 +21,10 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libexecinfo.so:${PORTSDIR}/devel/libexecinfo
BUILD_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= relies on x86 floating-point math
+# XXX: it should be possible to build it on i386, investigate
+# (currently link fails on undefined reference to __sync_fetch_and_add_8)
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= relies on x86 floating-point math and amd64 atomic ops
USE_SDL= sdl
USE_OPENAL= al
@@ -65,10 +67,6 @@ PR_DOWNLOADER_LIB_DEPENDS=libcurl.so:${PORTSDIR}/ftp/curl
.include <bsd.port.options.mk>
-.if ${ARCH} == "i386"
-BROKEN= does not build on i386 (undefined reference to __sync_fetch_and_add_8)
-.endif
-
.if defined(WITH_SYNC_DEBUG)
CFLAGS= # empty
CXXFLAGS= # empty