aboutsummaryrefslogtreecommitdiff
path: root/games/starfighter
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2016-01-24 00:21:32 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2016-01-24 00:21:32 +0000
commitbd2c34ac1d6027c452d65c4ef7fa597c53134537 (patch)
treeb9d2865225ea7ea29cc474bc8bf9041c9bdc4dfd /games/starfighter
parentdb16470403d4d4660663b574f9a1a7ed09fce019 (diff)
downloadports-bd2c34ac1d6027c452d65c4ef7fa597c53134537.tar.gz
ports-bd2c34ac1d6027c452d65c4ef7fa597c53134537.zip
Notes
Diffstat (limited to 'games/starfighter')
-rw-r--r--games/starfighter/Makefile64
-rw-r--r--games/starfighter/distinfo8
-rw-r--r--games/starfighter/pkg-plist230
3 files changed, 267 insertions, 35 deletions
diff --git a/games/starfighter/Makefile b/games/starfighter/Makefile
index 4e38ec4ec6a2..06cee2a7cee7 100644
--- a/games/starfighter/Makefile
+++ b/games/starfighter/Makefile
@@ -2,61 +2,63 @@
# $FreeBSD$
PORTNAME= starfighter
-PORTVERSION= 1.2
-PORTREVISION= 4
+PORTVERSION= 1.5.1.1
CATEGORIES= games
-MASTER_SITES= SF/pr-${PORTNAME}/ \
- SF/nemysisfreebsdp/${CATEGORIES}/:icons
-DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}.png:icons
+MASTER_SITES= SAVANNAH/${PORTNAME}/1.5 \
+ SF/nemysisfreebsdp/${CATEGORIES}/${PORTNAME}/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}-src${EXTRACT_SUFX} \
+ ${PORTNAME}-icons${EXTRACT_SUFX}:icons
DIST_SUBDIR= ${PORTNAME}
-EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= nemysis@FreeBSD.org
COMMENT= Liberate the universe from the evil company WEAPCO
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/docs/LICENSE
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}-src
-USES= gmake iconv python:2,build shebangfix
-USE_XORG= x11 xau xdmcp
-USE_SDL= image mixer
-WITH_ZLIB= yes
-MAKEFILE= makefile
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
-SHEBANG_FILES= pack.py unpack.py
+USES= gmake dos2unix iconv
+USE_SDL= image2 mixer2
-INSTALLS_ICONS= yes
+DOS2UNIX_GLOB= *.txt
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.png \
- %%DATADIR%%/${PORTNAME}.pak
+PORTDOCS= *
-PORTDOCS= index.html
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= README.txt
-OPTIONS_DEFINE= DOCS
+DOCSRCDIR2= ${WRKSRC}/docs/
+DOCSDIR2= ${DOCSDIR}/docs/
+DOC_FILES2= *.png *.html
-DESKTOP_ENTRIES="Project Starfighter" "" "${PORTNAME}" \
- "${PORTNAME}" "Game;ArcadeGame;" ""
+OPTIONS_DEFINE= DOCS
+
+INSTALLS_ICONS= yes
+ICON_SIZES= 16x16 32x32 48x48 64x64 72x72 96x96 128x128
post-patch:
@${REINPLACE_CMD} \
- -e 's|mkdir -p $$(DESTDIR)$$(DOCDIR)|| ; \
- s|cp -p $$(DOCS) $$(DESTDIR)$$(DOCDIR)|| ; \
- s| -O2 -Wall|${CXXFLAGS}| ; \
- s|docs/\*|docs/index.html| ; \
+ -e 's| -O2 -Wall|${CXXFLAGS}| ; \
+ s|mkdir -p $$(DESTDIR)$$(DOCDIR)|| ; \
+ s|cp $$(DOCS) $$(DESTDIR)$$(DOCDIR)|| ; \
s|/usr|${LOCALBASE}| ; \
s|$$(PREFIX)/games/|$$(PREFIX)/bin/| ; \
s|/share/games/parallelrealities/|/share/starfighter/|' \
- ${WRKSRC}/makefile
+ ${WRKSRC}/Makefile
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
- ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/
+.for s in ${ICON_SIZES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.endfor
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
.include <bsd.port.mk>
diff --git a/games/starfighter/distinfo b/games/starfighter/distinfo
index 0a5dcc6fe57f..1a2c88830d92 100644
--- a/games/starfighter/distinfo
+++ b/games/starfighter/distinfo
@@ -1,4 +1,4 @@
-SHA256 (starfighter/starfighter-1.2.tar.gz) = d2e05e45bbc49cbe4f597e0db715fdf64e2aa771f1c77d5055d9db9d5e32fd5e
-SIZE (starfighter/starfighter-1.2.tar.gz) = 1233548
-SHA256 (starfighter/starfighter.png) = 7e6b0ccb71b5f52c96044db7b063f61f862c87fe3d7405fa6e521d335638c53b
-SIZE (starfighter/starfighter.png) = 1203
+SHA256 (starfighter/starfighter-1.5.1.1-src.tar.gz) = af277bf7fafd69a57c2196d07691427cc0ab0e1345dfe8921d5ea39a388480e1
+SIZE (starfighter/starfighter-1.5.1.1-src.tar.gz) = 45844016
+SHA256 (starfighter/starfighter-icons.tar.gz) = 34a0b92f6b9d256aa1f201a72c00306212921de4921f2a37969cad73222ad6fc
+SIZE (starfighter/starfighter-icons.tar.gz) = 38812
diff --git a/games/starfighter/pkg-plist b/games/starfighter/pkg-plist
new file mode 100644
index 000000000000..0911386e3539
--- /dev/null
+++ b/games/starfighter/pkg-plist
@@ -0,0 +1,230 @@
+bin/starfighter
+share/applications/starfighter.desktop
+share/icons/hicolor/128x128/apps/starfighter.png
+share/icons/hicolor/16x16/apps/starfighter.png
+share/icons/hicolor/32x32/apps/starfighter.png
+share/icons/hicolor/48x48/apps/starfighter.png
+share/icons/hicolor/64x64/apps/starfighter.png
+share/icons/hicolor/72x72/apps/starfighter.png
+share/icons/hicolor/96x96/apps/starfighter.png
+share/pixmaps/starfighter.png
+%%DATADIR%%/data/credits.txt
+%%DATADIR%%/data/intro.txt
+%%DATADIR%%/gfx/aimFighter1.png
+%%DATADIR%%/gfx/aimFighter2.png
+%%DATADIR%%/gfx/alienDevice.png
+%%DATADIR%%/gfx/arrowEast.png
+%%DATADIR%%/gfx/arrowNorth.png
+%%DATADIR%%/gfx/arrowNorthEast.png
+%%DATADIR%%/gfx/arrowNorthWest.png
+%%DATADIR%%/gfx/arrowSouth.png
+%%DATADIR%%/gfx/arrowSouthEast.png
+%%DATADIR%%/gfx/arrowSouthWest.png
+%%DATADIR%%/gfx/arrowWest.png
+%%DATADIR%%/gfx/asteroid1.png
+%%DATADIR%%/gfx/asteroid2.png
+%%DATADIR%%/gfx/asteroid3.png
+%%DATADIR%%/gfx/barrier.png
+%%DATADIR%%/gfx/buyIcon.png
+%%DATADIR%%/gfx/cargo1.png
+%%DATADIR%%/gfx/chainLink.png
+%%DATADIR%%/gfx/cloakShip1.png
+%%DATADIR%%/gfx/cloakShip2.png
+%%DATADIR%%/gfx/credits.jpg
+%%DATADIR%%/gfx/cursor.png
+%%DATADIR%%/gfx/dollar.png
+%%DATADIR%%/gfx/drone1.png
+%%DATADIR%%/gfx/drone2.png
+%%DATADIR%%/gfx/dualFighter1.png
+%%DATADIR%%/gfx/dualFighter2.png
+%%DATADIR%%/gfx/elec1.png
+%%DATADIR%%/gfx/elec2.png
+%%DATADIR%%/gfx/elec3.png
+%%DATADIR%%/gfx/elec4.png
+%%DATADIR%%/gfx/eliteFighter1.png
+%%DATADIR%%/gfx/eliteFighter2.png
+%%DATADIR%%/gfx/escort1.png
+%%DATADIR%%/gfx/escort2.png
+%%DATADIR%%/gfx/evilUrsula1.png
+%%DATADIR%%/gfx/evilUrsula2.png
+%%DATADIR%%/gfx/execTrans1.png
+%%DATADIR%%/gfx/execTrans2.png
+%%DATADIR%%/gfx/explode05.png
+%%DATADIR%%/gfx/explode06.png
+%%DATADIR%%/gfx/explode07.png
+%%DATADIR%%/gfx/explode08.png
+%%DATADIR%%/gfx/explode1.png
+%%DATADIR%%/gfx/explode10.png
+%%DATADIR%%/gfx/explode11.png
+%%DATADIR%%/gfx/explode12.png
+%%DATADIR%%/gfx/explode13.png
+%%DATADIR%%/gfx/explode14.png
+%%DATADIR%%/gfx/explode15.png
+%%DATADIR%%/gfx/explode16.png
+%%DATADIR%%/gfx/explode2.png
+%%DATADIR%%/gfx/explode3.png
+%%DATADIR%%/gfx/explode4.png
+%%DATADIR%%/gfx/explode9.png
+%%DATADIR%%/gfx/eyananth.jpg
+%%DATADIR%%/gfx/face_chris.png
+%%DATADIR%%/gfx/face_crew.png
+%%DATADIR%%/gfx/face_kline.png
+%%DATADIR%%/gfx/face_krass.png
+%%DATADIR%%/gfx/face_phoebe.png
+%%DATADIR%%/gfx/face_sid.png
+%%DATADIR%%/gfx/face_ursula.png
+%%DATADIR%%/gfx/firefly-big.png
+%%DATADIR%%/gfx/firefly1.png
+%%DATADIR%%/gfx/firefly2.png
+%%DATADIR%%/gfx/friendArrowEast.png
+%%DATADIR%%/gfx/friendArrowNorth.png
+%%DATADIR%%/gfx/friendArrowNorthEast.png
+%%DATADIR%%/gfx/friendArrowNorthWest.png
+%%DATADIR%%/gfx/friendArrowSouth.png
+%%DATADIR%%/gfx/friendArrowSouthEast.png
+%%DATADIR%%/gfx/friendArrowSouthWest.png
+%%DATADIR%%/gfx/friendArrowWest.png
+%%DATADIR%%/gfx/frigateBody1.png
+%%DATADIR%%/gfx/frigateBody2.png
+%%DATADIR%%/gfx/frigateGun11.png
+%%DATADIR%%/gfx/frigateGun12.png
+%%DATADIR%%/gfx/frigateGun21.png
+%%DATADIR%%/gfx/frigateGun22.png
+%%DATADIR%%/gfx/gameover.png
+%%DATADIR%%/gfx/goodTrans1.png
+%%DATADIR%%/gfx/goodTrans2.png
+%%DATADIR%%/gfx/greenDir.png
+%%DATADIR%%/gfx/heart.png
+%%DATADIR%%/gfx/icon1.png
+%%DATADIR%%/gfx/icon10.png
+%%DATADIR%%/gfx/icon11.png
+%%DATADIR%%/gfx/icon12.png
+%%DATADIR%%/gfx/icon13.png
+%%DATADIR%%/gfx/icon14.png
+%%DATADIR%%/gfx/icon15.png
+%%DATADIR%%/gfx/icon16.png
+%%DATADIR%%/gfx/icon17.png
+%%DATADIR%%/gfx/icon18.png
+%%DATADIR%%/gfx/icon19.png
+%%DATADIR%%/gfx/icon2.png
+%%DATADIR%%/gfx/icon20.png
+%%DATADIR%%/gfx/icon21.png
+%%DATADIR%%/gfx/icon22.png
+%%DATADIR%%/gfx/icon23.png
+%%DATADIR%%/gfx/icon24.png
+%%DATADIR%%/gfx/icon25.png
+%%DATADIR%%/gfx/icon26.png
+%%DATADIR%%/gfx/icon3.png
+%%DATADIR%%/gfx/icon4.png
+%%DATADIR%%/gfx/icon5.png
+%%DATADIR%%/gfx/icon6.png
+%%DATADIR%%/gfx/icon7.png
+%%DATADIR%%/gfx/icon8.png
+%%DATADIR%%/gfx/icon9.png
+%%DATADIR%%/gfx/iconBase.png
+%%DATADIR%%/gfx/kline11.png
+%%DATADIR%%/gfx/kline12.png
+%%DATADIR%%/gfx/klineText.png
+%%DATADIR%%/gfx/merc1.png
+%%DATADIR%%/gfx/merc2.png
+%%DATADIR%%/gfx/mine.png
+%%DATADIR%%/gfx/mineBoss1.png
+%%DATADIR%%/gfx/mineBoss2.png
+%%DATADIR%%/gfx/mineBossWing11.png
+%%DATADIR%%/gfx/mineBossWing12.png
+%%DATADIR%%/gfx/mineBossWing21.png
+%%DATADIR%%/gfx/mineBossWing22.png
+%%DATADIR%%/gfx/mineBossWing31.png
+%%DATADIR%%/gfx/mineBossWing32.png
+%%DATADIR%%/gfx/mineBossWing41.png
+%%DATADIR%%/gfx/mineBossWing42.png
+%%DATADIR%%/gfx/miner1.png
+%%DATADIR%%/gfx/miner2.png
+%%DATADIR%%/gfx/missileBoat1.png
+%%DATADIR%%/gfx/missileBoat2.png
+%%DATADIR%%/gfx/mobileCannon1.png
+%%DATADIR%%/gfx/mobileCannon2.png
+%%DATADIR%%/gfx/mobileShield1.png
+%%DATADIR%%/gfx/mobileShield2.png
+%%DATADIR%%/gfx/mordor.jpg
+%%DATADIR%%/gfx/ore1.png
+%%DATADIR%%/gfx/ore2.png
+%%DATADIR%%/gfx/ore3.png
+%%DATADIR%%/gfx/phoebeText.png
+%%DATADIR%%/gfx/planet_blue.png
+%%DATADIR%%/gfx/planet_green.png
+%%DATADIR%%/gfx/planet_orange.png
+%%DATADIR%%/gfx/planet_red.png
+%%DATADIR%%/gfx/planet_sun.png
+%%DATADIR%%/gfx/plasmaAmmo.png
+%%DATADIR%%/gfx/plasmaDamage.png
+%%DATADIR%%/gfx/plasmaGreen.png
+%%DATADIR%%/gfx/plasmaRate.png
+%%DATADIR%%/gfx/plasmaRed.png
+%%DATADIR%%/gfx/plutoBoss1.png
+%%DATADIR%%/gfx/plutoBoss2.png
+%%DATADIR%%/gfx/pod.png
+%%DATADIR%%/gfx/prlogo.png
+%%DATADIR%%/gfx/rebelCarrier1.png
+%%DATADIR%%/gfx/rebelCarrier2.png
+%%DATADIR%%/gfx/redDir.png
+%%DATADIR%%/gfx/rocket.png
+%%DATADIR%%/gfx/rocket1.png
+%%DATADIR%%/gfx/rocket2.png
+%%DATADIR%%/gfx/rocketAmmo.png
+%%DATADIR%%/gfx/sellIcon.png
+%%DATADIR%%/gfx/sflogo.png
+%%DATADIR%%/gfx/sid1.png
+%%DATADIR%%/gfx/sid2.png
+%%DATADIR%%/gfx/sidText.png
+%%DATADIR%%/gfx/slaveTrans1.png
+%%DATADIR%%/gfx/slaveTrans2.png
+%%DATADIR%%/gfx/smallFont.png
+%%DATADIR%%/gfx/sol.jpg
+%%DATADIR%%/gfx/spirit.jpg
+%%DATADIR%%/gfx/splitBoss11.png
+%%DATADIR%%/gfx/splitBoss12.png
+%%DATADIR%%/gfx/splitBoss21.png
+%%DATADIR%%/gfx/splitBoss22.png
+%%DATADIR%%/gfx/splitBoss31.png
+%%DATADIR%%/gfx/splitBoss32.png
+%%DATADIR%%/gfx/startUp.jpg
+%%DATADIR%%/gfx/stunBolt.png
+%%DATADIR%%/gfx/superCharge.png
+%%DATADIR%%/gfx/targetText.png
+%%DATADIR%%/gfx/transport1.png
+%%DATADIR%%/gfx/transport2.png
+%%DATADIR%%/gfx/tug1.png
+%%DATADIR%%/gfx/tug2.png
+%%DATADIR%%/gfx/ursulaText.png
+%%DATADIR%%/gfx/wingmate1.png
+%%DATADIR%%/gfx/wingmate2.png
+%%DATADIR%%/music/RE.ogg
+%%DATADIR%%/music/death.ogg
+%%DATADIR%%/music/frozen_jam.ogg
+%%DATADIR%%/music/last_cyber_dance.ogg
+%%DATADIR%%/music/orbital_colossus.ogg
+%%DATADIR%%/music/railjet_short.ogg
+%%DATADIR%%/music/rise_of_spirit.ogg
+%%DATADIR%%/music/sound_and_silence.ogg
+%%DATADIR%%/music/space_dimensions.ogg
+%%DATADIR%%/music/through_space.ogg
+%%DATADIR%%/music/walking_among_androids.ogg
+%%DATADIR%%/sound/beamLaser.ogg
+%%DATADIR%%/sound/cloak.ogg
+%%DATADIR%%/sound/clock.ogg
+%%DATADIR%%/sound/explode.ogg
+%%DATADIR%%/sound/explode2.ogg
+%%DATADIR%%/sound/explode3.ogg
+%%DATADIR%%/sound/explode4.ogg
+%%DATADIR%%/sound/flyby.ogg
+%%DATADIR%%/sound/hyperSpace.ogg
+%%DATADIR%%/sound/item.ogg
+%%DATADIR%%/sound/laser.ogg
+%%DATADIR%%/sound/maledeath.ogg
+%%DATADIR%%/sound/missile.ogg
+%%DATADIR%%/sound/missile2.ogg
+%%DATADIR%%/sound/plasma.ogg
+%%DATADIR%%/sound/plasma2.ogg
+%%DATADIR%%/sound/plasma3.ogg
+%%DATADIR%%/sound/shield.ogg