aboutsummaryrefslogtreecommitdiff
path: root/games/starlanes/files
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2000-04-02 01:00:24 +0000
committerMichael Haro <mharo@FreeBSD.org>2000-04-02 01:00:24 +0000
commit4aed6f1e6536c2d3be11d0ac7596e10b27791cb5 (patch)
tree021f61372fc74d69c6dbb086d15d03b8a2cae67e /games/starlanes/files
parent77140e508e938432f22e37e787489915e2d78661 (diff)
downloadports-4aed6f1e6536c2d3be11d0ac7596e10b27791cb5.tar.gz
ports-4aed6f1e6536c2d3be11d0ac7596e10b27791cb5.zip
Notes
Diffstat (limited to 'games/starlanes/files')
-rw-r--r--games/starlanes/files/patch-ab30
1 files changed, 24 insertions, 6 deletions
diff --git a/games/starlanes/files/patch-ab b/games/starlanes/files/patch-ab
index 57a417f3d47c..c9412b003c60 100644
--- a/games/starlanes/files/patch-ab
+++ b/games/starlanes/files/patch-ab
@@ -1,11 +1,29 @@
---- ./Makefile.org Sat Mar 29 16:36:44 1997
-+++ ./Makefile Tue Jun 10 02:44:54 1997
-@@ -3,7 +3,7 @@
+--- Makefile.orig Sun Mar 30 09:36:44 1997
++++ Makefile Thu Mar 30 01:54:39 2000
+@@ -2,21 +2,17 @@
+ # Makefile for Starlanes
#
- CC=gcc
+-CC=gcc
-CCOPTS=-Wall
-+CCOPTS=-Wall ${CFLAGS}
++CC?=gcc
++CCOPTS=${CFLAGS}
CURSESLIB=ncurses
- INSTALLDIR=/usr/local
+-INSTALLDIR=/usr/local
++INSTALLDIR=${PREFIX}
+ starlanes: starlanes.c
+ $(CC) $(CCOPTS) -o starlanes starlanes.c -l$(CURSESLIB)
+
+ install:
+- cp starlanes $(INSTALLDIR)/games
+- cp starlanes.6 $(INSTALLDIR)/man/man6
+- chown bin:bin $(INSTALLDIR)/games/starlanes
+- chown root:root $(INSTALLDIR)/man/man6/starlanes.6
+- chmod 755 $(INSTALLDIR)/games/starlanes
+- chmod 444 $(INSTALLDIR)/man/man6/starlanes.6
++ ${BSD_INSTALL_PROGRAM} starlanes $(INSTALLDIR)/bin
++ ${BSD_INSTALL_MAN} starlanes.6 $(INSTALLDIR)/man/man6
+
+ # fakeinstall just echos the install commands:
+ fakeinstall: