aboutsummaryrefslogtreecommitdiff
path: root/games/stendhal
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-23 20:30:12 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-23 20:30:12 +0000
commit1b6531fbe3b5ccf6be24f272cb03c891d234ceda (patch)
treec8433c76c98b8853f376bea4b42192797d60d33a /games/stendhal
parentc13db80c72aa2c986197928e6d14392bb21511d6 (diff)
downloadports-1b6531fbe3b5ccf6be24f272cb03c891d234ceda.tar.gz
ports-1b6531fbe3b5ccf6be24f272cb03c891d234ceda.zip
Notes
Diffstat (limited to 'games/stendhal')
-rw-r--r--games/stendhal/Makefile103
-rw-r--r--games/stendhal/distinfo2
-rw-r--r--games/stendhal/files/patch-src_games_stendhal_server_core_engine_GenerateINI.java23
-rw-r--r--games/stendhal/files/stendhal3
-rw-r--r--games/stendhal/files/stendhal-server16
-rw-r--r--games/stendhal/files/stendhal-server.129
-rw-r--r--games/stendhal/files/stendhal.122
-rw-r--r--games/stendhal/files/stendhal.desktop10
-rw-r--r--games/stendhal/pkg-descr7
-rw-r--r--games/stendhal/pkg-plist192
10 files changed, 407 insertions, 0 deletions
diff --git a/games/stendhal/Makefile b/games/stendhal/Makefile
new file mode 100644
index 000000000000..d4a060644152
--- /dev/null
+++ b/games/stendhal/Makefile
@@ -0,0 +1,103 @@
+# Created by: Jordan Irwin <antumdeluge@gmail.com>
+# $FreeBSD$
+
+PORTNAME= stendhal
+PORTVERSION= 1.16
+DISTVERSIONSUFFIX= -src
+CATEGORIES= games java
+MASTER_SITES= SF/arianne/${PORTNAME}/${PORTVERSION}/
+
+MAINTAINER= antumdeluge@gmail.com
+COMMENT= Two-dimensional massively multi-player online RPG
+
+LICENSE= BSD2CLAUSE GPLv2
+LICENSE_COMB= multi
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+USE_ANT= yes
+USES= shebangfix
+
+OPTIONS_MULTI= COMPONENTS
+OPTIONS_MULTI_COMPONENTS= \
+ CLIENT SERVER
+OPTIONS_DEFAULT= CLIENT
+
+CLIENT_DESC= Build game client
+SERVER_DESC= Build game server
+
+OPTIONS_SUB= yes
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION} \
+ JAVAJARDIR=${JAVAJARDIR}
+
+.include <bsd.port.options.mk>
+
+MKDIRS= ${STAGEDIR}${DATADIR} ${STAGEDIR}${DATADIR}/doc/Licenses \
+ ${STAGEDIR}${DATADIR}/lib ${STAGEDIR}${DATADIR}/log
+CLIENTSTARTER= stendhal-starter
+CLIENTICON= data/gui/StendhalIcon
+
+SERVERSCRIPTS= build/build_server_script
+
+.if ${PORT_OPTIONS:MCLIENT}
+MAKE_ARGS+= client_build
+.endif
+
+.if ${PORT_OPTIONS:MSERVER}
+MAKE_ARGS+= server_build
+MKDIRS+= ${STAGEDIR}${DATADIR}/data/conf ${STAGEDIR}${DATADIR}/data/script
+.endif
+
+do-install:
+ # COMMON
+ @${MKDIR} ${MKDIRS}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} doc ${STAGEDIR}${DATADIR} && \
+ ${COPYTREE_SHARE} lib ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/libs/log4j.jar ${STAGEDIR}${DATADIR}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libs/marauroa.jar ${STAGEDIR}${DATADIR}/lib
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DATADIR}
+
+ # CLIENT
+.if ${PORT_OPTIONS:MCLIENT}
+ ${INSTALL_DATA} ${WRKSRC}/libs/jorbis.jar ${STAGEDIR}${DATADIR}/lib
+ ${INSTALL_DATA} ${WRKSRC}/build/lib/${PORTNAME}-${PORTVERSION}.jar \
+ ${STAGEDIR}${DATADIR}/lib/${PORTNAME}.jar
+ ${INSTALL_DATA} ${WRKSRC}/build/lib/${PORTNAME}-data-${PORTVERSION}.jar \
+ ${STAGEDIR}${DATADIR}/lib/${PORTNAME}-data.jar
+ ${INSTALL_DATA} ${WRKSRC}/build/lib/${PORTNAME}-music-data-${PORTVERSION}.jar \
+ ${STAGEDIR}${DATADIR}/lib/${PORTNAME}-music-data.jar
+ ${INSTALL_DATA} ${WRKSRC}/build/lib/${PORTNAME}-sound-data-${PORTVERSION}.jar \
+ ${STAGEDIR}${DATADIR}/lib/${PORTNAME}-sound-data.jar
+ ${INSTALL_DATA} ${WRKSRC}/build/lib/${CLIENTSTARTER}-${PORTVERSION}.jar \
+ ${STAGEDIR}${DATADIR}/${CLIENTSTARTER}.jar
+ ${INSTALL} ${FILESDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/.hotspotrc ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/${CLIENTICON}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_MAN} ${FILESDIR}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1
+.endif
+
+ # SERVER
+.if ${PORT_OPTIONS:MSERVER}
+ ${INSTALL_DATA} ${WRKSRC}/libs/groovy.jar ${STAGEDIR}${DATADIR}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libs/guava.jar ${STAGEDIR}${DATADIR}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libs/h2.jar ${STAGEDIR}${DATADIR}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libs/simple.jar ${STAGEDIR}${DATADIR}/lib
+ ${INSTALL_DATA} ${WRKSRC}/build/lib/${PORTNAME}-maps-${PORTVERSION}.jar \
+ ${STAGEDIR}${DATADIR}/lib/${PORTNAME}-maps.jar
+ ${INSTALL_DATA} ${WRKSRC}/build/lib/${PORTNAME}-server-${PORTVERSION}.jar \
+ ${STAGEDIR}${DATADIR}/lib/${PORTNAME}-server.jar
+ ${INSTALL_DATA} ${WRKSRC}/build/lib/${PORTNAME}-xmlconf-${PORTVERSION}.jar \
+ ${STAGEDIR}${DATADIR}/lib/${PORTNAME}-xmlconf.jar
+ @cd ${WRKSRC}/${SERVERSCRIPTS} && ${COPYTREE_SHARE} games ${STAGEDIR}${DATADIR}/data/script
+ ${INSTALL} ${FILESDIR}/${PORTNAME}-server \
+ ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/data/conf/admins.txt ${STAGEDIR}${DATADIR}/data/conf
+ ${INSTALL_MAN} ${FILESDIR}/${PORTNAME}-server.1 ${STAGEDIR}${PREFIX}/man/man1
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/stendhal/distinfo b/games/stendhal/distinfo
new file mode 100644
index 000000000000..9991251805e3
--- /dev/null
+++ b/games/stendhal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (stendhal-1.16-src.tar.gz) = 1d2702f4074a356926e2c4fe07f4d620192663e469f5c42e366815e4efac1f8a
+SIZE (stendhal-1.16-src.tar.gz) = 67320865
diff --git a/games/stendhal/files/patch-src_games_stendhal_server_core_engine_GenerateINI.java b/games/stendhal/files/patch-src_games_stendhal_server_core_engine_GenerateINI.java
new file mode 100644
index 000000000000..bb5ea50ce11c
--- /dev/null
+++ b/games/stendhal/files/patch-src_games_stendhal_server_core_engine_GenerateINI.java
@@ -0,0 +1,23 @@
+--- src/games/stendhal/server/core/engine/GenerateINI.java.orig 2015-01-08 08:02:23 UTC
++++ src/games/stendhal/server/core/engine/GenerateINI.java
+@@ -29,7 +29,10 @@ import marauroa.common.crypto.RSAKey;
+ * @author hendrik
+ */
+ public class GenerateINI {
+-
++
++ /** Server configuration directory */
++ private static String serverConfigDir = System.getenv("HOME") + "/.config/stendhal";
++
+ /** The name of the output file. */
+ private static String filename = "server.ini";
+
+@@ -218,7 +221,7 @@ public class GenerateINI {
+ }
+
+ private static String getStatisticsFilename() {
+- return "./server_stats.xml";
++ return serverConfigDir + "/server_stats.xml";
+ }
+
+ private static String getTurnLength() {
diff --git a/games/stendhal/files/stendhal b/games/stendhal/files/stendhal
new file mode 100644
index 000000000000..9f63816bb472
--- /dev/null
+++ b/games/stendhal/files/stendhal
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+java $@ -jar /usr/local/share/stendhal/stendhal-starter.jar
diff --git a/games/stendhal/files/stendhal-server b/games/stendhal/files/stendhal-server
new file mode 100644
index 000000000000..06f5b0b704f1
--- /dev/null
+++ b/games/stendhal/files/stendhal-server
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+LOCALCLASSPATH=/usr/local/share/java/classes/*:/usr/local/share/stendhal/*:/usr/local/share/stendhal/lib/*:/usr/local/share/stendhal/data/script/*:/usr/local/share/stendhal/data/conf/*
+
+CONFIGDIR=${HOME}/.config/stendhal
+SERVERLOG=${CONFIGDIR}/log/server.log
+if [ ! -d ${CONFIGDIR}/log ]; then
+ mkdir -p ${CONFIGDIR}/log
+fi
+if [ ! -f ${SERVERLOG} ]; then
+ touch ${SERVERLOG}
+fi
+
+cd ${CONFIGDIR}
+
+java -Dconfig.dir="" $@ -Xmx400m -cp "${LOCALCLASSPATH}" games.stendhal.server.StendhalServer -c "${HOME}/.config/stendhal/server.ini" -l
diff --git a/games/stendhal/files/stendhal-server.1 b/games/stendhal/files/stendhal-server.1
new file mode 100644
index 000000000000..59f91d51300e
--- /dev/null
+++ b/games/stendhal/files/stendhal-server.1
@@ -0,0 +1,29 @@
+.\"Created with GNOME Manpages Editor
+.\"http://sourceforge.net/projects/gmanedit2
+
+.TH STENDHAL-SERVER 1 "" "March 3, 2015" "Stendhal Server Manual"
+
+.SH NAME
+Stendal Server
+
+..SH SYNOPSIS
+.B stendhal-server
+.RI [ vmargs ]
+.br
+
+.SH DESCRIPTION
+Stendhal is a 2-dimenstional multiplayer-online role-playing game. It is set in a fantasy world and incorporates questing, fighting, special events, and more. This is the manual for the game server.
+
+.SH VMARGS
+These are arguments that will be passed to the Java Virtual Machine.
+
+.SS "Seasons:"
+.IP \fB\-Dstendhal.christmas\fP
+Enables Christmas maps.
+.IP \fB\-Dstendhal.easter\fP
+Enables Easter maps.
+.IP \fB\-Dstendhal.minetown\fP
+Enables Minetown Weeks maps.
+
+.SH "SEE ALSO"
+stendhal(1)
diff --git a/games/stendhal/files/stendhal.1 b/games/stendhal/files/stendhal.1
new file mode 100644
index 000000000000..1bd11d288a40
--- /dev/null
+++ b/games/stendhal/files/stendhal.1
@@ -0,0 +1,22 @@
+.\"Created with GNOME Manpages Editor
+.\"http://sourceforge.net/projects/gmanedit2
+
+.\"Replace <program> with the program name, x with the Section Number
+.TH STENDHAL 1 "" "March 3, 2015" "Stendhal Client Manual"
+
+.SH NAME
+Stendal Client
+
+..SH SYNOPSIS
+.B stendhal
+.RI [ vmargs ]
+.br
+
+.SH DESCRIPTION
+Stendhal is a 2-dimenstional multiplayer-online role-playing game. It is set in a fantasy world and incorporates questing, fighting, special events, and more. This is the manual for the game client.
+
+.SH VMARGS
+These are arguments that will be passed to the Java Virtual Machine.
+
+.SH "SEE ALSO"
+stendhal-server(1)
diff --git a/games/stendhal/files/stendhal.desktop b/games/stendhal/files/stendhal.desktop
new file mode 100644
index 000000000000..5879846dc2a6
--- /dev/null
+++ b/games/stendhal/files/stendhal.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Stendhal
+Icon=stendhal
+Exec=stendhal
+Comment=2-demensional MMORPG
+Type=Application
+Terminal=false
+StartupNotify=true
+Categories=Game;
diff --git a/games/stendhal/pkg-descr b/games/stendhal/pkg-descr
new file mode 100644
index 000000000000..7b77cbd26854
--- /dev/null
+++ b/games/stendhal/pkg-descr
@@ -0,0 +1,7 @@
+Stendhal is an open source 2D MMORPG with an excellent community. Players can
+gain experience through battling, quest for special items, explore an expanding
+world or even be a part of the development. There are lots of ways to be
+involved in the project. Stendhal is developed using the Arianne game
+development system.
+
+WWW: https://stendhalgame.org/
diff --git a/games/stendhal/pkg-plist b/games/stendhal/pkg-plist
new file mode 100644
index 000000000000..3d42adb5c236
--- /dev/null
+++ b/games/stendhal/pkg-plist
@@ -0,0 +1,192 @@
+share/stendhal/README.txt
+share/stendhal/doc/AUTHORS.txt
+share/stendhal/doc/BUGS.txt
+share/stendhal/doc/CHANGES.txt
+share/stendhal/doc/LICENSE.txt
+share/stendhal/doc/LICENSE-audio.txt
+share/stendhal/doc/LICENSE-images.txt
+share/stendhal/doc/Licenses/BSD.txt
+share/stendhal/doc/Licenses/CC0-1.0.txt
+share/stendhal/doc/Licenses/CC-BY-3.0.txt
+share/stendhal/doc/Licenses/MIT.txt
+share/stendhal/lib/EasyMockLicense.html
+share/stendhal/lib/license-apache-2.0.txt
+share/stendhal/lib/license-bsd.txt
+share/stendhal/lib/license-cpl.html
+share/stendhal/lib/license-gpl.txt
+share/stendhal/lib/license-h2.html
+share/stendhal/lib/license-lgpl.txt
+share/stendhal/lib/log4j.jar
+share/stendhal/lib/marauroa.jar
+share/stendhal/lib/LICENSES.txt
+share/stendhal/lib/NOTICE.txt
+@dir share/stendhal/log
+
+%%CLIENT%%bin/stendhal
+%%CLIENT%%man/man1/stendhal.1.gz
+%%CLIENT%%share/pixmaps/stendhal.png
+%%CLIENT%%share/applications/stendhal.desktop
+%%CLIENT%%share/stendhal/.hotspotrc
+%%CLIENT%%share/stendhal/stendhal-starter.jar
+%%CLIENT%%share/stendhal/lib/jorbis.jar
+%%CLIENT%%share/stendhal/lib/stendhal-data.jar
+%%CLIENT%%share/stendhal/lib/stendhal-music-data.jar
+%%CLIENT%%share/stendhal/lib/stendhal-sound-data.jar
+%%CLIENT%%share/stendhal/lib/stendhal.jar
+
+%%SERVER%%bin/stendhal-server
+%%SERVER%%man/man1/stendhal-server.1.gz
+%%SERVER%%share/stendhal/data/conf/admins.txt
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/AbstractOfflineAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/AdminMaker$TeleportAction$Destination.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/AdminMaker$TeleportAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/AdminMaker$UpgradeAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/AdminMaker.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/AdminPortal.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/AdminSign.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/AdosWildlifeRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/AlterQuest.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/AngelRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/AnimalRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/BarbarianRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/BeholderRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/BetManager$BetAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/BetManager$BetCondition.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/BetManager$BetInfo.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/BetManager$NoBetCondition.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/BetManager$State.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/BetManager.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/BlordroughRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/BugInspect$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/BugInspect.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ChaosRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ContMoveAndStrengthenOnlinePlayers$ContMoveAndStrengthenPlayersTurnListener.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ContMoveAndStrengthenOnlinePlayers.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/CountObjects.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/CreateRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/CreaturesRatioCalculator$CountCreature.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/CreaturesRatioCalculator.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Debuggera$QuestsAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Debuggera$SightseeingAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Debuggera$TeleportNPCAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Debuggera$TeleportScriptAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Debuggera.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/DeepInspect.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/DisableFeature.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/DragonRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/DropPlayerItems.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/DrowRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/DumpCharacterFromDatabase.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/DumpConditions.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/DumpDeletionCandidates.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/DumpOpenDBTransactions.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/DumpTransitions.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/DumpTransitionsEx.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/DumpTurnListenerEvents.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/DwarfRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/EasterBunny.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/EasyRPAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ElementalRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ElfRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/EnableFeature.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Enchant.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/EntitySearch.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/EventTest.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ExecuteSQL.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/FairyRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/FarmRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/FieldInspect.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/FindBrokenCorpses.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/FishInspect$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/FishInspect.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/FixDM.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/FixNegativeHp.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/FrogmanSheepmanRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/GC.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/GnomeRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/HandleTransitions.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Herald$1$ClearNewsAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Herald$1$ReadJobsAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Herald$1$ReadNewsAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Herald$1$RemoveNewsAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Herald$1$WriteNewsAction.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Herald$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Herald$HeraldListener.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Herald$HeraldNews.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Herald.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ImperialRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ItemRarity$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ItemRarity$CountCreature.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ItemRarity$EntryComparator.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ItemRarity.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/KoboldRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/LichRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ListNPCs.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ListRaids$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ListRaids.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Log4J.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/LogoutPlayer.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Maria$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Maria.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/MineTown.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/MoveAndStrengthenOnlinePlayers$MoveAndStrengthenPlayersTurnListener$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/MoveAndStrengthenOnlinePlayers$MoveAndStrengthenPlayersTurnListener.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/MoveAndStrengthenOnlinePlayers.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/NPCPathCheck$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/NPCPathCheck.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/NPCShout.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/NPCShoutZone.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/NameChange.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Observer.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/OfflineAdminlevel.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/OfflineClearSentence.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/OniRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/OrcRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Plague.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/PlayerPositionMonitoring$PlayerPositionListener$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/PlayerPositionMonitoring$PlayerPositionListener.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/PlayerPositionMonitoring.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ResetSlot.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ResetTutorial.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Santa.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/SaveAllPlayers.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ServerDown$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ServerDown.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ServerReset.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ServerShutdown$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ServerShutdown.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/SetNPCPath.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/SetWelcomeText.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/SokobanReload.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/SokobanWatcher.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/SummonChest.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/SummonSpell.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/TPPNextPhase.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/TPPShowQuestState.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/TeleportAllPlayers.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/TeleportNPC.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/TestShowItemList.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Unblock$KeepFreeArea.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Unblock$PlayerPositionEntry.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/Unblock.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/UnblockTradeTable.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/WhereWho$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/WhereWho.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ZombieRaid.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ZoneCollisionCheck$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ZoneCollisionCheck$2.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ZoneCollisionCheck$Border$1.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ZoneCollisionCheck$Border$2.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ZoneCollisionCheck$Border$3.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ZoneCollisionCheck$Border$4.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ZoneCollisionCheck$Border.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ZoneCollisionCheck.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/ZoneStatistics.class
+%%SERVER%%share/stendhal/data/script/games/stendhal/server/script/package-info.class
+%%SERVER%%share/stendhal/lib/groovy.jar
+%%SERVER%%share/stendhal/lib/guava.jar
+%%SERVER%%share/stendhal/lib/h2.jar
+%%SERVER%%share/stendhal/lib/simple.jar
+%%SERVER%%share/stendhal/lib/stendhal-maps.jar
+%%SERVER%%share/stendhal/lib/stendhal-server.jar
+%%SERVER%%share/stendhal/lib/stendhal-xmlconf.jar