aboutsummaryrefslogtreecommitdiff
path: root/games/stockfish
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-16 17:37:14 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-16 17:37:14 +0000
commit9060754677d9a1e46b0a498a81c31dfe9672e205 (patch)
treee776449d72b55fb4eb5dd6f9670f19474bf19e8c /games/stockfish
parentda27f0125af6dfcd1ebcdd31f29d0223e6d47ff7 (diff)
downloadports-9060754677d9a1e46b0a498a81c31dfe9672e205.tar.gz
ports-9060754677d9a1e46b0a498a81c31dfe9672e205.zip
Notes
Diffstat (limited to 'games/stockfish')
-rw-r--r--games/stockfish/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/games/stockfish/Makefile b/games/stockfish/Makefile
index ed99a8e9d50c..780c520f043b 100644
--- a/games/stockfish/Makefile
+++ b/games/stockfish/Makefile
@@ -19,7 +19,7 @@ LICENSE= GPLv3
USE_ZIP= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-USE_GMAKE= yes
+USES= gmake
MYARCH= ${ARCH}
BOOKDIR= .
PORTDOCS= Readme.txt polyglot.ini
@@ -69,6 +69,13 @@ ALL_TARGET= ${TGTBLD} ARCH=${MYARCH} COMP=${MYCC}
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
+.if exists(/usr/bin/clang) && ${OSVERSION} > 1000024
+MYCC= clang
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s/^PREFIX =/PREFIX ?=/" ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/stockfish ${PREFIX}/bin/stockfish