aboutsummaryrefslogtreecommitdiff
path: root/games/stonesoup
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-10-17 11:53:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-10-17 11:53:59 +0000
commit5208ddb58887828a18aa69d04404e3870c15fd4c (patch)
tree2ff2ea84a5fb1f6d101cdd8c0cb8e21f67dd1dc6 /games/stonesoup
parent4c5a4b5de15a5017c686db0f9b43210d78a134e5 (diff)
downloadports-5208ddb58887828a18aa69d04404e3870c15fd4c.tar.gz
ports-5208ddb58887828a18aa69d04404e3870c15fd4c.zip
Notes
Diffstat (limited to 'games/stonesoup')
-rw-r--r--games/stonesoup/Makefile7
-rw-r--r--games/stonesoup/distinfo6
-rw-r--r--games/stonesoup/files/patch-AppHdr.h15
-rw-r--r--games/stonesoup/files/patch-initfile.cc17
-rw-r--r--games/stonesoup/files/patch-makefile.unix74
-rw-r--r--games/stonesoup/files/patch-makefile_tiles.unix76
-rw-r--r--games/stonesoup/files/patch-tilesdl.cc11
-rw-r--r--games/stonesoup/files/patch-util__lua__src__Makefile12
-rw-r--r--games/stonesoup/files/patch-util__sqlite__Makefile10
-rw-r--r--games/stonesoup/pkg-plist2
10 files changed, 141 insertions, 89 deletions
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index 6ef942239c1f..69dc7b9bd83e 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= stonesoup
-PORTVERSION= 0.5.1
+PORTVERSION= 0.5.2
CATEGORIES= games
MASTER_SITES= SF/crawl-ref/Stone%20Soup/${PORTVERSION}
DISTNAME= stone_soup-${PORTVERSION}-src
@@ -24,13 +24,15 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/source/
SUB_FILES= README.FreeBSD
PLIST_SUB= SAVEDIR="${SAVEDIR}"
-FETCH_ARGS?= -pRr
+FETCH_ARGS?= -pRr
OPTIONS= SDL "SDL support (tiles interface)" off \
SOUND "Sound support" off \
LUA_BINDINGS "LUA bindings for user scripts" on \
UNICODE "Unicode glyphs (UTF-8)" off
+MAKE_ARGS= "FREEBSD=yes"
+
.include <bsd.port.options.mk>
.if defined(WITH_SDL)
@@ -54,6 +56,7 @@ post-patch:
@${REINPLACE_CMD} -e "s,%%DATADIR%%,${DATADIR}/," ${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e "s,%%SAVEDIR%%,${SAVEDIR}," ${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE}," ${WRKSRC}/${MAKEFILE}
.if defined(WITHOUT_LUA_BINDINGS)
@${REINPLACE_CMD} -e "s,-DCLUA_BINDINGS,," ${WRKSRC}/${MAKEFILE}
.endif
diff --git a/games/stonesoup/distinfo b/games/stonesoup/distinfo
index 0a4e0d2e4c97..d972c245785f 100644
--- a/games/stonesoup/distinfo
+++ b/games/stonesoup/distinfo
@@ -1,3 +1,3 @@
-MD5 (stone_soup-0.5.1-src.tbz2) = e1feb17d161311825e5eb676c14be44a
-SHA256 (stone_soup-0.5.1-src.tbz2) = 156b8766ca39f7446d0a0846c178e3c178050eaf1627fbb9f828f659d13f853e
-SIZE (stone_soup-0.5.1-src.tbz2) = 4758603
+MD5 (stone_soup-0.5.2-src.tbz2) = 48aca99f320b70c880363ddaca7da89a
+SHA256 (stone_soup-0.5.2-src.tbz2) = e943892da5da28cff9dc4117480d6fe48d25c03cb600696426ca9178aa2ae7c8
+SIZE (stone_soup-0.5.2-src.tbz2) = 4683454
diff --git a/games/stonesoup/files/patch-AppHdr.h b/games/stonesoup/files/patch-AppHdr.h
index 271c7e74f731..df955d12b13e 100644
--- a/games/stonesoup/files/patch-AppHdr.h
+++ b/games/stonesoup/files/patch-AppHdr.h
@@ -1,6 +1,6 @@
---- ./AppHdr.h.orig 2009-07-29 01:31:27.000000000 +0200
-+++ ./AppHdr.h 2009-08-03 10:10:09.000000000 +0200
-@@ -126,7 +126,7 @@
+--- ./AppHdr.h.orig 2009-10-06 20:44:04.000000000 +0200
++++ ./AppHdr.h 2009-10-15 18:40:29.000000000 +0200
+@@ -151,7 +151,7 @@
// setuid or setgid. Filenames passed to this command *are not
// validated in any way*.
//
@@ -9,12 +9,3 @@
// For cases when the game will be played on terms that don't support the
// curses "bold == lighter" 16 colour mode. -- bwr
-@@ -413,6 +413,8 @@
- // The default behaviour is to compress with zip.
- // To use GNU tar instead, define SAVE_PACKAGE_TAR.
- // To avoid compression entirely, define SAVE_PACKAGE_NONE.
-+ #define SAVE_PACKAGE_NONE
-+
- #ifndef SAVE_PACKAGE_NONE
- #ifdef SAVE_PACKAGE_TAR
- // The --absolute-names switch is only there to suppress noise on stdout.
diff --git a/games/stonesoup/files/patch-initfile.cc b/games/stonesoup/files/patch-initfile.cc
deleted file mode 100644
index de6229f550bc..000000000000
--- a/games/stonesoup/files/patch-initfile.cc
+++ /dev/null
@@ -1,17 +0,0 @@
---- ./initfile.cc.orig 2009-06-12 12:32:16.000000000 +0200
-+++ ./initfile.cc 2009-06-19 13:54:51.000000000 +0200
-@@ -2333,12 +2333,12 @@
- #ifndef USE_TILE
- else BOOL_OPTION(show_beam);
- #endif
--#ifndef SAVE_DIR_PATH
-+// #ifndef SAVE_DIR_PATH
- else if (key == "morgue_dir")
- {
- morgue_dir = field;
- }
--#endif
-+// #endif
- else if (key == "hp_warning")
- {
- hp_warning = atoi( field.c_str() );
diff --git a/games/stonesoup/files/patch-makefile.unix b/games/stonesoup/files/patch-makefile.unix
index d9e885d19729..68b414dbb33e 100644
--- a/games/stonesoup/files/patch-makefile.unix
+++ b/games/stonesoup/files/patch-makefile.unix
@@ -1,7 +1,7 @@
---- ./makefile.unix.orig 2009-06-12 12:39:29.000000000 +0200
-+++ ./makefile.unix 2009-06-19 13:54:52.000000000 +0200
+--- ./makefile.unix.orig 2009-10-06 20:44:04.000000000 +0200
++++ ./makefile.unix 2009-10-15 18:40:29.000000000 +0200
@@ -4,7 +4,7 @@
- # Modified for Crawl Reference by $Author: ennewalker $ on $Date: 2009-02-14 17:59:13 +0100 (Sa, 14 Feb 2009) $
+ # Modified for Crawl Reference by $Author$ on $Date$
#
-GAME = crawl
@@ -9,15 +9,17 @@
# this file contains a list of the libraries.
# it will make a variable called OBJECTS that contains all the libraries
-@@ -12,7 +12,6 @@
+@@ -12,7 +12,9 @@
OBJECTS += libunix.o crash-u.o
--CXX = g++
++ifndef FREEBSD
+ CXX = g++
++endif
DELETE = rm -f
COPY = cp
OS_TYPE = UNIX
-@@ -21,7 +20,7 @@
+@@ -21,7 +23,7 @@
# Change this to y (case-sensitive!) if you want to use Unicode glyphs
# in the map, and you have libncursesw available.
@@ -26,14 +28,14 @@
# If you're using UNICODE_GLYPHS=y, and have a preferred Unicode
# (UTF-8) locale you want Crawl to use, you can set it here. The
-@@ -39,16 +38,15 @@
+@@ -39,16 +41,16 @@
MCHMOD_SAVEDIR := 775
# The user:group to install the game as.
-INSTALL_UGRP := games:games
--
--INSTALLDIR := /usr/games/crawl
+INSTALL_UGRP := root:games
+
+-INSTALLDIR := /usr/games/crawl
+INSTALLDIR := %%PREFIX%%/bin
# If you're installing Crawl for multiple users, you *must* set this to a
@@ -47,25 +49,28 @@
LEX := flex
YACC := bison -y
-@@ -70,17 +68,8 @@
+@@ -70,16 +72,20 @@
INCLUDES := $(INCLUDES) -Iutil -I. -I$(LUASRC) $(EXTRA_INCLUDES)
--CFWARN := -Wall -Wno-parentheses -Wwrite-strings -Wshadow -pedantic
--
++ifndef FREEBSD
+ CFWARN := -Wall -Wno-parentheses -Wwrite-strings -Wshadow -pedantic
++endif
+
CFOTHERS := -fsigned-char -D$(OS_TYPE) $(EXTRA_FLAGS) -DCLUA_BINDINGS
--ifneq ($(HURRY),y)
--ifneq ($(DEBUG_CRAWL),y)
--CFWARN += -Wuninitialized
--CFOTHERS += -O2
--endif
--endif
--
++ifndef FREEBSD
+ ifneq ($(HURRY),y)
+ ifneq ($(DEBUG_CRAWL),y)
+ CFWARN += -Wuninitialized
+ CFOTHERS += -O2
+ endif
+ endif
++endif
+
ifneq ($(strip $(SAVEDIR)),)
CFOTHERS += '-DSAVE_DIR_PATH="$(strip $(SAVEDIR))"'
- endif
-@@ -117,8 +106,8 @@
+@@ -117,8 +123,8 @@
LIBCURS = ncurses
endif
@@ -76,7 +81,7 @@
UTIL = util/
-@@ -160,7 +149,7 @@
+@@ -160,7 +166,7 @@
rm -f $(DEPENDENCY_MKF).tmp
@for i in $^; do \
echo "Updating dependencies for $$i"; \
@@ -85,7 +90,7 @@
done
mv -f $(DEPENDENCY_MKF).tmp $(DEPENDENCY_MKF)
-@@ -257,17 +246,17 @@
+@@ -257,17 +263,17 @@
$(DELETE) $(DEPENDENCY_MKF)
$(GAME): $(GAME_DEPENDS)
@@ -106,3 +111,26 @@
# [ds] Note we don't use the standard CFLAGS here; that's intentional, most
# flex/bison combos I've tried don't produce code that passes the warnings
+@@ -280,14 +286,22 @@
+
+ $(LUASRC)$(LUALIBA):
+ echo Building Lua...
++ifdef FREEBSD
++ cd $(LUASRC) && $(MAKE) FREEBSD=yes crawl_unix
++else
+ cd $(LUASRC) && $(MAKE) crawl_unix
++endif
+
+ #############################################################################
+ # Build SQLite
+
+ $(FSQLLIBA):
+ echo Building SQLite
++ifdef FREEBSD
++ cd $(SQLSRC) && $(MAKE) FREEBSD=yes
++else
+ cd $(SQLSRC) && $(MAKE)
++endif
+
+ #############################################################################
+ # Packaging a source tarball for release
diff --git a/games/stonesoup/files/patch-makefile_tiles.unix b/games/stonesoup/files/patch-makefile_tiles.unix
index b76ec21d78eb..fc1ebee71c70 100644
--- a/games/stonesoup/files/patch-makefile_tiles.unix
+++ b/games/stonesoup/files/patch-makefile_tiles.unix
@@ -1,5 +1,5 @@
---- ./makefile_tiles.unix.orig 2009-06-12 12:32:15.000000000 +0200
-+++ ./makefile_tiles.unix 2009-06-19 13:54:52.000000000 +0200
+--- ./makefile_tiles.unix.orig 2009-10-06 20:44:04.000000000 +0200
++++ ./makefile_tiles.unix 2009-10-15 18:40:29.000000000 +0200
@@ -4,7 +4,7 @@
# Modified for Crawl Reference by $Author: dshaligram $ on $Date: 2007-06-24T16:27:58.475101Z $
#
@@ -9,15 +9,17 @@
# this file contains a list of the libraries.
# it will make a variable called OBJECTS that contains all the libraries
-@@ -15,7 +15,6 @@
+@@ -15,7 +15,9 @@
SDL_CFLAGS := $(shell sdl-config --cflags)
SDL_LDFLAGS := $(shell sdl-config --libs) -lSDLmain
--CXX = g++
++ifndef FREEBSD
+ CXX = g++
++endif
DELETE = rm -f
COPY = cp
OS_TYPE = UNIX
-@@ -25,7 +24,7 @@
+@@ -25,7 +27,7 @@
# Change this to y if you want to use Unicode glyphs in the map, and you have
# libncursesw available.
@@ -26,16 +28,16 @@
ifeq ($(strip $(OSX)),y)
PNG_INCLUDE := -I/sw/include
-@@ -41,7 +40,7 @@
+@@ -41,7 +43,7 @@
else
PNG_INCLUDE :=
PNG_LIB :=
-FREETYPE_INCLUDE := -I/usr/include/freetype2
-+FREETYPE_INCLUDE := -I/usr/local/include/freetype2
++FREETYPE_INCLUDE := -I%%LOCALBASE%%/include/freetype2
endif
# If you have lex and yacc, set DOYACC to y (lowercase y).
-@@ -54,16 +53,16 @@
+@@ -54,16 +56,16 @@
MCHMOD_SAVEDIR := 775
# The user:group to install the game as.
@@ -56,25 +58,30 @@
LEX := flex
YACC := bison -y
-@@ -105,17 +104,8 @@
+@@ -105,10 +107,13 @@
INCLUDES := $(INCLUDES) -Iutil -I. -I$(LUASRC) $(EXTRA_INCLUDES) $(PNG_INCLUDE) $(FREETYPE_INCLUDE)
--CFWARN := -Wall -Wwrite-strings -Wshadow -pedantic -Wno-parentheses
--
++ifndef FREEBSD
+ CFWARN := -Wall -Wwrite-strings -Wshadow -pedantic -Wno-parentheses
++endif
+
CFOTHERS := -fsigned-char -D$(OS_TYPE) $(EXTRA_FLAGS) -DCLUA_BINDINGS
--ifneq ($(HURRY),y)
--ifneq ($(DEBUG_CRAWL),y)
--CFWARN += -Wuninitialized
--CFOTHERS += -O2
--endif
--endif
--
++ifndef FREEBSD
+ ifneq ($(HURRY),y)
+ ifneq ($(DEBUG_CRAWL),y)
+ CFWARN += -Wuninitialized
+@@ -116,6 +121,8 @@
+ endif
+ endif
+
++endif
++
ifneq ($(strip $(SAVEDIR)),)
CFOTHERS += '-DSAVE_DIR_PATH="$(strip $(SAVEDIR))"'
endif
-@@ -124,8 +114,8 @@
+@@ -124,8 +131,8 @@
CFOTHERS += '-DDATA_DIR_PATH="$(strip $(DATADIR))"'
endif
@@ -85,7 +92,7 @@
UTIL = util/
-@@ -167,7 +157,7 @@
+@@ -167,7 +174,7 @@
rm -f $(DEPENDENCY_MKF).tmp
@for i in $^; do \
echo "Updating dependencies for $$i"; \
@@ -94,7 +101,7 @@
done
mv -f $(DEPENDENCY_MKF).tmp $(DEPENDENCY_MKF)
-@@ -210,7 +200,7 @@
+@@ -210,7 +217,7 @@
ORIGTILEFILES = $(TILEFILES:%=$(RLTILES)/%)
makerltiles:
@@ -103,7 +110,7 @@
$(TILEDEFSRCS): makerltiles
-@@ -222,7 +212,7 @@
+@@ -222,7 +229,7 @@
$(COPY) $< $@
clean-rltiles:
@@ -112,7 +119,7 @@
##########################################################################
-@@ -287,21 +277,21 @@
+@@ -287,21 +294,21 @@
$(DELETE) $(DEPENDENCY_MKF)
$(GAME): $(GAME_DEPENDS)
@@ -138,3 +145,26 @@
# [ds] Note we don't use the standard CFLAGS here; that's intentional, most
# flex/bison combos I've tried don't produce code that passes the warnings
+@@ -314,14 +321,22 @@
+
+ $(LUASRC)$(LUALIBA):
+ echo Building Lua...
++ifdef FREEBSD
++ cd $(LUASRC) && $(MAKE) FREEBSD=yes crawl_unix
++else
+ cd $(LUASRC) && $(MAKE) crawl_unix
++endif
+
+ #############################################################################
+ # Build SQLite
+
+ $(FSQLLIBA):
+ echo Building SQLite
++ifdef FREEBSD
++ cd $(SQLSRC) && $(MAKE) FREEBSD=yes
++else
+ cd $(SQLSRC) && $(MAKE)
++endif
+
+ #############################################################################
+ # Packaging a source tarball for release
diff --git a/games/stonesoup/files/patch-tilesdl.cc b/games/stonesoup/files/patch-tilesdl.cc
new file mode 100644
index 000000000000..6eaa00d9eb44
--- /dev/null
+++ b/games/stonesoup/files/patch-tilesdl.cc
@@ -0,0 +1,11 @@
+--- ./tilesdl.cc.orig 2009-10-15 18:41:56.000000000 +0200
++++ ./tilesdl.cc 2009-10-15 18:42:16.000000000 +0200
+@@ -249,7 +249,7 @@
+ "dat/tiles/stone_soup_icon-32x32.png";
+ #endif
+
+- SDL_Surface *icon = IMG_Load(datafile_path(icon_name).c_str());
++ SDL_Surface *icon = IMG_Load(datafile_path(icon_name, true, true).c_str());
+ if (!icon)
+ {
+ printf("Failed to load icon: %s\n", SDL_GetError());
diff --git a/games/stonesoup/files/patch-util__lua__src__Makefile b/games/stonesoup/files/patch-util__lua__src__Makefile
index 0a0ae5723651..79e645628118 100644
--- a/games/stonesoup/files/patch-util__lua__src__Makefile
+++ b/games/stonesoup/files/patch-util__lua__src__Makefile
@@ -1,11 +1,13 @@
---- ./util/lua/src/Makefile.orig 2009-06-12 12:24:43.000000000 +0200
-+++ ./util/lua/src/Makefile 2009-06-19 13:54:52.000000000 +0200
-@@ -9,8 +9,6 @@
+--- ./util/lua/src/Makefile.orig 2009-10-06 20:44:04.000000000 +0200
++++ ./util/lua/src/Makefile 2009-10-15 18:40:29.000000000 +0200
+@@ -9,8 +9,10 @@
# Your platform. See PLATS for possible values.
PLAT= none
--CC= gcc
--CFLAGS= -O2 -Wall $(MYCFLAGS)
++ifndef FREEBSD
+ CC= gcc
+ CFLAGS= -O2 -Wall $(MYCFLAGS)
++endif
AR= ar rcu
RANLIB= ranlib
RM= rm -f
diff --git a/games/stonesoup/files/patch-util__sqlite__Makefile b/games/stonesoup/files/patch-util__sqlite__Makefile
index b4fe77842137..9da867ee71de 100644
--- a/games/stonesoup/files/patch-util__sqlite__Makefile
+++ b/games/stonesoup/files/patch-util__sqlite__Makefile
@@ -1,10 +1,12 @@
---- ./util/sqlite/Makefile.orig 2009-06-12 12:27:11.000000000 +0200
-+++ ./util/sqlite/Makefile 2009-06-19 13:54:52.000000000 +0200
-@@ -4,12 +4,11 @@
+--- ./util/sqlite/Makefile.orig 2009-10-06 20:44:04.000000000 +0200
++++ ./util/sqlite/Makefile 2009-10-15 18:40:29.000000000 +0200
+@@ -4,12 +4,14 @@
LIBSQL = libsqlite3.a
AR = ar rcu
--CC = gcc
++ifndef FREEBSD
+ CC = gcc
++endif
RANLIB = ranlib
RM_F = rm -f
diff --git a/games/stonesoup/pkg-plist b/games/stonesoup/pkg-plist
index 47102dc4d975..6bf4efc5b579 100644
--- a/games/stonesoup/pkg-plist
+++ b/games/stonesoup/pkg-plist
@@ -115,6 +115,8 @@ bin/stonesoup
%%DATADIR%%/docs/changelog.txt
%%DATADIR%%/docs/aptitudes.txt
%%DATADIR%%/docs/tiles_help.txt
+%%DATADIR%%/docs/libpng-LICENSE.txt
+%%DATADIR%%/docs/tiles_creation.txt
@exec chown -R root:games %D/%%DATADIR%%
@exec install -d -o root -g games -m 775 %%SAVEDIR%%
%%PORTDOCS%%%%DOCSDIR%%/CREDITS.txt