aboutsummaryrefslogtreecommitdiff
path: root/games/stormbaancoureur/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-26 23:30:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-26 23:30:57 +0000
commit1d2f26a2a1575b44db3059120d300565dd515a0d (patch)
treec3522236e1e74cf72bfac9bf3b63b667c69dc35f /games/stormbaancoureur/Makefile
parent603eca81c126ebef8daeafcf0551b8b3d6f872be (diff)
downloadports-1d2f26a2a1575b44db3059120d300565dd515a0d.tar.gz
ports-1d2f26a2a1575b44db3059120d300565dd515a0d.zip
Notes
Diffstat (limited to 'games/stormbaancoureur/Makefile')
-rw-r--r--games/stormbaancoureur/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/games/stormbaancoureur/Makefile b/games/stormbaancoureur/Makefile
index be2b6732f1b6..aace18d99d02 100644
--- a/games/stormbaancoureur/Makefile
+++ b/games/stormbaancoureur/Makefile
@@ -5,10 +5,10 @@
# $FreeBSD$
#
-PORTNAME= sturmbahnfahrer
-PORTVERSION= 1.4
+PORTNAME= stormbaancoureur
+PORTVERSION= 2.0.0
CATEGORIES= games
-MASTER_SITES= http://www.stolk.org/sturmbahnfahrer/download/ \
+MASTER_SITES= http://bram.creative4vision.nl/sturmbahnfahrer/download/ \
http://www.amdmi3.ru/distfiles/
MAINTAINER= amdmi3@amdmi3.ru
@@ -22,22 +22,22 @@ USE_GL= yes
MAKE_ENV= DATADIR="${DATADIR}"
-BUILD_WRKSRC= ${WRKSRC}/src-sturmbahnfahrer
-INSTALL_WRKSRC= ${WRKSRC}/src-sturmbahnfahrer
+BUILD_WRKSRC= ${WRKSRC}/src-stormbaancoureur
+INSTALL_WRKSRC= ${WRKSRC}/src-stormbaancoureur
PORTDOCS= README
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/share/games/sturmbahnfahrer|${DATADIR}|' \
- ${WRKSRC}/src-sturmbahnfahrer/main.cxx
+ @${REINPLACE_CMD} -e 's|__DATADIR|"${DATADIR}"|' \
+ ${WRKSRC}/src-stormbaancoureur/main.cxx
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif