aboutsummaryrefslogtreecommitdiff
path: root/games/stormbaancoureur
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-26 23:30:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-26 23:30:57 +0000
commit1d2f26a2a1575b44db3059120d300565dd515a0d (patch)
treec3522236e1e74cf72bfac9bf3b63b667c69dc35f /games/stormbaancoureur
parent603eca81c126ebef8daeafcf0551b8b3d6f872be (diff)
downloadports-1d2f26a2a1575b44db3059120d300565dd515a0d.tar.gz
ports-1d2f26a2a1575b44db3059120d300565dd515a0d.zip
Notes
Diffstat (limited to 'games/stormbaancoureur')
-rw-r--r--games/stormbaancoureur/Makefile16
-rw-r--r--games/stormbaancoureur/distinfo6
-rw-r--r--games/stormbaancoureur/files/patch-src-stormbaancoureur-Makefile (renamed from games/stormbaancoureur/files/patch-src-sturmbahnfahrer-Makefile)101
-rw-r--r--games/stormbaancoureur/files/patch-src-stormbaancoureur-controllerpad.cxx (renamed from games/stormbaancoureur/files/patch-src-sturmbahnfahrer-controllerpad.cxx)4
-rw-r--r--games/stormbaancoureur/files/patch-src-stormbaancoureur-main.cxx (renamed from games/stormbaancoureur/files/patch-src-sturmbahnfahrer-main.cxx)11
-rw-r--r--games/stormbaancoureur/pkg-descr9
-rw-r--r--games/stormbaancoureur/pkg-plist23
7 files changed, 114 insertions, 56 deletions
diff --git a/games/stormbaancoureur/Makefile b/games/stormbaancoureur/Makefile
index be2b6732f1b6..aace18d99d02 100644
--- a/games/stormbaancoureur/Makefile
+++ b/games/stormbaancoureur/Makefile
@@ -5,10 +5,10 @@
# $FreeBSD$
#
-PORTNAME= sturmbahnfahrer
-PORTVERSION= 1.4
+PORTNAME= stormbaancoureur
+PORTVERSION= 2.0.0
CATEGORIES= games
-MASTER_SITES= http://www.stolk.org/sturmbahnfahrer/download/ \
+MASTER_SITES= http://bram.creative4vision.nl/sturmbahnfahrer/download/ \
http://www.amdmi3.ru/distfiles/
MAINTAINER= amdmi3@amdmi3.ru
@@ -22,22 +22,22 @@ USE_GL= yes
MAKE_ENV= DATADIR="${DATADIR}"
-BUILD_WRKSRC= ${WRKSRC}/src-sturmbahnfahrer
-INSTALL_WRKSRC= ${WRKSRC}/src-sturmbahnfahrer
+BUILD_WRKSRC= ${WRKSRC}/src-stormbaancoureur
+INSTALL_WRKSRC= ${WRKSRC}/src-stormbaancoureur
PORTDOCS= README
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/share/games/sturmbahnfahrer|${DATADIR}|' \
- ${WRKSRC}/src-sturmbahnfahrer/main.cxx
+ @${REINPLACE_CMD} -e 's|__DATADIR|"${DATADIR}"|' \
+ ${WRKSRC}/src-stormbaancoureur/main.cxx
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
diff --git a/games/stormbaancoureur/distinfo b/games/stormbaancoureur/distinfo
index 614e65a819b9..00ea934d9005 100644
--- a/games/stormbaancoureur/distinfo
+++ b/games/stormbaancoureur/distinfo
@@ -1,3 +1,3 @@
-MD5 (sturmbahnfahrer-1.4.tar.gz) = a861fffe67c90aa5a0cd114e8e786541
-SHA256 (sturmbahnfahrer-1.4.tar.gz) = 4e324dc080c7c0b302aaf64a9f30640560d08ac73a869bb86a272acee79fe85a
-SIZE (sturmbahnfahrer-1.4.tar.gz) = 3090504
+MD5 (stormbaancoureur-2.0.0.tar.gz) = 2d20b536c7616c74376b277132bd09c9
+SHA256 (stormbaancoureur-2.0.0.tar.gz) = f725eec8b3c8865e1cd3c91b751566d7576f2ae529906cb2af63f5a04fe7baa8
+SIZE (stormbaancoureur-2.0.0.tar.gz) = 4022711
diff --git a/games/stormbaancoureur/files/patch-src-sturmbahnfahrer-Makefile b/games/stormbaancoureur/files/patch-src-stormbaancoureur-Makefile
index 8d53dfcee8f9..5c757842faf2 100644
--- a/games/stormbaancoureur/files/patch-src-sturmbahnfahrer-Makefile
+++ b/games/stormbaancoureur/files/patch-src-stormbaancoureur-Makefile
@@ -1,64 +1,82 @@
---- src-sturmbahnfahrer/Makefile.orig Thu May 17 20:02:03 2007
-+++ src-sturmbahnfahrer/Makefile Thu Aug 9 02:28:39 2007
-@@ -6,19 +6,17 @@
-
- PLIBPREFIX=$(HOME)
- ODEPREFIX=$(HOME)
+--- src-stormbaancoureur/Makefile.orig 2007-12-29 00:55:42.000000000 +0300
++++ src-stormbaancoureur/Makefile 2007-12-31 16:51:58.000000000 +0300
+@@ -5,7 +5,7 @@
+ GLPREFIX=/usr
+ PLIBPREFIX=/usr
+ ODEPREFIX=/usr
-CXX=g++
+CXX?=g++
+ LIBDIRNAME=lib
+
+ #PLIBPREFIX=$(HOME)
+@@ -14,17 +14,14 @@
# END OF CUSTOM SETTINGS
- CXXFLAGS=\
+-CXXFLAGS=\
+- -I$(GLPREFIX)/include \
- -I$(ODEPREFIX)/include \
- -I$(PLIBPREFIX)/include \
++CXXFLAGS+=\
+ -I$(LOCALBASE)/include \
-I../src-common \
+ -DGAMEVERSION=$(VERSION) \
- -O2 -g -Wall
+ -g -Wall
LFLAGS=\
-- -L$(PLIBPREFIX)/lib \
-- -L/usr/X11R6/lib
+- -L$(PLIBPREFIX)/$(LIBDIRNAME) \
+- -L/usr/X11R6/$(LIBDIRNAME)
+ -L$(LOCALBASE)/lib
OBJS=\
-@@ -37,9 +35,9 @@
+@@ -43,15 +40,15 @@
LIBS=\
-- $(ODEPREFIX)/lib/libode.a \
+- $(ODEPREFIX)/$(LIBDIRNAME)/libode.a \
+ $(LOCALBASE)/lib/libode.a \
-lplibssgaux -lplibssg -lplibsg -lplibpu -lplibfnt -lplibul \
- -lglut -lGLU -lGL -lasound
+ -lglut -lGLU -lGL
- all: sturmbahnfahrer
-@@ -94,44 +92,43 @@
- GAMEDIR=$(DESTDIR)/usr/share/games/sturmbahnfahrer
- install: sturmbahnfahrer
+ all: stormbaancoureur
+
+
+-stormbaancoureur: $(OBJS) $(ODEPREFIX)/$(LIBDIRNAME)/libode.a
++stormbaancoureur: $(OBJS)
+ $(CXX) -o stormbaancoureur $(OBJS) $(LFLAGS) $(LIBS)
+
+ staticworldobject.o: ../src-common/staticworldobject.cxx ../src-common/staticworldobject.h ../src-common/worldobject.h
+@@ -102,62 +99,61 @@
+ GAMEDIR=$(DESTDIR)/usr/share/games/stormbaancoureur
+ install: stormbaancoureur
# Directories
- mkdir -p $(DESTDIR)/usr/games/
- mkdir -p $(GAMEDIR)/images/
- mkdir -p $(GAMEDIR)/sounds/
+- mkdir -p $(GAMEDIR)/shaders/
- mkdir -p $(GAMEDIR)/models/
+ mkdir -p $(DATADIR)/images/
+ mkdir -p $(DATADIR)/sounds/
++ mkdir -p $(DATADIR)/shaders/
+ mkdir -p $(DATADIR)/models/
# Binary
-- install sturmbahnfahrer $(DESTDIR)/usr/games/sturmbahnfahrer
-+ ${BSD_INSTALL_PROGRAM} sturmbahnfahrer $(PREFIX)/bin/sturmbahnfahrer
+- install stormbaancoureur $(DESTDIR)/usr/games/stormbaancoureur
++ ${BSD_INSTALL_PROGRAM} stormbaancoureur $(PREFIX)/bin/stormbaancoureur
# Images
- install -m 644 images/engine.tga $(GAMEDIR)/images/engine.tga
- install -m 644 images/info_carpet_smooth.rgb $(GAMEDIR)/images/info_carpet_smooth.rgb
- install -m 644 images/info_door_smooth.rgb $(GAMEDIR)/images/info_door_smooth.rgb
- install -m 644 images/info_jump_smooth.rgb $(GAMEDIR)/images/info_jump_smooth.rgb
+- install -m 644 images/spot.tga $(GAMEDIR)/images/spot.tga
+ ${BSD_INSTALL_DATA} -m 644 images/engine.tga $(DATADIR)/images/engine.tga
+ ${BSD_INSTALL_DATA} -m 644 images/info_carpet_smooth.rgb $(DATADIR)/images/info_carpet_smooth.rgb
+ ${BSD_INSTALL_DATA} -m 644 images/info_door_smooth.rgb $(DATADIR)/images/info_door_smooth.rgb
+ ${BSD_INSTALL_DATA} -m 644 images/info_jump_smooth.rgb $(DATADIR)/images/info_jump_smooth.rgb
++ ${BSD_INSTALL_DATA} -m 644 images/spot.tga $(DATADIR)/images/spot.tga
# Sounds
- install -m 644 sounds/rpm_graph.txt $(GAMEDIR)/sounds/rpm_graph.txt
- install -m 644 sounds/camaro_s16_le.wav $(GAMEDIR)/sounds/camaro_s16_le.wav
@@ -66,9 +84,33 @@
+ ${BSD_INSTALL_DATA} -m 644 sounds/rpm_graph.txt $(DATADIR)/sounds/rpm_graph.txt
+ ${BSD_INSTALL_DATA} -m 644 sounds/camaro_s16_le.wav $(DATADIR)/sounds/camaro_s16_le.wav
+ ${BSD_INSTALL_DATA} -m 644 sounds/detonationnorm_s16_le.wav $(DATADIR)/sounds/detonationnorm_s16_le.wav
- # Models
+ # Shaders
+- install -m 644 shaders/bramlight.fp $(GAMEDIR)/shaders/bramlight.fp
+- install -m 644 shaders/bramlight.vp $(GAMEDIR)/shaders/bramlight.vp
++ ${BSD_INSTALL_DATA} -m 644 shaders/bramlight.fp $(DATADIR)/shaders/bramlight.fp
++ ${BSD_INSTALL_DATA} -m 644 shaders/bramlight.vp $(DATADIR)/shaders/bramlight.vp
+ # Models (car parts)
+- install -m 644 models/coilspring.3ds $(GAMEDIR)/models/coilspring.3ds
+- install -m 644 models/fivespoke.3ds $(GAMEDIR)/models/fivespoke.3ds
+- install -m 644 models/frame.3ds $(GAMEDIR)/models/frame.3ds
+- install -m 644 models/leafspring.3ds $(GAMEDIR)/models/leafspring.3ds
+- install -m 644 models/rearaxle.3ds $(GAMEDIR)/models/rearaxle.3ds
+- install -m 644 models/spindle.3ds $(GAMEDIR)/models/spindle.3ds
+- install -m 644 models/wishbone.3ds $(GAMEDIR)/models/wishbone.3ds
++ ${BSD_INSTALL_DATA} -m 644 models/coilspring.3ds $(DATADIR)/models/coilspring.3ds
++ ${BSD_INSTALL_DATA} -m 644 models/fivespoke.3ds $(DATADIR)/models/fivespoke.3ds
++ ${BSD_INSTALL_DATA} -m 644 models/frame.3ds $(DATADIR)/models/frame.3ds
++ ${BSD_INSTALL_DATA} -m 644 models/leafspring.3ds $(DATADIR)/models/leafspring.3ds
++ ${BSD_INSTALL_DATA} -m 644 models/rearaxle.3ds $(DATADIR)/models/rearaxle.3ds
++ ${BSD_INSTALL_DATA} -m 644 models/spindle.3ds $(DATADIR)/models/spindle.3ds
++ ${BSD_INSTALL_DATA} -m 644 models/wishbone.3ds $(DATADIR)/models/wishbone.3ds
+ #install -m 644 models/car.3ds $(GAMEDIR)/models/car.3ds
+ #install -m 644 models/wheel.3ds $(GAMEDIR)/models/wheel.3ds
+ #install -m 644 models/licplate.ac $(GAMEDIR)/models/licplate.ac
+ #install -m 644 models/licplate.bmp $(GAMEDIR)/models/licplate.bmp
+ #install -m 644 models/truck.3ds $(GAMEDIR)/models/truck.3ds
+ # Models (other)
- install -m 644 models/baseplate.3ds $(GAMEDIR)/models/baseplate.3ds
-- install -m 644 models/car.3ds $(GAMEDIR)/models/car.3ds
- install -m 644 models/carpet.3ds $(GAMEDIR)/models/carpet.3ds
- install -m 644 models/crate.3ds $(GAMEDIR)/models/crate.3ds
- install -m 644 models/cratejump.3ds $(GAMEDIR)/models/cratejump.3ds
@@ -80,17 +122,17 @@
- install -m 644 models/ferriswheelwheel.3ds $(GAMEDIR)/models/ferriswheelwheel.3ds
- install -m 644 models/finishdoor.3ds $(GAMEDIR)/models/finishdoor.3ds
- install -m 644 models/finishplank.3ds $(GAMEDIR)/models/finishplank.3ds
+- install -m 644 models/floppy.3ds $(GAMEDIR)/models/floppy.3ds
- install -m 644 models/grid.3ds $(GAMEDIR)/models/grid.3ds
+- install -m 644 models/highjump.3ds $(GAMEDIR)/models/highjump.3ds
- install -m 644 models/jumpboard.3ds $(GAMEDIR)/models/jumpboard.3ds
-- install -m 644 models/licplate.ac $(GAMEDIR)/models/licplate.ac
-- install -m 644 models/licplate.bmp $(GAMEDIR)/models/licplate.bmp
- install -m 644 models/ramp.3ds $(GAMEDIR)/models/ramp.3ds
- install -m 644 models/spikegate.3ds $(GAMEDIR)/models/spikegate.3ds
+- install -m 644 models/terrain3.3ds $(GAMEDIR)/models/terrain3.3ds
- install -m 644 models/track.3ds $(GAMEDIR)/models/track.3ds
-- install -m 644 models/truck.3ds $(GAMEDIR)/models/truck.3ds
-- install -m 644 models/wheel.3ds $(GAMEDIR)/models/wheel.3ds
+- install -m 644 models/turntable_ramp.3ds $(GAMEDIR)/models/turntable_ramp.3ds
+- install -m 644 models/turntable_wheel.3ds $(GAMEDIR)/models/turntable_wheel.3ds
+ ${BSD_INSTALL_DATA} -m 644 models/baseplate.3ds $(DATADIR)/models/baseplate.3ds
-+ ${BSD_INSTALL_DATA} -m 644 models/car.3ds $(DATADIR)/models/car.3ds
+ ${BSD_INSTALL_DATA} -m 644 models/carpet.3ds $(DATADIR)/models/carpet.3ds
+ ${BSD_INSTALL_DATA} -m 644 models/crate.3ds $(DATADIR)/models/crate.3ds
+ ${BSD_INSTALL_DATA} -m 644 models/cratejump.3ds $(DATADIR)/models/cratejump.3ds
@@ -102,15 +144,16 @@
+ ${BSD_INSTALL_DATA} -m 644 models/ferriswheelwheel.3ds $(DATADIR)/models/ferriswheelwheel.3ds
+ ${BSD_INSTALL_DATA} -m 644 models/finishdoor.3ds $(DATADIR)/models/finishdoor.3ds
+ ${BSD_INSTALL_DATA} -m 644 models/finishplank.3ds $(DATADIR)/models/finishplank.3ds
++ ${BSD_INSTALL_DATA} -m 644 models/floppy.3ds $(DATADIR)/models/floppy.3ds
+ ${BSD_INSTALL_DATA} -m 644 models/grid.3ds $(DATADIR)/models/grid.3ds
++ ${BSD_INSTALL_DATA} -m 644 models/highjump.3ds $(DATADIR)/models/highjump.3ds
+ ${BSD_INSTALL_DATA} -m 644 models/jumpboard.3ds $(DATADIR)/models/jumpboard.3ds
-+ ${BSD_INSTALL_DATA} -m 644 models/licplate.ac $(DATADIR)/models/licplate.ac
-+ ${BSD_INSTALL_DATA} -m 644 models/licplate.bmp $(DATADIR)/models/licplate.bmp
+ ${BSD_INSTALL_DATA} -m 644 models/ramp.3ds $(DATADIR)/models/ramp.3ds
+ ${BSD_INSTALL_DATA} -m 644 models/spikegate.3ds $(DATADIR)/models/spikegate.3ds
++ ${BSD_INSTALL_DATA} -m 644 models/terrain3.3ds $(DATADIR)/models/terrain3.3ds
+ ${BSD_INSTALL_DATA} -m 644 models/track.3ds $(DATADIR)/models/track.3ds
-+ ${BSD_INSTALL_DATA} -m 644 models/truck.3ds $(DATADIR)/models/truck.3ds
-+ ${BSD_INSTALL_DATA} -m 644 models/wheel.3ds $(DATADIR)/models/wheel.3ds
-
++ ${BSD_INSTALL_DATA} -m 644 models/turntable_ramp.3ds $(DATADIR)/models/turntable_ramp.3ds
++ ${BSD_INSTALL_DATA} -m 644 models/turntable_wheel.3ds $(DATADIR)/models/turntable_wheel.3ds
deb:
+ strip stormbaancoureur
diff --git a/games/stormbaancoureur/files/patch-src-sturmbahnfahrer-controllerpad.cxx b/games/stormbaancoureur/files/patch-src-stormbaancoureur-controllerpad.cxx
index 057236a9eb65..81fa83d23797 100644
--- a/games/stormbaancoureur/files/patch-src-sturmbahnfahrer-controllerpad.cxx
+++ b/games/stormbaancoureur/files/patch-src-stormbaancoureur-controllerpad.cxx
@@ -1,5 +1,5 @@
---- src-sturmbahnfahrer/controllerpad.cxx.orig Mon Jul 17 00:26:08 2006
-+++ src-sturmbahnfahrer/controllerpad.cxx Mon Jul 17 00:28:23 2006
+--- src-stormbaancoureur/controllerpad.cxx.orig Mon Jul 17 00:26:08 2006
++++ src-stormbaancoureur/controllerpad.cxx Mon Jul 17 00:28:23 2006
@@ -14,7 +14,6 @@
#include <windows.h>
#include <mmsystem.h>
diff --git a/games/stormbaancoureur/files/patch-src-sturmbahnfahrer-main.cxx b/games/stormbaancoureur/files/patch-src-stormbaancoureur-main.cxx
index c2c45b30027d..87d2bf330b6c 100644
--- a/games/stormbaancoureur/files/patch-src-sturmbahnfahrer-main.cxx
+++ b/games/stormbaancoureur/files/patch-src-stormbaancoureur-main.cxx
@@ -1,15 +1,16 @@
---- src-sturmbahnfahrer/main.cxx.orig Thu May 17 20:02:03 2007
-+++ src-sturmbahnfahrer/main.cxx Thu Aug 9 02:21:33 2007
-@@ -656,12 +656,7 @@
+--- src-stormbaancoureur/main.cxx.orig 2007-12-28 23:09:41.000000000 +0300
++++ src-stormbaancoureur/main.cxx 2007-12-31 16:48:41.000000000 +0300
+@@ -1176,12 +1176,7 @@
fprintf(stderr,"OpenDE is (c) by Russel L. Smith\n");
char *bindirname = dirname(argv[0]);
- if (!strcmp(bindirname,"."))
- dirprefix="/usr/share/games/sturmbahnfahrer";
+- dirprefix="/usr/share/games/stormbaancoureur";
- else
- {
-- dirprefix = dirname(bindirname) + std::string("/share/games/sturmbahnfahrer");
+- dirprefix = dirname(bindirname) + std::string("/share/games/stormbaancoureur");
- }
++ dirprefix=__DATADIR;
if (getenv("PLODE_DATADIR"))
dirprefix = getenv("PLODE_DATADIR");
if (getenv("PLODE_DISPLAYMODE"))
diff --git a/games/stormbaancoureur/pkg-descr b/games/stormbaancoureur/pkg-descr
index 304b2fb2bc33..05584548c836 100644
--- a/games/stormbaancoureur/pkg-descr
+++ b/games/stormbaancoureur/pkg-descr
@@ -1,6 +1,9 @@
-Sturmbahnfahrer... for expert drivers only. If you want to master
-it, try to have the laws of physics work with you, not against you.
+Stormbaan Coureur is the Linux game that was formerly known as
+Sturmbahnfahrer. It is back with a larger track, more challenges,
+many improvements in a PC (Politically Correct) edition. In this
+game, it is all about the car Physics. If you want to master it,
+try to have the laws of physics work with you, not against you.
-Sturmbahnfahrer is a game by Bram Stolk.
+Stormbaan Coureur is a game by Bram Stolk.
WWW: http://www.sturmbahnfahrer.com/
diff --git a/games/stormbaancoureur/pkg-plist b/games/stormbaancoureur/pkg-plist
index 847c121c7b22..b0c8bc87f033 100644
--- a/games/stormbaancoureur/pkg-plist
+++ b/games/stormbaancoureur/pkg-plist
@@ -1,11 +1,12 @@
-bin/sturmbahnfahrer
+bin/stormbaancoureur
%%DATADIR%%/images/engine.tga
%%DATADIR%%/images/info_carpet_smooth.rgb
%%DATADIR%%/images/info_door_smooth.rgb
%%DATADIR%%/images/info_jump_smooth.rgb
+%%DATADIR%%/images/spot.tga
%%DATADIR%%/models/baseplate.3ds
-%%DATADIR%%/models/car.3ds
%%DATADIR%%/models/carpet.3ds
+%%DATADIR%%/models/coilspring.3ds
%%DATADIR%%/models/crate.3ds
%%DATADIR%%/models/crate_low.3ds
%%DATADIR%%/models/cratejump.3ds
@@ -16,19 +17,29 @@ bin/sturmbahnfahrer
%%DATADIR%%/models/ferriswheelwheel.3ds
%%DATADIR%%/models/finishdoor.3ds
%%DATADIR%%/models/finishplank.3ds
+%%DATADIR%%/models/fivespoke.3ds
+%%DATADIR%%/models/floppy.3ds
+%%DATADIR%%/models/frame.3ds
%%DATADIR%%/models/grid.3ds
+%%DATADIR%%/models/highjump.3ds
%%DATADIR%%/models/jumpboard.3ds
-%%DATADIR%%/models/licplate.ac
-%%DATADIR%%/models/licplate.bmp
+%%DATADIR%%/models/leafspring.3ds
%%DATADIR%%/models/ramp.3ds
+%%DATADIR%%/models/rearaxle.3ds
%%DATADIR%%/models/spikegate.3ds
+%%DATADIR%%/models/spindle.3ds
+%%DATADIR%%/models/terrain3.3ds
%%DATADIR%%/models/track.3ds
-%%DATADIR%%/models/truck.3ds
-%%DATADIR%%/models/wheel.3ds
+%%DATADIR%%/models/turntable_ramp.3ds
+%%DATADIR%%/models/turntable_wheel.3ds
+%%DATADIR%%/models/wishbone.3ds
+%%DATADIR%%/shaders/bramlight.fp
+%%DATADIR%%/shaders/bramlight.vp
%%DATADIR%%/sounds/camaro_s16_le.wav
%%DATADIR%%/sounds/detonationnorm_s16_le.wav
%%DATADIR%%/sounds/rpm_graph.txt
@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/shaders
@dirrm %%DATADIR%%/models
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%