aboutsummaryrefslogtreecommitdiff
path: root/games/stransball2
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-05-14 19:31:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-05-14 19:31:51 +0000
commitb8dbe5eaa1aac5dc251240b28de58518b621798d (patch)
tree8e6839a132b9c3a5d7c6ce485377cc8d0feb469e /games/stransball2
parente81019322947893ea2d1f94f3890c8296e04d00e (diff)
downloadports-b8dbe5eaa1aac5dc251240b28de58518b621798d.tar.gz
ports-b8dbe5eaa1aac5dc251240b28de58518b621798d.zip
- Add LICENSE
- Switch to options helpers - Fix build with clang 6.0
Notes
Notes: svn path=/head/; revision=469959
Diffstat (limited to 'games/stransball2')
-rw-r--r--games/stransball2/Makefile11
-rw-r--r--games/stransball2/files/patch-sources_auxiliar.cpp11
2 files changed, 19 insertions, 3 deletions
diff --git a/games/stransball2/Makefile b/games/stransball2/Makefile
index b9898c9b427a..6d419b866979 100644
--- a/games/stransball2/Makefile
+++ b/games/stransball2/Makefile
@@ -12,10 +12,13 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION:C/\.//}-linux
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Sequel to Transball and Transball 2 THRUST-type games
+LICENSE= GPLv2
+LICENSE_FILE= ${BUILD_WRKSRC}/LICENSE
+
LIB_DEPENDS= libSGE.so:devel/sdl_sge
USES= gmake dos2unix zip
-DOS2UNIX_FILES= sources/main.cpp
+DOS2UNIX_FILES= sources/main.cpp sources/auxiliar.cpp
USE_SDL= sdl image mixer sound
BUILD_WRKSRC= ${WRKSRC}/sources
@@ -37,8 +40,10 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- cd ${WRKSRC} && ${COPYTREE_SHARE} 'graphics sound maps demos' ${STAGEDIR}${DATADIR}/
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} 'graphics sound maps demos' ${STAGEDIR}${DATADIR}/
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/readme.txt ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>
diff --git a/games/stransball2/files/patch-sources_auxiliar.cpp b/games/stransball2/files/patch-sources_auxiliar.cpp
new file mode 100644
index 000000000000..02c8cdd7ca92
--- /dev/null
+++ b/games/stransball2/files/patch-sources_auxiliar.cpp
@@ -0,0 +1,11 @@
+--- sources/auxiliar.cpp.orig 2018-05-14 19:20:42 UTC
++++ sources/auxiliar.cpp
+@@ -48,7 +48,7 @@ SDL_Surface *load_maskedimage(char *imag
+ mask=IMG_Load(name);
+
+ if (tmp==0 ||
+- mask==0) return false;
++ mask==0) return NULL;
+
+ res=SDL_DisplayFormatAlpha(tmp);
+