aboutsummaryrefslogtreecommitdiff
path: root/games/sudoku/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-03-16 01:33:19 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-03-16 01:33:19 +0000
commitc8e6b8408ae13848e59143ed5deb59a1c3af4adc (patch)
tree88f4c94807a7956a34b8e8b06d41077637423a3c /games/sudoku/Makefile
parentd4c44f0a828d6c33343486bf781115169bc14818 (diff)
downloadports-c8e6b8408ae13848e59143ed5deb59a1c3af4adc.tar.gz
ports-c8e6b8408ae13848e59143ed5deb59a1c3af4adc.zip
Notes
Diffstat (limited to 'games/sudoku/Makefile')
-rw-r--r--games/sudoku/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/games/sudoku/Makefile b/games/sudoku/Makefile
new file mode 100644
index 000000000000..42716bcb9710
--- /dev/null
+++ b/games/sudoku/Makefile
@@ -0,0 +1,45 @@
+# ex:ts=8
+# Ports collection makefile for: sudoku
+# Date created: Feb 27, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sudoku
+PORTVERSION= 1.0.1
+CATEGORIES= games
+MASTER_SITES= http://www.laurasia.com.au/downloads/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= Console based sudoku games
+
+PLIST_FILES= bin/sudoku \
+ share/sudoku/template
+PLIST_DIRS= share/sudoku
+
+MAN6= sudoku.6
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-patch:
+ @${GREP} -lR "/usr/lib/sudoku" ${WRKSRC} | ${XARGS} \
+ ${REINPLACE_CMD} -e "s,/usr/lib/sudoku,${DATADIR},"
+
+do-build:
+ @cd ${WRKSRC} && ${CC} ${CFLAGS} -o ${PORTNAME} sudoku.c -lcurses
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${MAN6} ${MAN6PREFIX}/man/man6
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/template ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/sudoku.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>