aboutsummaryrefslogtreecommitdiff
path: root/games/sudoku
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-03-28 00:58:38 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-03-28 00:58:38 +0000
commit015a037fa205c270dd66e0e550f1c668cb548270 (patch)
tree97940b75fd70d0c3e9875b3c7f230733b7ccd5f0 /games/sudoku
parent1aab09a9059dccb0975787701aa683d40d8d1885 (diff)
Notes
Diffstat (limited to 'games/sudoku')
-rw-r--r--games/sudoku/Makefile1
-rw-r--r--games/sudoku/files/patch-sudoku.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/games/sudoku/Makefile b/games/sudoku/Makefile
index 42716bcb9710..552135c43cdc 100644
--- a/games/sudoku/Makefile
+++ b/games/sudoku/Makefile
@@ -8,6 +8,7 @@
PORTNAME= sudoku
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.laurasia.com.au/downloads/
EXTRACT_SUFX= .tgz
diff --git a/games/sudoku/files/patch-sudoku.c b/games/sudoku/files/patch-sudoku.c
new file mode 100644
index 000000000000..4f73a19cd3b3
--- /dev/null
+++ b/games/sudoku/files/patch-sudoku.c
@@ -0,0 +1,11 @@
+--- sudoku.c.orig Tue Mar 28 08:55:35 2006
++++ sudoku.c Tue Mar 28 08:55:55 2006
+@@ -1837,7 +1837,7 @@
+
+ /* Read character input (raw processing mode) */
+ i = strlen( userfile );
+- while( '\r' != ( ch = getkey( ) ) )
++ while( '\n' != ( ch = getkey( ) ) )
+ {
+ if( 0x08 == ch || VKEY_LEFT == ch ) /* destructive backspace */
+ {