aboutsummaryrefslogtreecommitdiff
path: root/games/super_methane_brothers
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-09-14 04:01:51 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-09-14 04:01:51 +0000
commitef6e522406462160b0f93a1fb47afff5ce5d8597 (patch)
tree229ba3d8b535c31cb4f89412ed1474b9f0f7f28f /games/super_methane_brothers
parentcc16bad9e2be50ad46e7f77791e11c60e74f1b66 (diff)
downloadports-ef6e522406462160b0f93a1fb47afff5ce5d8597.tar.gz
ports-ef6e522406462160b0f93a1fb47afff5ce5d8597.zip
Notes
Diffstat (limited to 'games/super_methane_brothers')
-rw-r--r--games/super_methane_brothers/Makefile31
-rw-r--r--games/super_methane_brothers/distinfo6
-rw-r--r--games/super_methane_brothers/pkg-install1
3 files changed, 16 insertions, 22 deletions
diff --git a/games/super_methane_brothers/Makefile b/games/super_methane_brothers/Makefile
index e27cecc5ad5f..aaee52c453ac 100644
--- a/games/super_methane_brothers/Makefile
+++ b/games/super_methane_brothers/Makefile
@@ -2,36 +2,36 @@
# Date created: 22 Jan 2004
# Whom: Jean-Yves Lefort <jylefort@brutele.be>
#
+# $Carpetsmoker: ports/games/super_methane_brothers/Makefile,v 1.2 2007/08/02 13:45:02 carpetsmoker Exp $
# $FreeBSD$
#
PORTNAME= super_methane_brothers
-PORTVERSION= 1.4.7
-PORTREVISION= 2
+PORTVERSION= 1.4.8
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= methane
DISTNAME= methane-${PORTVERSION}
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= carpetsmoker@xs4all.nl
COMMENT= A port of the Amiga platform game of the same name
-LIB_DEPENDS= clanCore-0.7:${PORTSDIR}/devel/clanlib-devel \
+LIB_DEPENDS= clanCore-0.8:${PORTSDIR}/devel/clanlib \
mikmod:${PORTSDIR}/audio/libmikmod
-BUILD_WRKSRC= ${WRKSRC}/source/linux
+USE_GMAKE= yes
MAKEFILE= makefile
+BUILD_WRKSRC= ${WRKSRC}/source/linux
-USE_X_PREFIX= yes
-USE_GMAKE= yes
+CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include/ClanLib-0.8
+LDFLAGS= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/ClanLib-0.8
post-patch:
@${REINPLACE_CMD} -e \
's|g++|${CXX}|; s|gcc|${CXX}|; \
- s|\(clanCore-0.7\)|\1 clanSignals-0.7|; \
- s|^\(METHANE_FLAGS =\)|\1 -I${X11BASE}/include|; \
- s|^\(METHANE_LIBS =\)|\1 -L${X11BASE}/lib|' \
+ s|^\(METHANE_FLAGS =\)|\1 ${CPPFLAGS}|; \
+ s|^\(METHANE_LIBS =\)|\1 ${LDFLAGS}|' \
${BUILD_WRKSRC}/makefile
do-install:
@@ -39,16 +39,9 @@ do-install:
${CHGRP} games ${PREFIX}/bin/methane
${CHMOD} g+s ${PREFIX}/bin/methane
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} \
- ${WRKSRC}/authors \
- ${WRKSRC}/history \
- ${WRKSRC}/readme \
- ${WRKSRC}/todo \
- ${DOCSDIR}
${MKDIR} ${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/docs/*.gif ${WRKSRC}/docs/*.html \
- ${DOCSDIR}/html
+ cd ${WRKSRC} && ${INSTALL_DATA} authors history readme todo ${DOCSDIR}
+ cd ${WRKSRC}/docs && ${INSTALL_DATA} *.gif *.html ${DOCSDIR}/html
.endif
post-install:
diff --git a/games/super_methane_brothers/distinfo b/games/super_methane_brothers/distinfo
index 6dd72250f802..f7bc36b5003f 100644
--- a/games/super_methane_brothers/distinfo
+++ b/games/super_methane_brothers/distinfo
@@ -1,3 +1,3 @@
-MD5 (methane-1.4.7.tgz) = c3db4683400ff39e5f9a4b93c4cdb526
-SHA256 (methane-1.4.7.tgz) = 53cd6cbf10da1011251765ad2bbc41f07c45be0a5d68ccfff8990f18b3912da9
-SIZE (methane-1.4.7.tgz) = 1058207
+MD5 (methane-1.4.8.tgz) = e580124ebbe40c81937e274ae5294e23
+SHA256 (methane-1.4.8.tgz) = 7e91d0b478b133a74565f0a7a01783cdda20bd555ca92feb4da66e51b51a9289
+SIZE (methane-1.4.8.tgz) = 1063099
diff --git a/games/super_methane_brothers/pkg-install b/games/super_methane_brothers/pkg-install
index 9d4d176b5a72..4a67b59829aa 100644
--- a/games/super_methane_brothers/pkg-install
+++ b/games/super_methane_brothers/pkg-install
@@ -4,6 +4,7 @@ SCOREFILE="/var/games/methanescores"
[ "$2" != "POST-INSTALL" -o -f "$SCOREFILE" ] && exit 0
+mkdir -p /var/games
touch $SCOREFILE
chown root:games $SCOREFILE
chmod 664 $SCOREFILE