aboutsummaryrefslogtreecommitdiff
path: root/games/super_methane_brothers
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-24 15:45:35 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-24 15:45:35 +0000
commitfa16001ef7d649001c363a37d64ecc2a5d0acb89 (patch)
treeeeec0ab3002b5a2e631f96a60b9313ab35f238af /games/super_methane_brothers
parent58db7776fd852e6c16926556bf7a79a94d898ec6 (diff)
downloadports-fa16001ef7d649001c363a37d64ecc2a5d0acb89.tar.gz
ports-fa16001ef7d649001c363a37d64ecc2a5d0acb89.zip
Notes
Diffstat (limited to 'games/super_methane_brothers')
-rw-r--r--games/super_methane_brothers/Makefile53
-rw-r--r--games/super_methane_brothers/distinfo4
-rw-r--r--games/super_methane_brothers/files/patch-source::linux::makefile49
-rw-r--r--games/super_methane_brothers/pkg-descr2
-rw-r--r--games/super_methane_brothers/pkg-install9
-rw-r--r--games/super_methane_brothers/pkg-plist45
6 files changed, 61 insertions, 101 deletions
diff --git a/games/super_methane_brothers/Makefile b/games/super_methane_brothers/Makefile
index 5818358d89b6..3f04669f6bbe 100644
--- a/games/super_methane_brothers/Makefile
+++ b/games/super_methane_brothers/Makefile
@@ -6,32 +6,44 @@
#
PORTNAME= super_methane_brothers
-PORTVERSION= 1.4.6
-PORTREVISION= 1
+PORTVERSION= 1.4.7
CATEGORIES= games
-MASTER_SITES= http://www.methane.fsnet.co.uk/
-DISTNAME= methane
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= methane
+DISTNAME= methane-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= jylefort@FreeBSD.org
COMMENT= A port of the Amiga platform game of the same name
-LIB_DEPENDS= clanCore.2:${PORTSDIR}/devel/clanlib \
+LIB_DEPENDS= clanCore-0.7:${PORTSDIR}/devel/clanlib-devel \
mikmod:${PORTSDIR}/audio/libmikmod
-WRKSRC= ${WRKDIR}/${DISTNAME}-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/source/linux
MAKEFILE= makefile
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
-MAKE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
- PTHREAD_LIBS=${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not compile on FreeBSD 4.X
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|g\+\+|$${CXX}|; \
+ s|gcc|$${CXX}|; \
+ s|^\(METHANE_FLAGS =\)|\1 -I${X11BASE}/include|; \
+ s|^\(METHANE_LIBS =\)|\1 -L${X11BASE}/lib|' \
+ ${BUILD_WRKSRC}/makefile
do-install:
- ${MKDIR} ${PREFIX}/bin
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/methane ${PREFIX}/bin
+ ${CHGRP} games ${PREFIX}/bin/methane
+ ${CHMOD} g+s ${PREFIX}/bin/methane
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} \
@@ -41,24 +53,11 @@ do-install:
${WRKSRC}/todo \
${DOCSDIR}
${MKDIR} ${DOCSDIR}/html
- ${INSTALL_DATA} \
- ${WRKSRC}/docs/block.gif \
- ${WRKSRC}/docs/bug.gif \
- ${WRKSRC}/docs/cookie.gif \
- ${WRKSRC}/docs/gamepic.gif \
- ${WRKSRC}/docs/gen.gif \
- ${WRKSRC}/docs/info.htm \
- ${WRKSRC}/docs/mbug.gif \
- ${WRKSRC}/docs/potion.gif \
- ${WRKSRC}/docs/puff.gif \
- ${WRKSRC}/docs/spike.gif \
- ${WRKSRC}/docs/spring.gif \
- ${WRKSRC}/docs/sucker.gif \
- ${WRKSRC}/docs/title.gif \
- ${WRKSRC}/docs/turbo.gif \
- ${WRKSRC}/docs/whirly.gif \
- ${WRKSRC}/docs/zoom.gif \
+ ${INSTALL_DATA} ${WRKSRC}/docs/*.gif ${WRKSRC}/docs/*.html \
${DOCSDIR}/html
.endif
-.include <bsd.port.mk>
+post-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.post.mk>
diff --git a/games/super_methane_brothers/distinfo b/games/super_methane_brothers/distinfo
index 992cb55bd7c5..0d8d6f2b6e59 100644
--- a/games/super_methane_brothers/distinfo
+++ b/games/super_methane_brothers/distinfo
@@ -1,2 +1,2 @@
-MD5 (methane.tgz) = fac55b79e9beb84fb2c1508b7a6b4964
-SIZE (methane.tgz) = 1040821
+MD5 (methane-1.4.7.tgz) = c3db4683400ff39e5f9a4b93c4cdb526
+SIZE (methane-1.4.7.tgz) = 1058207
diff --git a/games/super_methane_brothers/files/patch-source::linux::makefile b/games/super_methane_brothers/files/patch-source::linux::makefile
deleted file mode 100644
index 7591aab31a9f..000000000000
--- a/games/super_methane_brothers/files/patch-source::linux::makefile
+++ /dev/null
@@ -1,49 +0,0 @@
---- source/linux/makefile.orig Thu Jan 22 17:22:08 2004
-+++ source/linux/makefile Thu Jan 22 17:40:13 2004
-@@ -1,7 +1,7 @@
-
- # Comment out the two lines shown below to disable sound
--MIKMOD_LIBS = `libmikmod-config --cflags` `libmikmod-config --libs`
--METHANE_FLAGS = -DMETHANE_MIKMOD
-+MIKMOD_LIBS = `libmikmod-config --libs`
-+METHANE_FLAGS = -DMETHANE_MIKMOD -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-
- all: message methane
-
-@@ -22,7 +22,7 @@
- MainSource/misc.o MainSource/objlist.o MainSource/player.o MainSource/power.o MainSource/target.o \
- MainSource/suck.o MainSource/weapon.o MainSource/sound.o MainData/snddata.o MainData/gfxdata.o MainData/gfxdata2.o \
- MainData/gfxdata3.o MainData/mapdata.o MainLinux/font32.o MainLinux/doc.o MainLinux/main.o MainMikMod/audiodrv.o \
-- -o methane -lclanCore -lclanApp -lclanDisplay ${MIKMOD_LIBS}
-+ -o methane -L${LOCALBASE}/lib -lclanCore -lclanApp -lclanDisplay ${MIKMOD_LIBS} ${PTHREAD_LIBS}
-
- clean:
- @rm -Rf MainSource
-@@ -38,23 +38,23 @@
- MainSource/%.o : ../%.cpp
- @echo " Compiling $<..."
- @if [ ! -d MainSource ]; then mkdir MainSource; fi
-- gcc ${CXXFLAGS} ${METHANE_FLAGS} -I ../linux `libmikmod-config --cflags` -c $< -o $@
-+ ${CXX} ${CXXFLAGS} ${METHANE_FLAGS} -I ../linux `libmikmod-config --cflags` -c $< -o $@
-
- # The main data
- MainData/%.o : ../data/%.cpp
- @echo " Compiling $<..."
- @if [ ! -d MainData ]; then mkdir MainData; fi
-- gcc ${CXXFLAGS} ${METHANE_FLAGS} -I ../ `libmikmod-config --cflags` -c $< -o $@
-+ ${CXX} ${CXXFLAGS} ${METHANE_FLAGS} -I ../ `libmikmod-config --cflags` -c $< -o $@
-
- # The linux source code
- MainLinux/%.o : ../linux/%.cpp
- @echo " Compiling $<..."
- @if [ ! -d MainLinux ]; then mkdir MainLinux; fi
-- gcc ${CXXFLAGS} ${METHANE_FLAGS} -I ../ `libmikmod-config --cflags` -c $< -o $@
-+ ${CXX} ${CXXFLAGS} ${METHANE_FLAGS} -I ../ `libmikmod-config --cflags` -c $< -o $@
-
- # The sound driver source code
- MainMikMod/%.o : ../mikmod/%.cpp
- @echo " Compiling $<..."
- @if [ ! -d MainMikMod ]; then mkdir MainMikMod; fi
-- gcc ${CXXFLAGS} ${METHANE_FLAGS} -I ../ `libmikmod-config --cflags` -c $< -o $@
-+ ${CXX} ${CXXFLAGS} ${METHANE_FLAGS} -I ../ `libmikmod-config --cflags` -c $< -o $@
-
diff --git a/games/super_methane_brothers/pkg-descr b/games/super_methane_brothers/pkg-descr
index 7891988a9da5..9564ffb1a5dd 100644
--- a/games/super_methane_brothers/pkg-descr
+++ b/games/super_methane_brothers/pkg-descr
@@ -7,7 +7,7 @@ vertical surface. Bad guys then turn into bonuses which can be
collected. Be warned! - the gas cloud dissolves with time after which
baddies become active again and extremely annoyed.
-WWW: http://www.methane.fsnet.co.uk/
+WWW: http://methane.sourceforge.net/
- Jean-Yves Lefort
jylefort@FreeBSD.org
diff --git a/games/super_methane_brothers/pkg-install b/games/super_methane_brothers/pkg-install
new file mode 100644
index 000000000000..9d4d176b5a72
--- /dev/null
+++ b/games/super_methane_brothers/pkg-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+SCOREFILE="/var/games/methanescores"
+
+[ "$2" != "POST-INSTALL" -o -f "$SCOREFILE" ] && exit 0
+
+touch $SCOREFILE
+chown root:games $SCOREFILE
+chmod 664 $SCOREFILE
diff --git a/games/super_methane_brothers/pkg-plist b/games/super_methane_brothers/pkg-plist
index 4cb40c233684..886517a91c72 100644
--- a/games/super_methane_brothers/pkg-plist
+++ b/games/super_methane_brothers/pkg-plist
@@ -1,23 +1,24 @@
bin/methane
-%%PORTDOCS%%share/doc/super_methane_brothers/authors
-%%PORTDOCS%%share/doc/super_methane_brothers/history
-%%PORTDOCS%%share/doc/super_methane_brothers/html/block.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/bug.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/cookie.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/gamepic.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/gen.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/info.htm
-%%PORTDOCS%%share/doc/super_methane_brothers/html/mbug.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/potion.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/puff.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/spike.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/spring.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/sucker.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/title.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/turbo.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/whirly.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/html/zoom.gif
-%%PORTDOCS%%share/doc/super_methane_brothers/readme
-%%PORTDOCS%%share/doc/super_methane_brothers/todo
-%%PORTDOCS%%@dirrm share/doc/super_methane_brothers/html
-%%PORTDOCS%%@dirrm share/doc/super_methane_brothers
+%%PORTDOCS%%%%DOCSDIR%%/authors
+%%PORTDOCS%%%%DOCSDIR%%/history
+%%PORTDOCS%%%%DOCSDIR%%/html/backdrop.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/block.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/bug.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/cookie.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/gamepic.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/gen.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/info.html
+%%PORTDOCS%%%%DOCSDIR%%/html/mbug.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/potion.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/puff.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/spike.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/spring.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/sucker.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/title.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/turbo.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/whirly.gif
+%%PORTDOCS%%%%DOCSDIR%%/html/zoom.gif
+%%PORTDOCS%%%%DOCSDIR%%/readme
+%%PORTDOCS%%%%DOCSDIR%%/todo
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%