aboutsummaryrefslogtreecommitdiff
path: root/games/sxsame
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>1999-12-10 19:30:05 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>1999-12-10 19:30:05 +0000
commitfd1fff83b22d13f6d218ea02a33f04c85b10fc2a (patch)
tree8f6278034ad2b0639aec3f882fc49dc6e817b9e0 /games/sxsame
parent1f729c00fad997c1d2f7ee510a65d079c88e1995 (diff)
downloadports-fd1fff83b22d13f6d218ea02a33f04c85b10fc2a.tar.gz
ports-fd1fff83b22d13f6d218ea02a33f04c85b10fc2a.zip
Submitted by: aconitum@po.teleway.ne.jp
A tile-removing puzzle game for the X Window system
Notes
Notes: svn path=/head/; revision=23752
Diffstat (limited to 'games/sxsame')
-rw-r--r--games/sxsame/Makefile36
-rw-r--r--games/sxsame/distinfo1
-rw-r--r--games/sxsame/files/patch-aa31
-rw-r--r--games/sxsame/pkg-comment1
-rw-r--r--games/sxsame/pkg-descr5
-rw-r--r--games/sxsame/pkg-plist33
6 files changed, 107 insertions, 0 deletions
diff --git a/games/sxsame/Makefile b/games/sxsame/Makefile
new file mode 100644
index 000000000000..a1065ef76ad7
--- /dev/null
+++ b/games/sxsame/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: sxsame
+# Version required: 3.02
+# Date created: 11 December 1999
+# Whom: Yuichi Narahara
+#
+# $FreeBSD$
+#
+
+DISTNAME= sxsame-3.02
+CATEGORIES= games
+MASTER_SITES= ftp://stardust.sfc.wide.ad.jp/pub/JG/JG-0.9.1/sources/\
+ ftp://jg.cc.hit-u.ac.jp/pub/JG/JG-0.9.1/sources/\
+ ftp://ftp.jaist.ac.jp/pub/os/linux/JG/JG-0.9.1/sources/\
+ ftp://mirror.nucba.ac.jp/mirror/JG/JG-0.9.1/sources/
+
+MAINTAINER= aconitum@po.teleway.ne.jp
+
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+
+USE_IMAKE= yes
+NO_INSTALL_MANPAGES= yes
+INSTALL_TARGET= install install.dir
+BINOWN= games
+BINGRP= games
+BINMODE= 2755
+MAKE_ENV+= BINOWN=${BINOWN} BINGRP=${BINGRP} BINMODE=${BINMODE}
+
+WRKSRC= ${WRKDIR}/sxsame-3.02
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/doc/sxsame
+.for i in INSTALL.jp README.jp
+ @${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/doc/sxsame
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/sxsame/distinfo b/games/sxsame/distinfo
new file mode 100644
index 000000000000..e3d7c3b2bcde
--- /dev/null
+++ b/games/sxsame/distinfo
@@ -0,0 +1 @@
+MD5 (sxsame-3.02.tar.gz) = af73131f673ae16d78f3d1b2f84fe009
diff --git a/games/sxsame/files/patch-aa b/games/sxsame/files/patch-aa
new file mode 100644
index 000000000000..be66a133feb2
--- /dev/null
+++ b/games/sxsame/files/patch-aa
@@ -0,0 +1,31 @@
+--- Imakefile.orig Sun May 5 04:10:27 1996
++++ Imakefile Mon Nov 1 02:11:20 1999
+@@ -3,7 +3,7 @@
+ # * Copyleft (c) 1994-1996 Software Research Academy *
+ # **************************************************************
+ #
+-SAMEDIR = /usr/local/games/sxsame
++SAMEDIR = $(PREFIX)/lib/X11/sxsame
+
+ #BINDIR = /usr/local/bin
+ #MANDIR = /usr/local/man/man1
+@@ -11,6 +11,7 @@
+ #XPMLIB = -L/usr/local/lib/X11 -lXpm
+ #EXTRA_DEFINES = -DLOCAL_XPM_H -I/usr/local/include/X11
+
++INSTPGMFLAGS=-s -o ${BINOWN} -g ${BINGRP} -m ${BINMODE}
+
+ XPMLIB = -lXpm
+ LOCAL_LIBRARIES = $(XPMLIB) -lX11
+@@ -29,6 +30,10 @@
+ #defdata.o:: defdata.c defdata.h
+ install.dir::
+ $(MKDIRHIER) $(SAMEDIR)
+- chmod 777 $(SAMEDIR)
++ chmod 2775 $(SAMEDIR)
++ chown ${BINOWN}:${BINGRP} $(SAMEDIR)
+ /bin/cp -pr contrib/?* $(SAMEDIR)
++ touch $(SAMEDIR)/hiscore
++ chmod 664 $(SAMEDIR)/hiscore
++ chown ${BINOWN}:${BINGRP} $(SAMEDIR)/hiscore
+
diff --git a/games/sxsame/pkg-comment b/games/sxsame/pkg-comment
new file mode 100644
index 000000000000..b73d48067120
--- /dev/null
+++ b/games/sxsame/pkg-comment
@@ -0,0 +1 @@
+A tile-removing puzzle game for the X Window system.
diff --git a/games/sxsame/pkg-descr b/games/sxsame/pkg-descr
new file mode 100644
index 000000000000..adde087b38af
--- /dev/null
+++ b/games/sxsame/pkg-descr
@@ -0,0 +1,5 @@
+sxsame -- a game of removing tiles,for X Window system
+
+Goal of this game is removing more tiles as you can and
+get much score. You can remove two or more tiles with
+same color,neibouring vertical or horizontal.
diff --git a/games/sxsame/pkg-plist b/games/sxsame/pkg-plist
new file mode 100644
index 000000000000..b67e5e3dd4d1
--- /dev/null
+++ b/games/sxsame/pkg-plist
@@ -0,0 +1,33 @@
+bin/sxsame
+lib/X11/sxsame/bomb/blun.xpm
+lib/X11/sxsame/bomb/blus.xpm
+lib/X11/sxsame/bomb/cyan.xpm
+lib/X11/sxsame/bomb/cyas.xpm
+lib/X11/sxsame/bomb/frame.xpm
+lib/X11/sxsame/bomb/purn.xpm
+lib/X11/sxsame/bomb/purs.xpm
+lib/X11/sxsame/bomb/pushed.xpm
+lib/X11/sxsame/bomb/redn.xpm
+lib/X11/sxsame/bomb/reds.xpm
+lib/X11/sxsame/bomb/tile.xpm
+lib/X11/sxsame/bomb/yeln.xpm
+lib/X11/sxsame/bomb/yels.xpm
+lib/X11/sxsame/bomb.same
+lib/X11/sxsame/hiscore
+lib/X11/sxsame/mono1/back.xpm
+lib/X11/sxsame/mono1/frame.xpm
+lib/X11/sxsame/mono1/koma1.xpm
+lib/X11/sxsame/mono1/koma2.xpm
+lib/X11/sxsame/mono1/koma3.xpm
+lib/X11/sxsame/mono1/koma4.xpm
+lib/X11/sxsame/mono1/koma5.xpm
+lib/X11/sxsame/mono1.same
+lib/X11/sxsame/s_marble.bmp
+lib/X11/sxsame/samegame.dat
+lib/X11/sxsame/snake.bmp
+share/doc/sxsame/INSTALL.jp
+share/doc/sxsame/README.jp
+@dirrm share/doc/sxsame
+@exec mkdir -p %D/lib/X11/sxsame
+@exec chmod 2775 %D/lib/X11/sxsame
+@unexec rm -rf %D/lib/X11/sxsame