aboutsummaryrefslogtreecommitdiff
path: root/games/sxsame
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-18 15:31:02 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-18 15:31:02 +0000
commit0f066d73c48f8e104cf1c028065bd899fb8f2421 (patch)
tree9c74774589473b2b595f39d29a7644d9b81d115c /games/sxsame
parente82f7cc8f78bd4a4e7e87d0539702dc7739b921d (diff)
downloadports-0f066d73c48f8e104cf1c028065bd899fb8f2421.tar.gz
ports-0f066d73c48f8e104cf1c028065bd899fb8f2421.zip
Notes
Diffstat (limited to 'games/sxsame')
-rw-r--r--games/sxsame/Makefile20
-rw-r--r--games/sxsame/pkg-plist10
2 files changed, 16 insertions, 14 deletions
diff --git a/games/sxsame/Makefile b/games/sxsame/Makefile
index 767241d8cae0..cfd7915af813 100644
--- a/games/sxsame/Makefile
+++ b/games/sxsame/Makefile
@@ -20,20 +20,16 @@ COMMENT= Tile-removing puzzle game for the X Window system
USES= imake
USE_XORG= xpm
INSTALL_TARGET= install install.dir
-BINOWN= root
-BINGRP= games
-BINMODE= 2755
-MAKE_ENV+= BINOWN=${BINOWN} BINGRP=${BINGRP} BINMODE=${BINMODE}
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sxsame ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/X11/sxsame
+ (cd ${WRKSRC}/contrib ; ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/X11/sxsame)
+ ${TOUCH} ${STAGEDIR}${PREFIX}/lib/X11/sxsame/hiscore
+ @${CHMOD} 664 ${STAGEDIR}${PREFIX}/lib/X11/sxsame/hiscore
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in INSTALL.jp README.jp
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/games/sxsame/pkg-plist b/games/sxsame/pkg-plist
index a10d1faa9a88..f4678943a90d 100644
--- a/games/sxsame/pkg-plist
+++ b/games/sxsame/pkg-plist
@@ -1,4 +1,8 @@
+@group games
+@mode 2755
bin/sxsame
+@mode
+@group
lib/X11/sxsame/bomb/blun.xpm
lib/X11/sxsame/bomb/blus.xpm
lib/X11/sxsame/bomb/cyan.xpm
@@ -28,6 +32,8 @@ lib/X11/sxsame/snake.bmp
%%PORTDOCS%%%%DOCSDIR%%/INSTALL.jp
%%PORTDOCS%%%%DOCSDIR%%/README.jp
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry lib/X11/sxsame/mono1
+@dirrmtry lib/X11/sxsame/bomb
+@dirrmtry lib/X11/sxsame
@exec mkdir -p %D/lib/X11/sxsame
-@exec chmod 2775 %D/lib/X11/sxsame
-@unexec rm -rf %D/lib/X11/sxsame
+@exec chmod 2775 %D/lib/X11/sxsame ; chown -R root:games %D/lib/X11/sxsame