aboutsummaryrefslogtreecommitdiff
path: root/games/syobon
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-09-24 23:59:05 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-09-24 23:59:05 +0000
commit8cdaf19a99a517aaf5b88680ebf857afea0aae12 (patch)
tree3887dd26aac11aabb492dc746f9917c6097accfc /games/syobon
parent67bb853a59405279c1dff50a5d8513b3bc9e7133 (diff)
downloadports-8cdaf19a99a517aaf5b88680ebf857afea0aae12.tar.gz
ports-8cdaf19a99a517aaf5b88680ebf857afea0aae12.zip
Notes
Diffstat (limited to 'games/syobon')
-rw-r--r--games/syobon/Makefile41
-rw-r--r--games/syobon/distinfo2
-rw-r--r--games/syobon/pkg-plist40
3 files changed, 63 insertions, 20 deletions
diff --git a/games/syobon/Makefile b/games/syobon/Makefile
index 46e5d63484eb..a1ec716191b0 100644
--- a/games/syobon/Makefile
+++ b/games/syobon/Makefile
@@ -1,46 +1,47 @@
-# Created by: nemysis@gmx.ch
+# Created by: nemysis <nemysis@gmx.ch>
# $FreeBSD$
PORTNAME= syobon
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
-MASTER_SITES= http://download.zapek.com/software/${PORTNAME}/
-DISTNAME= ${PORTNAME}_${PORTVERSION}
-EXTRACT_SUFX= _src.tar.gz
+MASTER_SITES= http://download.zapek.com/software/${PORTNAME}/ \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}_${DISTVERSION}_src${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+EXTRACT_ONLY= ${PORTNAME}_${DISTVERSION}_src${EXTRACT_SUFX}
-MAINTAINER= nemysis@gmx.ch
-COMMENT= Syobon Action is a platform game as Super Mario Bros
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Platform game as Super Mario Bros
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= gmake pkgconfig
-USE_DOS2UNIX= *.txt
-ALL_TARGET= ${PORTNAME}
USE_SDL= sdl gfx image mixer ttf
+USE_DOS2UNIX= *.cpp *.txt
+USE_GCC= yes
+ALL_TARGET= ${PORTNAME}
-PLIST_FILES= bin/${PORTNAME}
+MAKE_ENV= GAMEDATA="${DATADIR}"
PORTDOCS= README.txt
-PORTDATA= *
-MAKE_ENV= GAMEDATA="${DATADIR}"
+DESKTOP_ENTRIES="Syobon Action" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" false
+
+OPTIONS_DEFINE= DOCS
NO_STAGE= yes
.include <bsd.port.options.mk>
do-install:
-# Executable
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-
-# Data
- ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "BGM SE res" ${DATADIR})
+ ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
-# Documentation
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/games/syobon/distinfo b/games/syobon/distinfo
index 1ea6a84549f3..758c729ae65e 100644
--- a/games/syobon/distinfo
+++ b/games/syobon/distinfo
@@ -1,2 +1,4 @@
SHA256 (syobon_1.0.1_src.tar.gz) = e7aaf73098e6bd748ae682aab4e959e887a742647124aac813f864e5106b943a
SIZE (syobon_1.0.1_src.tar.gz) = 2721153
+SHA256 (syobon.png) = ef9c5d27c855ef4d83da98562e8f7d4515d232ca4352ecdbf75b0725490f4111
+SIZE (syobon.png) = 1760
diff --git a/games/syobon/pkg-plist b/games/syobon/pkg-plist
new file mode 100644
index 000000000000..9180c1c1c32c
--- /dev/null
+++ b/games/syobon/pkg-plist
@@ -0,0 +1,40 @@
+bin/syobon
+share/pixmaps/syobon.png
+%%DATADIR%%/BGM/castle.ogg
+%%DATADIR%%/BGM/dungeon.ogg
+%%DATADIR%%/BGM/field.ogg
+%%DATADIR%%/BGM/puyo.ogg
+%%DATADIR%%/BGM/star4.ogg
+%%DATADIR%%/SE/4-clear.ogg
+%%DATADIR%%/SE/Pswitch.ogg
+%%DATADIR%%/SE/allclear.ogg
+%%DATADIR%%/SE/brockbreak.ogg
+%%DATADIR%%/SE/brockcoin.ogg
+%%DATADIR%%/SE/brockkinoko.ogg
+%%DATADIR%%/SE/coin.ogg
+%%DATADIR%%/SE/death.ogg
+%%DATADIR%%/SE/dokan.ogg
+%%DATADIR%%/SE/gameover.ogg
+%%DATADIR%%/SE/goal.ogg
+%%DATADIR%%/SE/hintBlock.ogg
+%%DATADIR%%/SE/humi.ogg
+%%DATADIR%%/SE/jump.ogg
+%%DATADIR%%/SE/jumpBlock.ogg
+%%DATADIR%%/SE/kirra.ogg
+%%DATADIR%%/SE/koura.ogg
+%%DATADIR%%/SE/powerup.ogg
+%%DATADIR%%/SE/tekifire.ogg
+%%DATADIR%%/res/DejaVuSans.ttf
+%%DATADIR%%/res/brock.PNG
+%%DATADIR%%/res/brock2.PNG
+%%DATADIR%%/res/haikei.PNG
+%%DATADIR%%/res/item.PNG
+%%DATADIR%%/res/omake.PNG
+%%DATADIR%%/res/omake2.PNG
+%%DATADIR%%/res/player.PNG
+%%DATADIR%%/res/syobon3.PNG
+%%DATADIR%%/res/teki.PNG
+@dirrm %%DATADIR%%/res
+@dirrm %%DATADIR%%/SE
+@dirrm %%DATADIR%%/BGM
+@dirrm %%DATADIR%%