aboutsummaryrefslogtreecommitdiff
path: root/games/tali
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /games/tali
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
Notes
Diffstat (limited to 'games/tali')
-rw-r--r--games/tali/Makefile26
-rw-r--r--games/tali/distinfo2
-rw-r--r--games/tali/pkg-descr5
-rw-r--r--games/tali/pkg-install17
-rw-r--r--games/tali/pkg-plist199
5 files changed, 249 insertions, 0 deletions
diff --git a/games/tali/Makefile b/games/tali/Makefile
new file mode 100644
index 000000000000..55d636e4d1ca
--- /dev/null
+++ b/games/tali/Makefile
@@ -0,0 +1,26 @@
+# Created by: FreeBSD GNOME Team <gnome@freebsd.org>
+# $FreeBSD$
+# $MCom: ports/trunk/games/tali/Makefile 19989 2014-10-18 09:53:56Z gusi $
+
+PORTNAME= tali
+PORTVERSION= 3.14.0
+CATEGORIES= games gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Gnome tali
+
+BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
+
+USES= gettext gmake pathfix pkgconfig tar:xz
+USE_GNOME= gtk30 intlhack librsvg2 libxml2:build
+INSTALLS_ICONS= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+GLIB_SCHEMAS= org.gnome.tali.gschema.xml
+
+.include <bsd.port.mk>
diff --git a/games/tali/distinfo b/games/tali/distinfo
new file mode 100644
index 000000000000..b06af2bd0537
--- /dev/null
+++ b/games/tali/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/tali-3.14.0.tar.xz) = 81f15fcab820d384d02cd39033f2931cd15926f5a39d8c02766584d3b1b2f939
+SIZE (gnome3/tali-3.14.0.tar.xz) = 2835264
diff --git a/games/tali/pkg-descr b/games/tali/pkg-descr
new file mode 100644
index 000000000000..37400748ae0a
--- /dev/null
+++ b/games/tali/pkg-descr
@@ -0,0 +1,5 @@
+Tali is a sort of poker with dice and less money. You roll five dice three
+times and try to create the best hand. Your two rerolls may include any or
+all of your dice. Tali also supports playing Kismet.
+
+WWW: https://wiki.gnome.org/Tali
diff --git a/games/tali/pkg-install b/games/tali/pkg-install
new file mode 100644
index 000000000000..5776e0fbfb55
--- /dev/null
+++ b/games/tali/pkg-install
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+PATH=/bin:/usr/bin:/usr/sbin
+
+case $2 in
+POST-INSTALL)
+ mkdir -p ${PKG_PREFIX}/share/games
+ SCORES="gtali.Colors.scores gtali.Regular.scores"
+ for i in ${SCORES}; do
+ if [ ! -f ${PKG_PREFIX}/share/games/${i} ]; then
+ touch -f ${PKG_PREFIX}/share/games/${i}
+ chown games:games ${PKG_PREFIX}/share/games/${i}
+ chmod 0666 ${PKG_PREFIX}/share/games/${i}
+ fi
+ done
+ ;;
+esac
diff --git a/games/tali/pkg-plist b/games/tali/pkg-plist
new file mode 100644
index 000000000000..ba908d8151fa
--- /dev/null
+++ b/games/tali/pkg-plist
@@ -0,0 +1,199 @@
+bin/tali
+man/man6/tali.6.gz
+share/appdata/tali.appdata.xml
+share/applications/tali.desktop
+@unexec [ -s %D/share/games/gtali.Colors.scores ] || rm -f %D/share/games/gtali.Colors.scores
+@unexec [ -s %D/share/games/gtali.Regular.scores ] || rm -f %D/share/games/gtali.Regular.scores
+share/help/C/tali/index.docbook
+share/help/C/tali/legal.xml
+share/help/C/tali/figures/mainwindow.png
+share/help/C/tali/figures/preferences.png
+share/help/ca/tali/index.docbook
+share/help/ca/tali/legal.xml
+share/help/ca/tali/figures/mainwindow.png
+share/help/ca/tali/figures/preferences.png
+share/help/cs/tali/index.docbook
+share/help/cs/tali/legal.xml
+share/help/cs/tali/figures/mainwindow.png
+share/help/cs/tali/figures/preferences.png
+share/help/da/tali/index.docbook
+share/help/da/tali/legal.xml
+share/help/da/tali/figures/mainwindow.png
+share/help/da/tali/figures/preferences.png
+share/help/de/tali/index.docbook
+share/help/de/tali/legal.xml
+share/help/de/tali/figures/mainwindow.png
+share/help/de/tali/figures/preferences.png
+share/help/el/tali/index.docbook
+share/help/el/tali/legal.xml
+share/help/el/tali/figures/mainwindow.png
+share/help/el/tali/figures/preferences.png
+share/help/en_GB/tali/index.docbook
+share/help/en_GB/tali/legal.xml
+share/help/en_GB/tali/figures/mainwindow.png
+share/help/en_GB/tali/figures/preferences.png
+share/help/es/tali/index.docbook
+share/help/es/tali/legal.xml
+share/help/es/tali/figures/mainwindow.png
+share/help/es/tali/figures/preferences.png
+share/help/eu/tali/index.docbook
+share/help/eu/tali/legal.xml
+share/help/eu/tali/figures/mainwindow.png
+share/help/eu/tali/figures/preferences.png
+share/help/fr/tali/index.docbook
+share/help/fr/tali/legal.xml
+share/help/fr/tali/figures/mainwindow.png
+share/help/fr/tali/figures/preferences.png
+share/help/gl/tali/index.docbook
+share/help/gl/tali/legal.xml
+share/help/gl/tali/figures/mainwindow.png
+share/help/gl/tali/figures/preferences.png
+share/help/it/tali/index.docbook
+share/help/it/tali/legal.xml
+share/help/it/tali/figures/mainwindow.png
+share/help/it/tali/figures/preferences.png
+share/help/oc/tali/index.docbook
+share/help/oc/tali/legal.xml
+share/help/oc/tali/figures/mainwindow.png
+share/help/oc/tali/figures/preferences.png
+share/help/pt_BR/tali/index.docbook
+share/help/pt_BR/tali/legal.xml
+share/help/pt_BR/tali/figures/mainwindow.png
+share/help/pt_BR/tali/figures/preferences.png
+share/help/ru/tali/figures/mainwindow.png
+share/help/ru/tali/figures/preferences.png
+share/help/ru/tali/index.docbook
+share/help/ru/tali/legal.xml
+share/help/sl/tali/index.docbook
+share/help/sl/tali/legal.xml
+share/help/sl/tali/figures/mainwindow.png
+share/help/sl/tali/figures/preferences.png
+share/help/sr/tali/index.docbook
+share/help/sr/tali/legal.xml
+share/help/sr/tali/figures/mainwindow.png
+share/help/sr/tali/figures/preferences.png
+share/help/sr@latin/tali/index.docbook
+share/help/sr@latin/tali/legal.xml
+share/help/sr@latin/tali/figures/mainwindow.png
+share/help/sr@latin/tali/figures/preferences.png
+share/help/sv/tali/index.docbook
+share/help/sv/tali/legal.xml
+share/help/sv/tali/figures/mainwindow.png
+share/help/sv/tali/figures/preferences.png
+share/help/zh_CN/tali/index.docbook
+share/help/zh_CN/tali/legal.xml
+share/help/zh_CN/tali/figures/mainwindow.png
+share/help/zh_CN/tali/figures/preferences.png
+share/icons/HighContrast/16x16/apps/tali.png
+share/icons/HighContrast/22x22/apps/tali.png
+share/icons/HighContrast/24x24/apps/tali.png
+share/icons/HighContrast/256x256/apps/tali.png
+share/icons/HighContrast/32x32/apps/tali.png
+share/icons/HighContrast/48x48/apps/tali.png
+share/icons/hicolor/16x16/apps/tali.png
+share/icons/hicolor/22x22/apps/tali.png
+share/icons/hicolor/24x24/apps/tali.png
+share/icons/hicolor/32x32/apps/tali.png
+share/icons/hicolor/48x48/apps/tali.png
+share/icons/hicolor/scalable/apps/tali.svg
+share/locale/af/LC_MESSAGES/tali.mo
+share/locale/am/LC_MESSAGES/tali.mo
+share/locale/ar/LC_MESSAGES/tali.mo
+share/locale/as/LC_MESSAGES/tali.mo
+share/locale/ast/LC_MESSAGES/tali.mo
+share/locale/az/LC_MESSAGES/tali.mo
+share/locale/be/LC_MESSAGES/tali.mo
+share/locale/bg/LC_MESSAGES/tali.mo
+share/locale/bn/LC_MESSAGES/tali.mo
+share/locale/bn_IN/LC_MESSAGES/tali.mo
+share/locale/br/LC_MESSAGES/tali.mo
+share/locale/ca/LC_MESSAGES/tali.mo
+share/locale/ca@valencia/LC_MESSAGES/tali.mo
+share/locale/cs/LC_MESSAGES/tali.mo
+share/locale/cy/LC_MESSAGES/tali.mo
+share/locale/da/LC_MESSAGES/tali.mo
+share/locale/de/LC_MESSAGES/tali.mo
+share/locale/dz/LC_MESSAGES/tali.mo
+share/locale/el/LC_MESSAGES/tali.mo
+share/locale/en@shaw/LC_MESSAGES/tali.mo
+share/locale/en_CA/LC_MESSAGES/tali.mo
+share/locale/en_GB/LC_MESSAGES/tali.mo
+share/locale/eo/LC_MESSAGES/tali.mo
+share/locale/es/LC_MESSAGES/tali.mo
+share/locale/et/LC_MESSAGES/tali.mo
+share/locale/eu/LC_MESSAGES/tali.mo
+share/locale/fa/LC_MESSAGES/tali.mo
+share/locale/fi/LC_MESSAGES/tali.mo
+share/locale/fr/LC_MESSAGES/tali.mo
+share/locale/ga/LC_MESSAGES/tali.mo
+share/locale/gl/LC_MESSAGES/tali.mo
+share/locale/gu/LC_MESSAGES/tali.mo
+share/locale/he/LC_MESSAGES/tali.mo
+share/locale/hi/LC_MESSAGES/tali.mo
+share/locale/hr/LC_MESSAGES/tali.mo
+share/locale/hu/LC_MESSAGES/tali.mo
+share/locale/id/LC_MESSAGES/tali.mo
+share/locale/is/LC_MESSAGES/tali.mo
+share/locale/it/LC_MESSAGES/tali.mo
+share/locale/ja/LC_MESSAGES/tali.mo
+share/locale/ka/LC_MESSAGES/tali.mo
+share/locale/kk/LC_MESSAGES/tali.mo
+share/locale/km/LC_MESSAGES/tali.mo
+share/locale/kn/LC_MESSAGES/tali.mo
+share/locale/ko/LC_MESSAGES/tali.mo
+share/locale/ku/LC_MESSAGES/tali.mo
+share/locale/lt/LC_MESSAGES/tali.mo
+share/locale/lv/LC_MESSAGES/tali.mo
+share/locale/mai/LC_MESSAGES/tali.mo
+share/locale/mk/LC_MESSAGES/tali.mo
+share/locale/ml/LC_MESSAGES/tali.mo
+share/locale/mn/LC_MESSAGES/tali.mo
+share/locale/mr/LC_MESSAGES/tali.mo
+share/locale/ms/LC_MESSAGES/tali.mo
+share/locale/nb/LC_MESSAGES/tali.mo
+share/locale/ne/LC_MESSAGES/tali.mo
+share/locale/nl/LC_MESSAGES/tali.mo
+share/locale/nn/LC_MESSAGES/tali.mo
+share/locale/oc/LC_MESSAGES/tali.mo
+share/locale/or/LC_MESSAGES/tali.mo
+share/locale/pa/LC_MESSAGES/tali.mo
+share/locale/pl/LC_MESSAGES/tali.mo
+share/locale/pt/LC_MESSAGES/tali.mo
+share/locale/pt_BR/LC_MESSAGES/tali.mo
+share/locale/ro/LC_MESSAGES/tali.mo
+share/locale/ru/LC_MESSAGES/tali.mo
+share/locale/rw/LC_MESSAGES/tali.mo
+share/locale/si/LC_MESSAGES/tali.mo
+share/locale/sk/LC_MESSAGES/tali.mo
+share/locale/sl/LC_MESSAGES/tali.mo
+share/locale/sq/LC_MESSAGES/tali.mo
+share/locale/sr/LC_MESSAGES/tali.mo
+share/locale/sr@latin/LC_MESSAGES/tali.mo
+share/locale/sv/LC_MESSAGES/tali.mo
+share/locale/ta/LC_MESSAGES/tali.mo
+share/locale/te/LC_MESSAGES/tali.mo
+share/locale/tg/LC_MESSAGES/tali.mo
+share/locale/th/LC_MESSAGES/tali.mo
+share/locale/tr/LC_MESSAGES/tali.mo
+share/locale/ug/LC_MESSAGES/tali.mo
+share/locale/uk/LC_MESSAGES/tali.mo
+share/locale/vi/LC_MESSAGES/tali.mo
+share/locale/wa/LC_MESSAGES/tali.mo
+share/locale/xh/LC_MESSAGES/tali.mo
+share/locale/zh_CN/LC_MESSAGES/tali.mo
+share/locale/zh_HK/LC_MESSAGES/tali.mo
+share/locale/zh_TW/LC_MESSAGES/tali.mo
+share/tali/gnome-dice-1.svg
+share/tali/gnome-dice-2.svg
+share/tali/gnome-dice-3.svg
+share/tali/gnome-dice-4.svg
+share/tali/gnome-dice-5.svg
+share/tali/gnome-dice-6.svg
+share/tali/gnome-dice-none.svg
+share/tali/kismet-none.svg
+share/tali/kismet1.svg
+share/tali/kismet2.svg
+share/tali/kismet3.svg
+share/tali/kismet4.svg
+share/tali/kismet5.svg
+share/tali/kismet6.svg