aboutsummaryrefslogtreecommitdiff
path: root/games/tbe/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2010-11-08 21:46:57 +0000
committerJohan van Selst <johans@FreeBSD.org>2010-11-08 21:46:57 +0000
commit425b7ee4ebf77a83be3703e1670d0db8fd0703f5 (patch)
tree1f49ad865a4ef95d718bf7e73d93809406e36d5c /games/tbe/Makefile
parent1ba9a26bb7f5900f1834447a125e579ead1b61b4 (diff)
downloadports-425b7ee4ebf77a83be3703e1670d0db8fd0703f5.tar.gz
ports-425b7ee4ebf77a83be3703e1670d0db8fd0703f5.zip
Notes
Diffstat (limited to 'games/tbe/Makefile')
-rw-r--r--games/tbe/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/games/tbe/Makefile b/games/tbe/Makefile
new file mode 100644
index 000000000000..5dff95a180ca
--- /dev/null
+++ b/games/tbe/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: tbe
+# Date created: 7 November 2010
+# Whom: johans
+#
+# $FreeBSD$
+#
+
+PORTNAME= tbe
+PORTVERSION= M7
+CATEGORIES= games
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PORTNAME}/Milestone%20${PORTVERSION:S/M//}
+DISTNAME= TheButterflyEffect-${PORTVERSION}.src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= johans@FreeBSD.org
+COMMENT= The Butterfly Effect
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
+
+USE_GMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= qmake corelib gui moc rcc svg uic xml
+WRKSRC= ${WRKDIR}/TheButterflyEffect-${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} 's/ make/ ${GMAKE}/' \
+ ${WRKSRC}/3rdParty/Makefile
+ @${REINPLACE_CMD} 's/debug/release link_prl/' ${WRKSRC}/tbe.pro
+ @${REINPLACE_CMD} 's:BINARY_DIRECTORY+":"${DATADIR}:' \
+ ${WRKSRC}/src/tbe_global.h
+
+pre-build:
+ # This is supposedly done by the ./configure script
+ @cd ${WRKSRC}/3rdParty && ${GMAKE}
+ @cd ${WRKSRC} && ${QMAKE}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${MKDIR} ${DATADIR}
+ @cd ${WRKSRC} && ${PAX} -rw images levels ${DATADIR}
+
+.include <bsd.port.mk>