aboutsummaryrefslogtreecommitdiff
path: root/games/tbe
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-02-05 19:39:39 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-02-05 19:39:39 +0000
commita123b618c333b944162f4ab7bd37cdee2e557aba (patch)
tree3a42378e286b75faab907b6080682bbc07a722ea /games/tbe
parent0a73097383b2b02edbfdc91dea52a3b3947c6760 (diff)
downloadports-a123b618c333b944162f4ab7bd37cdee2e557aba.tar.gz
ports-a123b618c333b944162f4ab7bd37cdee2e557aba.zip
Notes
Diffstat (limited to 'games/tbe')
-rw-r--r--games/tbe/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/games/tbe/Makefile b/games/tbe/Makefile
index 74f3e6a6fb02..98a643927990 100644
--- a/games/tbe/Makefile
+++ b/games/tbe/Makefile
@@ -11,10 +11,9 @@ MAINTAINER= johans@FreeBSD.org
COMMENT= The Butterfly Effect
BUILD_DEPENDS= ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip
-LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
-USES= qmake
-USE_GMAKE= yes
+USES= qmake gmake
USE_QT4= corelib gui moc_build rcc_build svg uic_build xml
WRKSRC= ${WRKDIR}/TheButterflyEffect-M${PORTVERSION}rc3
@@ -25,7 +24,6 @@ DESKTOP_ENTRIES="The Butterfly Effect" "Inspired by The Incredible Machine" \
"${DATADIR}/images/tbe-icon.png" \
"${PREFIX}/bin/tbe" "LogicGame;Game;" false
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} 's/ make/ ${GMAKE}/' \
${WRKSRC}/3rdParty/Makefile
@@ -40,12 +38,8 @@ pre-configure:
@cd ${WRKSRC}/3rdParty && ${GMAKE}
do-install:
- @${MKDIR} ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
- @${MKDIR} ${DATADIR}
- @cd ${WRKSRC} && ${PAX} -rw images levels ${DATADIR}
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/bin ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ cd ${WRKSRC} && ${PAX} -rw images levels ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>